Go Back   Computer Forums > Web Design | Website Development > Web Programming
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-17-2006, 10:37 PM   #1
Baseband Member
 
jonny912's Avatar
 
Join Date: Jun 2006
Posts: 80
Send a message via MSN to jonny912
Default Flash and Frames

Hi. I'm building a whole website using a flash navbar and logo, an the rest in HTML. I am using frames for one of my pages in order to integrate an IBP forum webiste. I have a frame for the logo (at top) one for the nav bar (column left) and one for the forums (rest of page). When I preview the forum page from Dreamweaver everything looks great but when I try to enter another page from the nav bar the forum frame remains inplace while the other two change to the correct page. I'm not sure why it does this and am wondering if anyone knows a fix for this. Heres the code. Save it into an HTML doc to view it.

Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-frameset.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Untitled Document</title>
</head>

<frameset rows="80,*" cols="*" frameborder="no" border="0" framespacing="0">
  <frame src="UntitledFrame-2.html" name="topFrame" scrolling="No" noresize="noresize" id="topFrame" title="topFrame" />
  <frameset rows="356*" cols="182,*" framespacing="0" frameborder="no" border="0">
    <frame src="UntitledFrame-3.html" name="leftFrame" scrolling="No" noresize="noresize" id="leftFrame" title="leftFrame" />
    <frame src="http://s10.invisionfree.com/Uber_Knights/index.php?act=idx" name="mainFrame" id="mainFrame" scrolling="auto" noresize="noresize" title="mainFrame" />

  </frameset>
</frameset>
<noframes><body>
</body>
</noframes></html>
I'm developing locally so it wont work that well (links to files on my HDD.)
Is this a problem with my navbar? I noticed in the flash builder were the links will open (_self _blank _parent _top) Should I change one of these?

Heres two screenshots to illustrate my problem more clearly.
Sorry there kinda big, if thats a prob just say so and I'll put them on a seperate web page.


when the join button is clicked (which links to join.htm of which has no frames) it goes to this:

So the nav bar and the logo on top change correctly but the main frame remains.
Anyone?
Thx in advance.
__________________

__________________
Computers are like air conditioners, they break when you open windows.
jonny912 is offline   Reply With Quote
Old 11-18-2006, 04:21 AM   #2
In Runtime
 
jamieoliver22's Avatar
 
Join Date: Apr 2004
Posts: 245
Default Re: Flash and Frames

You need to change the link to "_parent" for it to work properly.

But to be honest, iframes are dying breed and can cause problems. They never usually display things that well (mainly if you have lots of them).

The best thing is, is to use some PHP include scripts. They are more versatile and can be a lot easier to work with.
__________________

__________________
Desktop: AMD Athlon XP 2000+ - 1.6ghz | MSI KT4-Ultra Motherboard |ATI Radeon Powercolor x850 XT 256mb DDR3 | 400gb HDD space |1gb PC2700 DDR SDRAM.
---
Laptop: AMD Sempron 3200+ - 1.6ghz | ATI Radeon Xpress 1100 - 128mb | 100gb PATA HDD | 1gb DDR2 RAM.
jamieoliver22 is offline   Reply With Quote
Old 11-18-2006, 04:38 PM   #3
Baseband Member
 
jonny912's Avatar
 
Join Date: Jun 2006
Posts: 80
Send a message via MSN to jonny912
Default Re: Flash and Frames

Ok thanks.
Am i really using iframes because my code is <frameset> not <iframe> ?
I'll look up that thing on PHP.
__________________
Computers are like air conditioners, they break when you open windows.
jonny912 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 02:43 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0