Go Back   Computer Forums > General Computing > Software and Operating Systems
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-02-2011, 12:05 AM   #1
Daemon Poster
 
GibsonSGKing's Avatar
 
Join Date: Jan 2009
Posts: 1,384
Default Ubuntu goof'd my bootloader

Ok, I had Vista installed. Then I installed 7 on another partition. Then I decided I didn't use Vista, so I formatted the partition and slapped Ubuntu on it. Now I can't get back into windows7. I've tried the install disk/restore windows option, but it doesn't detect my Windows install. I know that I didn't format the partition though, as I've been pulling some files from it now and then under Linux. Help? I'm at a bit of a loss right now...
__________________

__________________
C2Q Q9400 @ 3.2GHZ | Zalman 9900 LED HeatSink | Asus P5E3 Pro Motherboard | CM Storm Scout case | 1TB Caviar Black HDD | GTX760 4GB | 23" Acer [1920x1080] & 21.6" Asus [1920x1080] monitors
GibsonSGKing is offline   Reply With Quote
Old 05-02-2011, 12:15 AM   #2
Beta Member
 
fritolay's Avatar
 
Join Date: May 2011
Posts: 2
Default Re: Ubuntu goof'd my bootloader

This might help.
How to install Grub from a live Ubuntu cd. - Ubuntu Forums
__________________

fritolay is offline   Reply With Quote
Old 05-02-2011, 12:18 AM   #3
Daemon Poster
 
GibsonSGKing's Avatar
 
Join Date: Jan 2009
Posts: 1,384
Default Re: Ubuntu goof'd my bootloader

Quote:
Originally Posted by fritolay View Post
Uhm... how? I think I may be missing something here. I'm trying to get Win7 to boot, obviously the Grub loader is fine if I'm getting into Linux.
__________________
C2Q Q9400 @ 3.2GHZ | Zalman 9900 LED HeatSink | Asus P5E3 Pro Motherboard | CM Storm Scout case | 1TB Caviar Black HDD | GTX760 4GB | 23" Acer [1920x1080] & 21.6" Asus [1920x1080] monitors
GibsonSGKing is offline   Reply With Quote
Old 05-02-2011, 02:17 AM   #4
Baseband Member
 
dustin88's Avatar
 
Join Date: Apr 2011
Posts: 24
Send a message via AIM to dustin88 Send a message via MSN to dustin88 Send a message via Yahoo to dustin88
Default Re: Ubuntu goof'd my bootloader

your windows boot loader is missing, pop in your CD and use the fix windows portion of it or w/e it should detect it. if not there is another way

this may help How to use the Bootrec.exe tool in the Windows Recovery Environment to troubleshoot and repair startup issues in Windows its to help fix boot loading issues with boot recovery =)
dustin88 is offline   Reply With Quote
Old 05-02-2011, 05:23 AM   #5
Fully Optimized
 
~Darkseeker~'s Avatar
 
Join Date: Jan 2010
Location: Welwyn Garden City, United Kingdom
Posts: 2,494
Default Re: Ubuntu goof'd my bootloader

On Win7, you get the Recovery console on the disk

I believe, the command is this:

Quote:
fixboot c:
Then, you may or may not have to do

Quote:
bootcfg /rebuild
__________________
EVGA SLI Micro Z68 // Intel i5-2500k @ 4.4GHz // 8GB Corsair Vengeance 1866MHz // Overclocked ASUS GTX 660 Ti // Corsair Carbide SPEC-03 // Kingston Hyper-X 120GB // 2TB WD Green + 500GB WD Black
#JC4PM
~Darkseeker~ is offline   Reply With Quote
Old 05-02-2011, 02:18 PM   #6
Daemon Poster
 
GibsonSGKing's Avatar
 
Join Date: Jan 2009
Posts: 1,384
Default Re: Ubuntu goof'd my bootloader

I've tried that, but the install disk doesn't even recognize that I have Win7 installed.... I'm going to try Darkseeker's advice in a bit though, I'll see if that helps at all.

EDIT: Darkseeker, neither of those commands worked for me :S

I made the NTFS partition bootable, and tried restoring the Win7 install with the disk, and now I can't boot in to either. it just says "Reboot and Select proper Boot device
or Insert Boot Media in selected Boot device and press a key"

Now what do I do? :'(

I got the GRUB loader working again and can get into Ubuntu now. Still no 7 though
__________________
C2Q Q9400 @ 3.2GHZ | Zalman 9900 LED HeatSink | Asus P5E3 Pro Motherboard | CM Storm Scout case | 1TB Caviar Black HDD | GTX760 4GB | 23" Acer [1920x1080] & 21.6" Asus [1920x1080] monitors
GibsonSGKing is offline   Reply With Quote
Old 05-02-2011, 08:23 PM   #7
Beta Member
 
fritolay's Avatar
 
Join Date: May 2011
Posts: 2
Default Re: Ubuntu goof'd my bootloader

Quote:
Originally Posted by fritolay View Post
Sorry about that. This looks better.
[ubuntu] Can't see Windows 7 in grub - Ubuntu Forums
fritolay is offline   Reply With Quote
Old 05-02-2011, 10:24 PM   #8
Daemon Poster
 
GibsonSGKing's Avatar
 
Join Date: Jan 2009
Posts: 1,384
Default Re: Ubuntu goof'd my bootloader

I've fixed it. I have to reinstall everything, due to Win7 not being on a primary partition =/

It was imminent anyhow.
__________________
C2Q Q9400 @ 3.2GHZ | Zalman 9900 LED HeatSink | Asus P5E3 Pro Motherboard | CM Storm Scout case | 1TB Caviar Black HDD | GTX760 4GB | 23" Acer [1920x1080] & 21.6" Asus [1920x1080] monitors
GibsonSGKing is offline   Reply With Quote
Old 05-03-2011, 02:15 AM   #9
Baseband Member
 
dustin88's Avatar
 
Join Date: Apr 2011
Posts: 24
Send a message via AIM to dustin88 Send a message via MSN to dustin88 Send a message via Yahoo to dustin88
Default Re: Ubuntu goof'd my bootloader

=( sorry we weren't able to help, but on the bright side, sometimes a fresh install is nice =) i do one every 3 months, jsut for a change, and the thrill of new....I'm weird i know
dustin88 is offline   Reply With Quote
Old 05-04-2011, 09:31 PM   #10
Daemon Poster
 
GibsonSGKing's Avatar
 
Join Date: Jan 2009
Posts: 1,384
Default Re: Ubuntu goof'd my bootloader

Quote:
Originally Posted by dustin88 View Post
=( sorry we weren't able to help, but on the bright side, sometimes a fresh install is nice =) i do one every 3 months, jsut for a change, and the thrill of new....I'm weird i know
It was kind of beyond help tbh *shrug*
__________________

__________________
C2Q Q9400 @ 3.2GHZ | Zalman 9900 LED HeatSink | Asus P5E3 Pro Motherboard | CM Storm Scout case | 1TB Caviar Black HDD | GTX760 4GB | 23" Acer [1920x1080] & 21.6" Asus [1920x1080] monitors
GibsonSGKing is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 07:50 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0