Go Back   Computer Forums > General Computing > Software and Operating Systems
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-02-2009, 05:43 AM   #1
Beta Member
 
Join Date: Nov 2009
Posts: 4
Default Im having problems with ATI graphics card...

I just bought the Radeon HD 4770 graphics card because my Nvidia 7900gs stopped working. I've never owned a ATI card but I did what everyone said remove all the old Nvidia software. So I installed the card just fine but I tried downloading the newest drivers from the ATI website everytime I run the thing to install my computer restarts. So I tried like 5 times and the same thing when it was about to install. So instead I put the disk that came with the card and it installed but now how to I upgrade to the new catalyst when I downloaded the one from the website and it wont install. Please help anyone who has an ATI card.

Also for reference if anyone has questions about my card mobo, power supply or past topic here it is

http://www.computerforums.org/showth...286#post990286

specs on my power supply is 550 watts. But I've had the rig for 2 years and I dont see how its going to crap out now.
__________________

Menasor is offline   Reply With Quote
Old 12-02-2009, 07:51 AM   #2
Omnicide now.
 
foothead's Avatar
 
Join Date: May 2009
Location: My own personal hell
Posts: 10,014
Default Re: Im having problems with ATI graphics card...

So you did remove all the old nvidia drivers?
Hmm... when you say it doesnt load the installer, do you mean nothing ever happens or does it crash, or what? Also, are you sure you have the right drivers for your OS, and architecture (32 vs. 64 bit OS)?
Either way, the 4770 has been out for quite a while, so I don't see it completely necessary to have the very newest drivers if you could get a previous one working.
__________________

foothead is offline   Reply With Quote
Old 12-02-2009, 01:38 PM   #3
In Runtime
 
Join Date: Dec 2009
Posts: 102
Default Re: Im having problems with ATI graphics card...

okay first ATI like Nvidia has alot of diff Board makers like XFX, HIS, ect which brand did you buy? dont use ATI drivetrs as they suck uninstall em and install your brands' drivers
Trueyears is offline   Reply With Quote
Old 12-02-2009, 04:16 PM   #4
Beta Member
 
Join Date: Nov 2009
Posts: 4
Default Re: Im having problems with ATI graphics card...

I have the XFX brand. Ok so I downloaded 9.11 version catalyst for my card and it wont install. It goes through the process of installing the folders and stuff and when its about to start installing it restarts. So I tried 9.10 and that installed without a problem.
Menasor is offline   Reply With Quote
Old 12-02-2009, 06:14 PM   #5
In Runtime
 
Join Date: Dec 2009
Posts: 102
Default Re: Im having problems with ATI graphics card...

Quote:
Originally Posted by Menasor View Post
I have the XFX brand. Ok so I downloaded 9.11 version catalyst for my card and it wont install. It goes through the process of installing the folders and stuff and when its about to start installing it restarts. So I tried 9.10 and that installed without a problem.
Hmm odd that could be you need to update all your hardware actually it can mean alot more LOL but thats good you got it working
Trueyears is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 05:01 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0