Go Back   Computer Forums > General Computing > Software and Operating Systems
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-28-2010, 10:39 AM   #1
In Runtime
 
Rakuma's Avatar
 
Join Date: Jun 2010
Posts: 197
Send a message via AIM to Rakuma
Default HD 5770 drivers

I recently bought a asus HD 5770 ati card for my comp and installed the drivers from the supplied disk. After that I went to ati's site and dl'd the newest catalyst drivers and attempted to install. When I started the install process I was able to Initialize the install but but when it got to the install new drivers portion it would close when I clicked on the add new drivers button. I have tried checking and updating all other computer drivers, removing old drivers before installing the latest, also removing all drivers and redownloading the drivers with no drivers installed yet I still face the same problem. I haven't been able to find anything about it on ASUS' forum or ATI's.

Comp:
Pentium 4
2gig ram
xp 32 bit.
__________________

Rakuma is offline   Reply With Quote
Old 06-28-2010, 11:24 AM   #2
BSOD
 
Join Date: Jun 2010
Posts: 504
Default Re: HD 5770 drivers

Have you tried installing in safe mode?
__________________

gmcrepair is offline   Reply With Quote
Old 06-28-2010, 12:51 PM   #3
In Runtime
 
Rakuma's Avatar
 
Join Date: Jun 2010
Posts: 197
Send a message via AIM to Rakuma
Default Re: HD 5770 drivers

I have not. I will give it a try when i get home from work today.
Rakuma is offline   Reply With Quote
Old 06-28-2010, 02:16 PM   #4
BSOD
 
Join Date: Jun 2010
Posts: 504
Default Re: HD 5770 drivers

Quote:
Originally Posted by Rakuma View Post
I have not. I will give it a try when i get home from work today.
Ok, let us know what happens, even if it works.
gmcrepair is offline   Reply With Quote
Old 06-28-2010, 07:23 PM   #5
In Runtime
 
Rakuma's Avatar
 
Join Date: Jun 2010
Posts: 197
Send a message via AIM to Rakuma
Default Re: HD 5770 drivers

Well i started up in safe mode and tried to install the drivers again and I had the same problem in non safe mode after selecting the language and then clicking the install button it once again did nothing. So I am at a loss.
Rakuma is offline   Reply With Quote
Old 06-29-2010, 02:16 AM   #6
BSOD
 
Join Date: Jun 2010
Posts: 504
Default Re: HD 5770 drivers

Quote:
Originally Posted by Rakuma View Post
Well i started up in safe mode and tried to install the drivers again and I had the same problem in non safe mode after selecting the language and then clicking the install button it once again did nothing. So I am at a loss.
Do you have administrative rights?
gmcrepair is offline   Reply With Quote
Old 06-29-2010, 10:20 AM   #7
In Runtime
 
Rakuma's Avatar
 
Join Date: Jun 2010
Posts: 197
Send a message via AIM to Rakuma
Default Re: HD 5770 drivers

Oh yeah started up in safe mode logged in under admin and not one of the other two names I have for my wife and I and still nothing. Its just weird because this if the first driver I have ever had trouble with. Mildly frustrating.
Rakuma is offline   Reply With Quote
Old 06-29-2010, 10:41 AM   #8
Fully Optimized
 
eslfish's Avatar
 
Join Date: Sep 2008
Posts: 1,604
Send a message via AIM to eslfish Send a message via MSN to eslfish Send a message via Yahoo to eslfish
Default Re: HD 5770 drivers

FYI. Don't bother installing from the disc, even though the card is new the drivers are outdated. Have you ever used Driver Sweep?

Check out Driver Sweep. Next time you install drivers just go directly to ATI's website.
__________________
XFIRE: Lindmando STEAM: Lindmando
Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz (2 CPUs), ~3.0GHz
4094MB RAM 500 GB HD ATI Radeon™ HD 5850 8800 GT
Windows 7 64-bit Ultimate
eslfish is offline   Reply With Quote
Old 06-29-2010, 03:23 PM   #9
In Runtime
 
Rakuma's Avatar
 
Join Date: Jun 2010
Posts: 197
Send a message via AIM to Rakuma
Default Re: HD 5770 drivers

Yeah I know that the drivers on the disk are outdated at the point of purchase. I haven't tried the driver sweep I will give it a whirl when i get home tonight. I take it the manual deleting of drivers is possibly not removing them properly? And Driver Sweep will make sure they are completely cleaned up?
Rakuma is offline   Reply With Quote
Old 07-08-2010, 03:42 PM   #10
In Runtime
 
Rakuma's Avatar
 
Join Date: Jun 2010
Posts: 197
Send a message via AIM to Rakuma
Default Re: HD 5770 drivers

Alright so this is bumped back up because after dealing with life I was able to d/l driver sweeper and run it which cleaned up most of the old nvidia drivers but one pesky file remains and I can't seem to get it to go away. When I run driver sweeper on that file and reboot it brings up a msdos command screen that has C:/NVIDIA/ yes or no? And I still can't get the current drivers to install. Starting to get to the hair pulling stage of frustration hah.
__________________

Rakuma is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 06:29 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0