Go Back   Computer Forums > General Computing > Software and Operating Systems
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-27-2017, 11:31 AM   #1
Baseband Member
 
Join Date: May 2012
Location: Canada
Posts: 78
Default Do I have .NET Framework 3.5 SP1

Hello,

I have an application called VisionClient. When I try to start it, it gives me an error message:

"To run Vision 6.2, you must first install Microsoft .NET Framework 3.5 SP1 on your workstation..."

I'm certain that I have .NET Framework 3.5 installed. This is what the Windows Features dialog looks like:



I'm not sure I have SP1 installed. I went to:

https://www.microsoft.com/en-ca/down...ils.aspx?id=22

...to download SP1. It downloaded dotnetfx35setup.exe. I ran it. It asked for administrator permissions. I said yes. Then nothing happened.

I have no idea whether it worked or not, but I'm still getting the same message from VisionClient.

How can I tell if I have .NET Framework 3.5 with SP1 installed? If I don't have it installed, how can I get it installed (obviously, the methods I tried didn't work).

This happens on two computers: Windows 10 and Windows 7
__________________

__________________
gib88 is offline   Reply With Quote
Old 03-27-2017, 01:51 PM   #2
Fully Optimized
 
crazyman143's Avatar
 
Join Date: May 2004
Location: USA
Posts: 2,963
Default Re: Do I have .NET Framework 3.5 SP1

Try running this from command line:

Quote:
DISM /Online /Enable-Feature /FeatureName:NetFx3 /All
__________________

__________________
crazyman143 is offline   Reply With Quote
Old 03-27-2017, 08:04 PM   #3
Baseband Member
 
Join Date: May 2012
Location: Canada
Posts: 78
Default Re: Do I have .NET Framework 3.5 SP1

Done.

It said the operation completed successfully.

Does that mean I have .NET 3.5 with service pack 1?
__________________
gib88 is offline   Reply With Quote
Old 03-27-2017, 10:23 PM   #4
Fully Optimized
 
crazyman143's Avatar
 
Join Date: May 2004
Location: USA
Posts: 2,963
Default Re: Do I have .NET Framework 3.5 SP1

I believe so. What are you trying to use that requires .net 3.5? does it work?
__________________
crazyman143 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 05:10 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0