Go Back   Computer Forums > Welcome To Computer Forums .org > Social Lounge | Off Topic
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-08-2007, 10:37 PM   #11
Fully Optimized
 
Join Date: Oct 2005
Location: 1
Posts: 2,525
Default Re: So I was on YouTube...

Get The Fucking Bag Off My Head!
__________________

Ronco Rox is offline   Reply With Quote
Old 12-08-2007, 10:39 PM   #12
Fully Optimized
 
Juice's Avatar
 
Join Date: Apr 2007
Posts: 2,946
Send a message via AIM to Juice Send a message via MSN to Juice
Default Re: So I was on YouTube...

It was so real, I felt the hair on the back of my neck stand up when he cut the back of my head
__________________

__________________
Juice
P4 2.4GHz, 1.5Gb, 40Gb.
PowerBook G4 867MHz, 1Gb, 60Gb.
Juice is offline   Reply With Quote
Old 12-08-2007, 10:59 PM   #13
Bogan
 
Neodude112320's Avatar
 
Join Date: Feb 2006
Location: Australia
Posts: 8,471
Send a message via MSN to Neodude112320
Default Re: So I was on YouTube...

Dam! Im breathless lol.....Wow......
__________________
Desktop:BitFenix Survivor~Gigabyte GA-P67A-UD3R~ i7 2600K @ 4hz~AMD 6870 1GB~12gb Team Elite DDR3 1333~3xWD In RAID5~W7 Ult
Laptop:Alienware M11x~ i7-2637M 1.7GHz~16GB 1333MHz DDR3~GeForce GT 540M~W7 Ult
Neodude112320 is offline   Reply With Quote
Old 12-09-2007, 12:04 AM   #14
Golden Master
 
Rubber314Chicken's Avatar
 
Join Date: Mar 2006
Posts: 5,574
Send a message via AIM to Rubber314Chicken
Default Re: So I was on YouTube...

that was crazy. I think I'm bald now, I did it like 3 times. I really need better headphones.
__________________
AMD Athlon 64X2 4200+, 2 GB ram, 2 TB HDD, Ubuntu+SAMBA ♫ Lenovo T410, i5@ 2.4 GHz, 4 GB ram, 7
Rubber314Chicken is offline   Reply With Quote
Old 12-09-2007, 12:11 AM   #15
Fully Optimized
 
DefCon_!1!'s Avatar
 
Join Date: Dec 2007
Posts: 1,733
Send a message via AIM to DefCon_!1! Send a message via MSN to DefCon_!1!
Default Re: So I was on YouTube...

ya...i have 5.1 headphones....but i can only plug in the cord for the center cause my soundcard....so stuff wasent as good as it could be...but stillllfrekin awsome......and creepy
__________________
Gigabyte Z68X-UD4
i5 2500k 4.5ghz with H100 Cooling
2x 560ti @ 950mhz
DefCon_!1! is offline   Reply With Quote
Old 12-09-2007, 01:15 AM   #16
Fully Optimized
 
Bahawolf's Avatar
 
Join Date: May 2005
Location: United States
Posts: 2,604
Default Re: So I was on YouTube...

That was amazing.. wow.
Bahawolf is offline   Reply With Quote
Old 12-09-2007, 02:01 AM   #17
In Runtime
 
Join Date: Mar 2007
Posts: 383
Default Re: So I was on YouTube...

When he whispered that freaked me out.
pooker is offline   Reply With Quote
Old 12-09-2007, 05:08 AM   #18
Daemon Poster
 
Join Date: Aug 2007
Posts: 878
Default Re: So I was on YouTube...

oh man that sucks for me cause I had these really nice Sony headphones that lasted me something like 2 years or more I think and they died on like Friday, I was like what the hell, suddenly just stopped working lol I'll have to watch this soon... with a pair of crappy replacements. Interesting find though, Youtube owns.
Thrasher is offline   Reply With Quote
Old 12-10-2007, 06:45 PM   #19
Fully Optimized
 
Jesusfrk611's Avatar
 
Join Date: Feb 2005
Location: US
Posts: 2,193
Default Re: So I was on YouTube...

I listened to this so many times now, lol. It's pretty cool. I got kinda scared when he said "nice and sharp" about the scissors. I would be out the door if a real barber said that... The snaps sounded like they were very real, and the whisper sounded real as well.
Jesusfrk611 is offline   Reply With Quote
Old 12-10-2007, 08:17 PM   #20
Bogan
 
Neodude112320's Avatar
 
Join Date: Feb 2006
Location: Australia
Posts: 8,471
Send a message via MSN to Neodude112320
Default Re: So I was on YouTube...

Although,if you had good enough microphones and some stands you could easily do it your self.
__________________

__________________
Desktop:BitFenix Survivor~Gigabyte GA-P67A-UD3R~ i7 2600K @ 4hz~AMD 6870 1GB~12gb Team Elite DDR3 1333~3xWD In RAID5~W7 Ult
Laptop:Alienware M11x~ i7-2637M 1.7GHz~16GB 1333MHz DDR3~GeForce GT 540M~W7 Ult
Neodude112320 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 09:38 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0