Go Back   Computer Forums > Welcome To Computer Forums .org > Social Lounge | Off Topic
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-03-2007, 11:41 PM   #1
BSOD
 
Join Date: Apr 2005
Posts: 6,556
Send a message via MSN to Rudster816
Default My Story...

Well today was the day that my 8800GTS 320MB and my 650 Watt Rosewill PSU was supposed to arrive. it was nearly 7PM and my stuff still wasnt here. then my mom tracked it and it said it was delevired to the front door even though we hadnt got it.. then my mom notices a black car driving house to house near ours, surely this is someone looking to drop off something, i flagged her down and it was a UPS driver in a sedan. she said that there were so many packages to deliver today she decided to help with this one because she lived in there area and took the package(signing for it) and delivered to us. great service IMO.

well i quickly set the thing up having to remove a custom fan i put on the drive bay covers to be able to store all of the cables. well i booted up everything worked first try hooray! i started to install my driver's looked like it froze so i pulled out the CD and then soon as it was out it said installtion complete and you must restart. probably didnt work but lets resart and see, clicked reboot everything normal. booted up into windows again and as soon the drivers took effect(the fan on the card revved up) my computer shut down. i tried to turn it back on, fans and lights were on for just a couple of seconds then it shutdown again. ok i have tons of custom power adapters that i have spliced and what not so i unplug those items, same thing, unplug everything expect for my video card, same thing. then i unplugged the video card pci-e thing and the video card makes a screacing sound of death so i turned it off before anything else blew up. disconnected the psu and put it up on my work bench and shorted the green wire and a ground, flipped the switch, nothing not even a sign of life, totaly dead.

now i face the choice of returning it to newegg and getting my money back OR RMAing it to Rosewill to try another PSU. i would get 20$ from the return because i bought both products as a combo deal with a 20$ disscount. now i hope to god my PSU dieing didnt fry my video card.

im not really mad just sad very sad

on a higher note im 99% sure im giving my old card an ATi Radon 9250 to muz

EDIT:
i cant return for a refund so i have to get the same PSU
__________________

Rudster816 is offline   Reply With Quote
Old 08-04-2007, 12:51 AM   #2
Fully Optimized
 
CompMan's Avatar
 
Join Date: Aug 2006
Posts: 3,323
Send a message via AIM to CompMan
Default Re: My Story...

Wow dude I'm sorry to hear that.

You could always send the card down this way and I can test it for ya!

lol j.k but I hope you get it sorted!
__________________

__________________
|Intel Q6600@3.0ghz||ASUS MAXIMUS FORMULA||2GiG Corsair XM2 DDR2 800||EvGa 8800GTS||36gig Western Digital Raptor 10,000 rpm||Ultra X2 connect 550W modular psu||Thermaltake Tsunami Case|Vista 64bit|
Windows has Blue screens, Mac has grey screens, and CF has White screens!!
2004 Mazda RX-8 GT Titanium Grey, Greddy Exhaust, AEM cold air intake
--objects in rearview get smaller with each shift--
CompMan is offline   Reply With Quote
Old 08-04-2007, 02:14 AM   #3
Golden Master
 
alvino's Avatar
 
Join Date: Sep 2004
Posts: 19,967
Send a message via AIM to alvino
Default Re: My Story...

Not to rain on your parade, but that's why I don't buy Rosewill PSU's. They're just not that great. Might be attractive in pricing, but I'd rather pay good money for something as important as a PSU.
alvino is offline   Reply With Quote
Old 08-04-2007, 04:27 AM   #4
BSOD
 
Join Date: Apr 2005
Posts: 6,556
Send a message via MSN to Rudster816
Default Re: My Story...

Quote:
Originally Posted by alvino View Post
Not to rain on your parade, but that's why I don't buy Rosewill PSU's. They're just not that great. Might be attractive in pricing, but I'd rather pay good money for something as important as a PSU.
i did really. i was going to get the 550 watt then i decided that it wouldnt provide enough juice in the road ahead to be worth it so i bought the 650 watt combo. worst comes to worst i could refund my RMA and get a new one but i dont want to pay to re ship everything again etc. i totaly skipped rosewill customer service and went staight threw newegg dont want to deal with someone who might not take it back
Rudster816 is offline   Reply With Quote
Old 08-04-2007, 05:19 AM   #5
Fully Optimized
 
Join Date: Nov 2006
Posts: 3,629
Send a message via AIM to ߧ∩H♠H䎀
Default Re: My Story...

Ouch that sucks. Guess you gotta wait some more.
ߧ∩H♠H䎀 is offline   Reply With Quote
Old 08-04-2007, 07:45 AM   #6
muz
Golden Master
 
muz's Avatar
 
Join Date: Oct 2006
Posts: 6,928
Default Re: My Story...

Thats just gotta suck . Still i hope the 8800 isn't damaged cos that would suck even harder . Do you have another psu you could test it with to check the card
On another note i dunno how us plugs work but is there a fuse in the plug cos i had a psu that i thought was bad and i changed the fuse in the plug and it fixed it again
__________________
Desktop-AMD Athlon 64 X2 6000+-2GB Elixer DDR2 800 250gb+500gb+500gb+120gb
Laptop-Apple Macbook Pro 13" Intel core i5(2.3ghz) 4gb Ram 320gb hard drive
muz is offline   Reply With Quote
Old 08-04-2007, 07:53 AM   #7
BSOD
 
Join Date: Apr 2005
Posts: 6,556
Send a message via MSN to Rudster816
Default Re: My Story...

no fuses in the plug but thats what my dad said, that it might have blown a fuse but im not going to void my warrenty by cracking it open.
i just tested it in a 480 watt 16Amp PSU, my splash screen came up all dimmed but it appeared correctly so i dont think the core was damaged. it does suck royally, im going to try to use 2 psu's the one i just mentioned to supply just the 8800 and another for the rest of the crap.

funny because i just relized my crap 480 watt psu that came with a 40$ case held up against the 8800 for a little while but a 90$ 650 watt 39amp single rail couldnt hold under a little bit of load. damn i wish i could get my money back instead of a new psu then i could buy a 550ish OCZ. im thinking about working for my mom this weekend and seeing if i can pay to overnight it here on its way back.
Rudster816 is offline   Reply With Quote
Old 08-04-2007, 01:09 PM   #8
Golden Master
 
Join Date: Mar 2005
Posts: 13,091
Default Re: My Story...

Never buy Rosewill PSUs. They have the most horrible reliability I've ever seen.
lhuser is offline   Reply With Quote
Old 08-04-2007, 01:10 PM   #9
BSOD
 
Join Date: Apr 2005
Posts: 6,556
Send a message via MSN to Rudster816
Default Re: My Story...

Quote:
Originally Posted by lhuser View Post
Never buy Rosewill PSUs. They have the most horrible reliability I've ever seen.
so does there site
http://www.rosewill.com/
Rudster816 is offline   Reply With Quote
Old 08-04-2007, 01:21 PM   #10
Golden Master
 
Join Date: Mar 2005
Posts: 13,091
Default Re: My Story...

Never been a fan of those POS family anyways.
__________________

lhuser is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 09:33 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0