Go Back   Computer Forums > General Computing > Server Administration
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-28-2010, 07:20 PM   #1
Daemon Poster
 
r_moore04's Avatar
 
Join Date: Oct 2005
Posts: 737
Send a message via MSN to r_moore04
Default remote desktop

im studying for my next microsoft exam so messing a little

i have vmware server installed and on that im running two server 2003 servers and an win xp

server 1 is a DC with DNS and DHCP installed and also routing and remote access

server 2 is a file server and has IIS installed on it

server 1 has two NIC cards one for my house netgear router (internet) and the other 1 is connected 2 DHCP on the server

my problem is that i was able to connect to server 1 from my laptop using the netgear lan ip which is 192.168.0.23, ever since i put server 2 on the domain im unable to connect to server 1 using the ip of 192.168.0.23 but its still on the internet, the only way i can connect is to connect to the network using VPN and then it will allow me to connect using the DHCP server ip address of 10.0.1.1, i want to no how i can connect to the server again using 192.168.0.23
__________________

__________________
Microsoft Certified IT Professional (MCITP)
MCP,MOS,MCDST,MCSA,MCITP,MCTS
r_moore04 is offline   Reply With Quote
Old 07-29-2010, 12:47 PM   #2
Site Team
 
root's Avatar
 
Join Date: Mar 2004
Posts: 8,003
Default Re: remote desktop

what is the output of ipconfig /all on server 1?

I'm going to guess that you've got something like

nic 1
IP 192.168.0.23
Subnet 255.255.255.0
Gateway 192.168.0.1

nic 2
IP 10.0.1.1
subnet 255.0.0.0
Gateway 10.0.1.1

if that's the case, try removing the gateway from nic 2.

Also check firewall rules (on the server) to make sure that RDP connections aren't being blocked on the server by the windows firewall installed on the server
__________________

__________________
I didn’t fight my way to the top of the food chain to be a vegetarian…
Im sick of people saying 'dont waste paper'. If trees wanted to live, they'd all carry guns.
"The inherent vice of capitalism is the unequal sharing of blessings; The inherent vice of socialism is the equal sharing of miseries."
root is offline   Reply With Quote
Old 07-30-2010, 06:15 AM   #3
Daemon Poster
 
r_moore04's Avatar
 
Join Date: Oct 2005
Posts: 737
Send a message via MSN to r_moore04
Default Re: remote desktop

yeh that is the output from ipconfig/all and removing the gateway from nic2 didnt work, its something to do with routing and remote access, if i go into services and stop the routing and remote access service i can connect to server 1 using remote desktop but as soon as i turn it back on i cant connect
__________________
Microsoft Certified IT Professional (MCITP)
MCP,MOS,MCDST,MCSA,MCITP,MCTS
r_moore04 is offline   Reply With Quote
Old 08-02-2010, 04:23 AM   #4
Site Team
 
root's Avatar
 
Join Date: Mar 2004
Posts: 8,003
Default Re: remote desktop

ok,
well, leave the gateway off anyway, you should only really have one route configured anyway.

have you investigated the firewall to see if the ports are open on the nic1 interface?
__________________
I didn’t fight my way to the top of the food chain to be a vegetarian…
Im sick of people saying 'dont waste paper'. If trees wanted to live, they'd all carry guns.
"The inherent vice of capitalism is the unequal sharing of blessings; The inherent vice of socialism is the equal sharing of miseries."
root is offline   Reply With Quote
Old 08-02-2010, 08:46 AM   #5
Daemon Poster
 
r_moore04's Avatar
 
Join Date: Oct 2005
Posts: 737
Send a message via MSN to r_moore04
Default Re: remote desktop

iv fixed it now, went into routing and remote access and clicked on NAT/Basic Firewall and right clicked on NIC1 and clicked properties and unticked the box "enable a basic firewall on this interface" and it now works, but i tick the box it gets blocked again
__________________
Microsoft Certified IT Professional (MCITP)
MCP,MOS,MCDST,MCSA,MCITP,MCTS
r_moore04 is offline   Reply With Quote
Old 08-02-2010, 12:45 PM   #6
Site Team
 
root's Avatar
 
Join Date: Mar 2004
Posts: 8,003
Default Re: remote desktop

you should be able to leave the firewall enabled and just leave TCP 3389 open for inbound connections.
__________________
I didn’t fight my way to the top of the food chain to be a vegetarian…
Im sick of people saying 'dont waste paper'. If trees wanted to live, they'd all carry guns.
"The inherent vice of capitalism is the unequal sharing of blessings; The inherent vice of socialism is the equal sharing of miseries."
root is offline   Reply With Quote
Old 08-02-2010, 01:54 PM   #7
Daemon Poster
 
r_moore04's Avatar
 
Join Date: Oct 2005
Posts: 737
Send a message via MSN to r_moore04
Default Re: remote desktop

yeh just done that, its on the same tab as the other setting, iv set an inbound filter for the port 3389, and put the firewall back on and its still works
__________________

__________________
Microsoft Certified IT Professional (MCITP)
MCP,MOS,MCDST,MCSA,MCITP,MCTS
r_moore04 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 07:39 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0