Go Back   Computer Forums > General Computing > Programming
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-30-2010, 08:33 PM   #1
Baseband Member
 
Shazer2's Avatar
 
Join Date: May 2009
Posts: 89
Default Perl problem

Alright, I have that code but when I try to execute it, it has an error
message of:

Unrecognized character \XA0; Marked by <-- HERE after <-- HERE near column 1 at backup.pl line 10


Just wondering if anyone knows what the problem is?

Code:
use strict;
use warnings;

my $startDir = 'C:\Documents and Settings\Shannon\Desktop\SETUPS AND FILES';
my $newDir = 'G:\BACKUP';

myReadDir($startDir);

sub myReadDir {
***my ($dir) = @_;****
***opendir (DIR, $dir);
***my @dir = readdir (DIR);
***closedir(DIR);
***foreach my $file (@dir)**{
******next if ($file eq '.' or $file eq '..');
******if (-d $file) {
*********print "$file is a directory\n";
*********myReadDir("$dir/$file");
******}
***}************
}
The asterix's are spaces so yeah
__________________
Need some PHP questions answered? Give me a PM and I will see what I can do.
Shazer2 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 04:14 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0