Go Back   Computer Forums > General Computing > Programming
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-15-2010, 02:13 PM   #1
Daemon Poster
 
Join Date: May 2009
Posts: 690
Default embed help

I use this tag and it works
<embed src="beach.wav" autostart="true" loop="6"></embed>

But it just puts a Black Box for I gess the player.
Can I ad a Width and Height attribute to make it show a player or what do I do???

It plays the sound for my website great and it works
__________________

biferi is offline   Reply With Quote
Old 07-16-2010, 11:24 AM   #2
Site Team
 
berry120's Avatar
 
Join Date: Jul 2009
Location: England, UK
Posts: 3,425
Default Re: embed help

No, if you want a player you're have to write / put that in separately, most likely in javascript.
__________________

__________________
Save the whales, feed the hungry, free the mallocs.
berry120 is offline   Reply With Quote
Old 07-16-2010, 11:33 AM   #3
Daemon Poster
 
Join Date: May 2009
Posts: 690
Default Re: embed help

I need one more thing?

If I have this code
<embed src="beach.wav" autostart="true" loop="6"></embed>

In the top of the body tag or at the end of the body tag will it effect how long it take for the sound to play?

Or can I have it all the way at the end of my Body code you know right before the </body> tag??
biferi is offline   Reply With Quote
Old 07-16-2010, 11:41 AM   #4
Site Team
 
berry120's Avatar
 
Join Date: Jul 2009
Location: England, UK
Posts: 3,425
Default Re: embed help

It'll make no difference.

Incidentally, I hope you're not actually using this on a site people visit...!
__________________
Save the whales, feed the hungry, free the mallocs.
berry120 is offline   Reply With Quote
Old 07-16-2010, 01:10 PM   #5
Daemon Poster
 
Join Date: May 2009
Posts: 690
Default Re: embed help

every page has it's own theme so every page has a sound file.

I fegure most people today have DSL or Cable speed this will be ok?????????????????????
biferi is offline   Reply With Quote
Old 07-16-2010, 06:59 PM   #6
Site Team
 
berry120's Avatar
 
Join Date: Jul 2009
Location: England, UK
Posts: 3,425
Default Re: embed help

No, it's really not ok. From a technical / speed perspective you don't need to worry, but you're seriously, seriously going to annoy people if you start playing background music as soon as they load the page.

If I visited a site and it started spewing out some random sound, I wouldn't give it a second look (unless it was a site deliberately demonstrating the use of such a criminal tag!)
__________________
Save the whales, feed the hungry, free the mallocs.
berry120 is offline   Reply With Quote
Old 07-16-2010, 09:34 PM   #7
Daemon Poster
 
Join Date: May 2009
Posts: 690
Default Re: embed help

OK I understand what you are telling me but it is not music.

I sell Artwork and my FALL Gallery is for Halloween so I made my own background sound.

It is Rain and then Woves.

People seem to love it and every page has it's own theme.

I use this
<embed src="rain.wav" autostart="true" loop="true"></embed>
And it works great and plays the sound automaticly. But it just plays one time.

I tryed
<embed src="rain.wav" autostart="true" loop="6"></embed>
But it still plays one time??????????????????

Please help
biferi is offline   Reply With Quote
Old 07-17-2010, 04:14 AM   #8
Daemon Poster
 
Join Date: Jun 2004
Posts: 511
Send a message via AIM to Denthúl Send a message via MSN to Denthúl Send a message via Yahoo to Denthúl
Default Re: embed help

To get your player to show, try specifying height and width when you use the <embed> tag (for example, height=75 width=155). As for getting it to loop, try adding playcount=6 as well. It's been quite some time since I actually used this tag for anything, because it really is annoying as Hell when you come to a site with it, mind you.
Denthúl is offline   Reply With Quote
Old 07-17-2010, 12:28 PM   #9
Daemon Poster
 
Join Date: May 2009
Posts: 690
Default Re: embed help

Thanks for the help.
Adding the width and height did not put a player there I still have a black box but it does let me make the black box smaller.

And I did not understand what you ment when you told me try to ad the playcount=6 did you meen in place of Loop=6 or like this

<embed src="people.wav" width="70" height="55" autostart="true" playcount="6" loop="6"></embed>
biferi is offline   Reply With Quote
Old 07-17-2010, 03:46 PM   #10
Daemon Poster
 
Join Date: Jun 2004
Posts: 511
Send a message via AIM to Denthúl Send a message via MSN to Denthúl Send a message via Yahoo to Denthúl
Default Re: embed help

Yeah, like in the example that you have.

Out of interest, which browser(s) are you trying this with?
__________________

Denthúl is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 06:48 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0