Go Back   Computer Forums > General Computing > Networking | DNS
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-12-2011, 12:34 PM   #1
Solid State Member
 
Join Date: Apr 2011
Posts: 11
Default PXE booting ?

Ok I have setup a dhcp/tftp server. I am using Tftpd32 .

I have another computer on the network that supports PXE booting.
And it is enabled in the bios.

I am getting this on my boot up screen for the network booting machine
Code:
client ip 192.168.1.101 mask 255.255.255.0 dhcp ip 192.168.1.100
gateway ip: 192.168.1.1
PXE-E79: NBP is too big to fit in free base memory

PXE-MBF: Exiting Broadcom PXE ROM
And I am getting this in my log files on Tftpd32
Code:
Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 00:0B:DB:2B:0E:F4 [12/10 20:17:59.843]
Client requested address 0.0.0.108 [12/10 20:17:59.843]
DHCP: proposed address 192.168.1.101 [12/10 20:18:02.265]
Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 00:0B:DB:2B:0E:F4 [12/10 20:18:03.375]
Client requested address 0.0.0.108 [12/10 20:18:03.375]
DHCP: proposed address 192.168.1.101 [12/10 20:18:05.265]
1652 Request 2 not processed [12/10 20:18:05.265]
1652 Request 2 not processed [12/10 20:18:05.265]
Rcvd DHCP Rqst Msg for IP 0.0.0.0, Mac 00:0B:DB:2B:0E:F4 [12/10 20:18:05.640]
Previously allocated address 192.168.1.101 acked [12/10 20:18:05.640]
1652 Request 2 not processed [12/10 20:18:05.640]
Connection received from 192.168.1.101 on port 2070 [12/10 20:18:06.187]
Read request for file <myth.0>. Mode octet [12/10 20:18:06.187]
OACK: <tsize=676710400,> [12/10 20:18:06.187]
Using local port 2137 [12/10 20:18:06.187]
Peer returns ERROR <TFTP Aborted> -> aborting transfer [12/10 20:18:06.203]
I know at least that it is finding the dhcp/tftp service but is failing to load the image
myth.0 was an iso file that I got at distrowatch which I have used before.
(I renamed it to myth.0 because I didn't know if their was a special . extension I needed )

I am lost on how to get this working. What does the format of this disk image have to be floppy , cd ,...etc Is their any config files I need?
__________________

sam111 is offline   Reply With Quote
Old 10-13-2011, 03:39 AM   #2
Fully Optimized
 
BikerEcho's Avatar
 
Join Date: Feb 2011
Location: Denmark
Posts: 4,013
Default Re: PXE booting ?

your RIS server needs to be setup correctly else it wont work.
are you sure that you have correctly setup the RIS server. i have made a RIS server once, worked perfectly.
my teacher (i am an IT student) says that it can be a bit advanced to set it up correctly. so it might not be the file that is the problem.
__________________

__________________
MOBO: Asus Maximus 6 Hero - GPU: Gigabyte GTX 980ti xtreme - CPU: I7-4770K - PSU: Corsair AX760
RAM: Corsair Vantage 2x4GB - SSD: Samsung 840 EVO 512 + LiteOn LCS-256 - Case: NZXT H440
BikerEcho is offline   Reply With Quote
Old 10-13-2011, 07:30 AM   #3
Site Team
 
root's Avatar
 
Join Date: Mar 2004
Posts: 8,006
Default Re: PXE booting ?

Re: [Unattended] PXE-E79: NBP is too big to fit free base memory

that link may help you?
__________________
I didn’t fight my way to the top of the food chain to be a vegetarian…
Im sick of people saying 'dont waste paper'. If trees wanted to live, they'd all carry guns.
"The inherent vice of capitalism is the unequal sharing of blessings; The inherent vice of socialism is the equal sharing of miseries."
root is online now   Reply With Quote
Old 10-13-2011, 02:10 PM   #4
Solid State Member
 
SEOGlopex's Avatar
 
Join Date: Oct 2011
Posts: 6
Post Re: PXE booting ?

Quote:
Ok I have setup a dhcp/tftp server. I am using Tftpd32 . I have another computer on the network that supports PXE booting. And it is enabled in the bios. I am getting this on my boot up screen for the network booting machine Code: client ip 192.168.1.101 mask 255.255.255.0 dhcp ip 192.168.1.100 gateway ip: 192.168.1.1 PXE-E79: NBP is too big to fit in free base memory PXE-MBF: Exiting Broadcom PXE ROM And I am getting this in my log files on Tftpd32 Code: Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 00:0BB:2B:0E:F4 [12/10 20:17:59.843] Client requested address 0.0.0.108 [12/10 20:17:59.843] DHCP: proposed address 192.168.1.101 [12/10 20:18:02.265] Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 00:0BB:2B:0E:F4 [12/10 20:18:03.375] Client requested address 0.0.0.108 [12/10 20:18:03.375] DHCP: proposed address 192.168.1.101 [12/10 20:18:05.265] 1652 Request 2 not processed [12/10 20:18:05.265] 1652 Request 2 not processed [12/10 20:18:05.265] Rcvd DHCP Rqst Msg for IP 0.0.0.0, Mac 00:0BB:2B:0E:F4 [12/10 20:18:05.640] Previously allocated address 192.168.1.101 acked [12/10 20:18:05.640] 1652 Request 2 not processed [12/10 20:18:05.640] Connection received from 192.168.1.101 on port 2070 [12/10 20:18:06.187] Read request for file <myth.0>. Mode octet [12/10 20:18:06.187] OACK: <tsize=676710400,> [12/10 20:18:06.187] Using local port 2137 [12/10 20:18:06.187] Peer returns ERROR <TFTP Aborted> -> aborting transfer [12/10 20:18:06.203] I know at least that it is finding the dhcp/tftp service but is failing to load the image myth.0 was an iso file that I got at distrowatch which I have used before. (I renamed it to myth.0 because I didn't know if their was a special . extension I needed ) I am lost on how to get this working. What does the format of this disk image have to be floppy , cd ,...etc Is their any config files I need?
that's Awsomeness... you are a legend mate However, on other note:
Quote:
your RIS server needs to be setup correctly else it wont work. are you sure that you have correctly setup the RIS server. i have made a RIS server once, worked perfectly. my teacher (i am an IT student) says that it can be a bit advanced to set it up correctly. so it might not be the file that is the problem.
SEOGlopex is offline   Reply With Quote
Old 10-13-2011, 05:11 PM   #5
Fully Optimized
 
BikerEcho's Avatar
 
Join Date: Feb 2011
Location: Denmark
Posts: 4,013
Default Re: PXE booting ?

Quote:
Originally Posted by SEOGlopex View Post
that's Awsomeness... you are a legend mate However, on other note:
are you mocking me?
__________________
MOBO: Asus Maximus 6 Hero - GPU: Gigabyte GTX 980ti xtreme - CPU: I7-4770K - PSU: Corsair AX760
RAM: Corsair Vantage 2x4GB - SSD: Samsung 840 EVO 512 + LiteOn LCS-256 - Case: NZXT H440
BikerEcho is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 03:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0