Go Back   Computer Forums > General Computing > Networking | DNS
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-15-2011, 07:45 AM   #11
Fully Optimized
 
jmacavali's Avatar
 
Join Date: Jun 2009
Posts: 4,867
Default Re: new computer won't connect to internet

Can you do a file>save as and save it as something on your desktop?
__________________

__________________
****************************************
Don't take life too seriously -- no one gets out alive. Plus, who wants to arrive to the hereafter in pristine condition wearing a suit and tie?
I want to slide in sideways, worn out, used up, hair a mess, clothes tattered, & screaming, "Whooo! What a ride!"
****************************************
jmacavali is offline   Reply With Quote
Old 11-15-2011, 10:41 AM   #12
Baseband Member
 
Join Date: Oct 2007
Posts: 82
Default Re: new computer won't connect to internet

Even as administrator, I can't make it appear or delete it.

I can save it to my desktop:

Code:
# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
#	127.0.0.1       localhost
#	::1             localhost
66.232.102.249 www.google.com 
66.232.102.249 google.com 
66.232.102.249 google.com.au 
66.232.102.249 www.google.com.au
66.232.102.249 google.be 
66.232.102.249 www.google.be
66.232.102.249 google.com.br 
66.232.102.249 www.google.com.br
66.232.102.249 google.ca 
66.232.102.249 www.google.ca
66.232.102.249 google.ch 
66.232.102.249 www.google.ch
66.232.102.249 google.de 
66.232.102.249 www.google.de
66.232.102.249 google.dk 
66.232.102.249 www.google.dk
66.232.102.249 google.fr 
66.232.102.249 www.google.fr
66.232.102.249 google.ie 
66.232.102.249 www.google.ie
66.232.102.249 google.it 
66.232.102.249 www.google.it
66.232.102.249 google.co.jp 
66.232.102.249 www.google.co.jp
66.232.102.249 google.nl 
66.232.102.249 www.google.nl
66.232.102.249 google.no 
66.232.102.249 www.google.no
66.232.102.249 google.co.nz 
66.232.102.249 www.google.co.nz
66.232.102.249 google.pl 
66.232.102.249 www.google.pl
66.232.102.249 google.se 
66.232.102.249 www.google.se
66.232.102.249 google.co.uk 
66.232.102.249 www.google.co.uk
66.232.102.249 google.co.za 
66.232.102.249 www.google.co.za
66.232.102.249 www.google-analytics.com
66.232.102.249 www.bing.com
66.232.102.249 search.yahoo.com 
66.232.102.249 www.search.yahoo.com
66.232.102.249 uk.search.yahoo.com
66.232.102.249 ca.search.yahoo.com
66.232.102.249 de.search.yahoo.com
66.232.102.249 fr.search.yahoo.com
66.232.102.249 au.search.yahoo.com
__________________

gib65 is offline   Reply With Quote
Old 11-15-2011, 10:48 AM   #13
Baseband Member
 
Join Date: Nov 2011
Posts: 32
Default Re: new computer won't connect to internet

If you right click on Notepad (or whatever text editor you use) and select Run As Administrator, you can modify it and save it.
__________________
It's tough to make predictions, especially about the future. -- Yogi Berra
RonNYC is offline   Reply With Quote
Old 11-15-2011, 01:07 PM   #14
Fully Optimized
 
jmacavali's Avatar
 
Join Date: Jun 2009
Posts: 4,867
Default Re: new computer won't connect to internet

Once it's on the desktop, do whatever edits you need to. Save it again to your desktop, then copy and paste it into the folder it's supposed to be under. See if it will let you override it. Also check to see if you can change the permissions on the folder where it's hidden, perhaps you've lost the rights to that folder.

Either way it sounds as if you have some kind of malware or spyware on the computer. I'd do a scan with MalwareBytes AntiMalware. It's free and it should take care of anything that might be on the computer.
__________________
****************************************
Don't take life too seriously -- no one gets out alive. Plus, who wants to arrive to the hereafter in pristine condition wearing a suit and tie?
I want to slide in sideways, worn out, used up, hair a mess, clothes tattered, & screaming, "Whooo! What a ride!"
****************************************
jmacavali is offline   Reply With Quote
Old 11-15-2011, 01:13 PM   #15
Baseband Member
 
Join Date: Nov 2011
Posts: 32
Default Re: new computer won't connect to internet

First, I'd try to run notepad as Administrator. I did it (Win7) and had no problem saving it to etc.
__________________
It's tough to make predictions, especially about the future. -- Yogi Berra
RonNYC is offline   Reply With Quote
Old 11-18-2011, 01:17 PM   #16
Baseband Member
 
Join Date: Oct 2007
Posts: 82
Default Re: new computer won't connect to internet

OK, first, let me apologize for not responding earlier. I haven't had access to this computer in a while.

Second, this setting of permissions is so bloody complicated: not only do I have to be an administrator, not only do I have to change the permissions, but I also have to be the ^^owneršš of the etc folder and hosts file in order to set the permissions to what I want. Furthermore, Im doubting that the permissions I set to the etc folder were really carried down to the hosts file (even though it said they were).

I did open a new notepad file with the OPEN AS ADMINISTRATOR and recreated the good version of the hosts file (being sure that the .txt extention is not there) on my desktop, but even after setting the permissions of the etc folder to FULL CONTROL for the administrator I was logged in as, these permission settings didnt seem to cascade down to the hosts file. After setting the permissions on the folder and telling it to cascade these settings to the folders contents, I tried to copy the hosts file from my desktop to the etc folder and it tells me: you need permission to perform this action.

If I look at the properties of any file in the etc folder (remember that I cant do this with the actual hosts file because its invisible), I see that the administrator account Im logged in as DOES have full control checked (and everything else except special permissions), and I am the owner of the file. I can overwrite any file in there but not the hosts file. Im guessing that because Im not the original OWNER of the bad hosts file, and I cant set the owner to myself since I cant open the properties of this file, its an issue of ownership.

BTW, I unchecked read-only in the properties of the etc folder and chose to make this change to all content of the etc folder, but it told me I need to get administrator permission to make this change. The check box DID remain unchecked, but every time I close and reopen the properties dialog box, the check reappears (greyed out).

BTW, Im doing all this in safe mode. I also did run MBAM and it found no malware (doesnt mean I dont have any).
gib65 is offline   Reply With Quote
Old 11-18-2011, 01:27 PM   #17
Baseband Member
 
Join Date: Nov 2011
Posts: 32
Default Re: new computer won't connect to internet

I found this:
TAKEOWN /A /F C:
then the next one
TAKEOWN /F C:

Takeown

(describes what it does)

RON
__________________
It's tough to make predictions, especially about the future. -- Yogi Berra
RonNYC is offline   Reply With Quote
Old 11-18-2011, 01:35 PM   #18
Baseband Member
 
Join Date: Oct 2007
Posts: 82
Default Re: new computer won't connect to internet

Problem solved!!!

I figured out how to make the hosts file visible! In any folder under organize > folder and search options > view tab > unselect "hide protected operating system files".

Then it was a simple matter of opening the properties of the hosts file and changing the permission and ownership settings.
gib65 is offline   Reply With Quote
Old 11-19-2011, 11:16 AM   #19
xxcobraxx
 
Join Date: Oct 2004
Location: England
Posts: 6,224
Default Re: new computer won't connect to internet

so you're on the tinternet now?
__________________
Liveleaker
IAntDemo is offline   Reply With Quote
Old 11-21-2011, 12:11 PM   #20
Fully Optimized
 
jmacavali's Avatar
 
Join Date: Jun 2009
Posts: 4,867
Default Re: new computer won't connect to internet

Ah nice. Got to love Win7. Added another layer of "protection".
__________________

__________________
****************************************
Don't take life too seriously -- no one gets out alive. Plus, who wants to arrive to the hereafter in pristine condition wearing a suit and tie?
I want to slide in sideways, worn out, used up, hair a mess, clothes tattered, & screaming, "Whooo! What a ride!"
****************************************
jmacavali is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 11:48 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0