Go Back   Computer Forums > General Computing > Networking | DNS
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-20-2011, 02:52 PM   #1
Daemon Poster
 
GibsonSGKing's Avatar
 
Join Date: Jan 2009
Posts: 1,384
Default How to force Firefox to use my wireless network

Ok, hears the deal. I have two computers. Both are connected to my wireless router using wireless dongles. My main computer (not the one with the problem) has a PCI wireless card, and is connected to an active switch via an ethernet cable. My second computer (one with the problem) is on XP, and is connected wirelessly with a USB dongle, and is connected to the same switch with an ethernet cable. The switch is simply to connect the two computers, it has no internet access, and I'm just using it for FTP. The FTP works fine and dandy, no problems there. The problem arises when I try to connect to the internet on a web browser. Steam can update games just fine, but when I try to browse any internet page, I can't connect. I just get a "Server not found" message. I believe it is trying to connect through the wired connection, which of course has no internet access. Is there any way to force firefox to use my wireless connection? I don't want to constantly have to plug/unplug the ethernet cable, it's just a nuisance. Any and all help is greatly appreciated.
__________________

__________________
C2Q Q9400 @ 3.2GHZ | Zalman 9900 LED HeatSink | Asus P5E3 Pro Motherboard | CM Storm Scout case | 1TB Caviar Black HDD | GTX760 4GB | 23" Acer [1920x1080] & 21.6" Asus [1920x1080] monitors
GibsonSGKing is offline   Reply With Quote
Old 02-20-2011, 02:58 PM   #2
..m.0,0.m..
Site Team
 
iPwn's Avatar
 
Join Date: May 2010
Location: USA
Posts: 3,870
Default Re: How to force Firefox to use my wireless network

What version of Firefox is this?


So from what I've read, you can't force a Windows application to use a specific network adapter unless it's already built into the GUI, which I checked Firefox 4.0 and it's not. One creative solution I've found is to host the program in a virtual machine and then have that virtual machine use a specific Network adapter. I know this can be done in VMWare player.
__________________

__________________
Me: You'd think as the dominant species we wouldn't be so effing stupid.
J: We're just intelligent enough to be completely effing stupid.
iPwn is offline   Reply With Quote
Old 02-20-2011, 07:46 PM   #3
Daemon Poster
 
GibsonSGKing's Avatar
 
Join Date: Jan 2009
Posts: 1,384
Default Re: How to force Firefox to use my wireless network

Quote:
Originally Posted by InfectionZero View Post
What version of Firefox is this?


So from what I've read, you can't force a Windows application to use a specific network adapter unless it's already built into the GUI, which I checked Firefox 4.0 and it's not. One creative solution I've found is to host the program in a virtual machine and then have that virtual machine use a specific Network adapter. I know this can be done in VMWare player.
3.something. I haven't updated it in a while, but I'll gladly update if that will fix it. The thing I don't understand is that it works fine on my main machine, which is on Win7. I have FF4 on this machine though. A VM seems pretty unpractical for just a web browser... Isn't there some way I could set up a proxy setting so it would be forced to go to the router? That's what I read somewhere else, but couldn't figure out how to do it myself.

I'm going to assume my problem here is with XP, not necessarily FireFox, because Win7 can tell if the connection has internet access, while XP can not (at least to my knowledge). It also attempts to update my clock through the wired connection, and obviously it can't connect to time.windows.com through that, so now my clock is off >_>

EDIT:
Is there any way I can use this software to do it? ForceBindIP - Bind any Windows application to a specific interface
I've tried installing it and going into cmd and putting
Code:
ForceBindIP 192.168.1.107 "C:\Program Files\Mozilla Firefox\firefox.exe"
And it didn't help at all. 192.168.1.107 is the IP I get for my wireless connection when I put in ipconfig in cmd, I doubt it's right but I don't know what other ip to try. I know if I type "home" into my browser it puts me to my routers control panel, should I try that? I don't know what my routers ip would be.
__________________
C2Q Q9400 @ 3.2GHZ | Zalman 9900 LED HeatSink | Asus P5E3 Pro Motherboard | CM Storm Scout case | 1TB Caviar Black HDD | GTX760 4GB | 23" Acer [1920x1080] & 21.6" Asus [1920x1080] monitors
GibsonSGKing is offline   Reply With Quote
Old 02-21-2011, 11:11 AM   #4
Daemon Poster
 
PokerDegenerate's Avatar
 
Join Date: Dec 2008
Posts: 1,465
Default Re: How to force Firefox to use my wireless network

you can get your actual ip address from What's My IP Address? Networking Tools & More that ip you get from ipconfig is a private ip address that is used in your network which allows more than one computer utilize the same ip to connect to the internet. Private ip is used only in your network to make sure packets get to the right computer.
__________________
Raidmax Smilodon Extreme Black Case -|-AMD Phenom II x4 955 BE @ 3829.50 Mhz (18.5 x 207, vcore 1.424, NB 2600 mhz, HT link 2200 mhz) -|- Xigmatek Dark Knight S1283V -|- Gigabyte MA790XT-UD4P Mobo -|- G. Skill 6Gb (3 x 2Gb) DDR3 1333 RAM 7-7-7-18-2t -|- WD Caviar 7200 RPM 1 TB HDD -|- OCZ GameXtreme 700W -|- Radeon 4870 1Gb @ 780/1050 -|- Asus VW202NR 20" wide-screen -|- Windows 7 Professional 64 Bit -|- Saitek Cyborg Keyboard -|- Razer Lachesis Mouse
PokerDegenerate is offline   Reply With Quote
Old 02-21-2011, 11:13 AM   #5
Site Team
 
root's Avatar
 
Join Date: Mar 2004
Posts: 8,004
Default Re: How to force Firefox to use my wireless network

you could also add specific routes

you can look at your machines routing table by typing route -print at the command line.

You can tell your computer to only use a specific adapter to get to the gateway IP address.
(that way you should be able to use either interface for intra-machine connection and have wireless forced for internet connectivity).

type route /? at the command prompt for help on using the command.
__________________
I didn’t fight my way to the top of the food chain to be a vegetarian…
Im sick of people saying 'dont waste paper'. If trees wanted to live, they'd all carry guns.
"The inherent vice of capitalism is the unequal sharing of blessings; The inherent vice of socialism is the equal sharing of miseries."
root is offline   Reply With Quote
Old 02-22-2011, 12:47 AM   #6
Daemon Poster
 
GibsonSGKing's Avatar
 
Join Date: Jan 2009
Posts: 1,384
Default Re: How to force Firefox to use my wireless network

Quote:
Originally Posted by root View Post
you could also add specific routes

you can look at your machines routing table by typing route -print at the command line.

You can tell your computer to only use a specific adapter to get to the gateway IP address.
(that way you should be able to use either interface for intra-machine connection and have wireless forced for internet connectivity).

type route /? at the command prompt for help on using the command.
Ok, how can I use this to do what I'm trying to? I'm not too terribly familiar with networking, so a little bit more detail would be greatly appreciated. This certainly sounds like a step in the right direction though. I also tried making my wireless connection the first listed under Network Connections>Advanced>Adapters and Bindings, but that didn't seem to help at all.

Quote:
Originally Posted by PokerDegenerate View Post
you can get your actual ip address from What's My IP Address? Networking Tools & More that ip you get from ipconfig is a private ip address that is used in your network which allows more than one computer utilize the same ip to connect to the internet. Private ip is used only in your network to make sure packets get to the right computer.
I'm confused as to why you are telling me this. I know I'm getting my internal IP with ipconfig, that's what I'm looking for. What good does my external address do if I'm never actually getting out of my network? It wouldn't be able to find that IP either, it's not actually getting to the router, it's getting stuck at the switch because it's trying to use the wrong connection.
__________________
C2Q Q9400 @ 3.2GHZ | Zalman 9900 LED HeatSink | Asus P5E3 Pro Motherboard | CM Storm Scout case | 1TB Caviar Black HDD | GTX760 4GB | 23" Acer [1920x1080] & 21.6" Asus [1920x1080] monitors
GibsonSGKing is offline   Reply With Quote
Old 02-22-2011, 06:30 AM   #7
Site Team
 
root's Avatar
 
Join Date: Mar 2004
Posts: 8,004
Default Re: How to force Firefox to use my wireless network

ok...

having re-read what you wrote. (forget about routing tables)

you have a wireless router connected to the internet
your PC connects to this (wireless), your laptop connects to this (wireless)

you then have a switch that is completely independent of your wireless router, effective forming a second completely private network between the two machines. there is no connection from this switch to your wireless router.

the easiest (and best) thing to do would be to change the IP address of the wired connection on each of the two computers.

in this way you could use
192.168.0.1 for your router
192.168.0.2 for your wireless on the PC
192.168.0.3 for the wireless on the laptop.

then have 172.16.0.1 for the wired connection on the PC
and 172.16.0.2 for the wired connection on the laptop
use a subnet of whatever size you like (permissible in the range) (though 255.255.255.0 will be easiest).


at the moment it sounds like your routing internet traffic down a second link, trying to relay through the PC, but the PC (is not a router) is ignoring this traffic
__________________
I didn’t fight my way to the top of the food chain to be a vegetarian…
Im sick of people saying 'dont waste paper'. If trees wanted to live, they'd all carry guns.
"The inherent vice of capitalism is the unequal sharing of blessings; The inherent vice of socialism is the equal sharing of miseries."
root is offline   Reply With Quote
Old 02-22-2011, 10:53 PM   #8
Daemon Poster
 
GibsonSGKing's Avatar
 
Join Date: Jan 2009
Posts: 1,384
Default Re: How to force Firefox to use my wireless network

Quote:
Originally Posted by root View Post
ok...

having re-read what you wrote. (forget about routing tables)

you have a wireless router connected to the internet
your PC connects to this (wireless), your laptop connects to this (wireless)

you then have a switch that is completely independent of your wireless router, effective forming a second completely private network between the two machines. there is no connection from this switch to your wireless router.

the easiest (and best) thing to do would be to change the IP address of the wired connection on each of the two computers.

in this way you could use
192.168.0.1 for your router
192.168.0.2 for your wireless on the PC
192.168.0.3 for the wireless on the laptop.

then have 172.16.0.1 for the wired connection on the PC
and 172.16.0.2 for the wired connection on the laptop
use a subnet of whatever size you like (permissible in the range) (though 255.255.255.0 will be easiest).


at the moment it sounds like your routing internet traffic down a second link, trying to relay through the PC, but the PC (is not a router) is ignoring this traffic
That sounds about right, the other machine is another desktop, but it's pretty much the same idea. How exactly would I go about doing all of that though? A step by step would be very greatly appreciated, I'm sorry, I'm pretty new to networking....
__________________
C2Q Q9400 @ 3.2GHZ | Zalman 9900 LED HeatSink | Asus P5E3 Pro Motherboard | CM Storm Scout case | 1TB Caviar Black HDD | GTX760 4GB | 23" Acer [1920x1080] & 21.6" Asus [1920x1080] monitors
GibsonSGKing is offline   Reply With Quote
Old 02-23-2011, 05:06 AM   #9
Site Team
 
root's Avatar
 
Join Date: Mar 2004
Posts: 8,004
Default Re: How to force Firefox to use my wireless network

ok,

For XP.
click start,
control pannel.
networking

right click on the adapter you want to change. (the one that is a wired connection to the other machine).
press properties.
click IPv4 networking
click properties.

change the IP address to another address (I'll suggest that you use a private class B address)
make the IP address 172.16.0.1 make the subnet 255.255.255.0
leave the gateway blank (there's no internet connection, so there is no gateway).
also leave the DNS server settings blank.

on the windows 7 machine,
right click on the networking icon in the system tray and select open network connection and sharing centre
then click change adapter settings from the text links on the left
select the adapter you want.
right click
select properties
click IP4
click properties.
change the address to
172.16.0.2 with a subnet of 255.255.255.0
leave the gateway and DNS settings blank again.

you can now test the connection by typing ping 172.16.0.2 from the first box and ping 172.16.0.1 from the second box...
__________________
I didn’t fight my way to the top of the food chain to be a vegetarian…
Im sick of people saying 'dont waste paper'. If trees wanted to live, they'd all carry guns.
"The inherent vice of capitalism is the unequal sharing of blessings; The inherent vice of socialism is the equal sharing of miseries."
root is offline   Reply With Quote
Old 11-14-2011, 11:41 AM   #10
Beta Member
 
Join Date: Nov 2011
Posts: 1
Default Re: How to force Firefox to use my wireless network

Force the undesirable network interface to have a HIGH metric in the Advanced properties of the Networking interface, in Windows 7.



Go to Network connections


Properties of undesirable network interface


Properties > Double Click Internet Protocol Version 4 > Advanced



Deselect Automatic Metric


and enter a high number like 500


use route print to verify
__________________

klau is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 01:40 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0