Go Back   Computer Forums > General Computing > Networking | DNS
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-03-2011, 03:00 AM   #1
Beta Member
 
Join Date: Oct 2011
Posts: 1
Question Help Required PLZ! Dual network setup

hey guys,
currently i have cdg24n as my modem/wireless router which wirelessly connect to my pc which has a dlink dwa-510 wireless card in it.

Now heres where the problems start... I decided to set up a so called "render farm" with another pc, so what i did is connected a Netgear RT314 Gateway Router from wired internet port on my pc to the second pc. It works exactly as required when i only have 1 connection "activated" in windows network settings, if two are activated i do not receive my normal internet connection and chrome thinks i'm not connected to the internet.

I've heard this is caused my ip switching or something like that and everytime i turn on the computers and set up Cinema 4D Net Client (The render farm client) i need to use a different ip address as the iPv4 address of the pc has changed.. i tried to turn off dhcp on the Netgear RT314 Gateway Router as google searches has suggested but it has not made a difference.

Sorry for the long explanation
Thanks
__________________

ausman is offline   Reply With Quote
Old 10-25-2011, 12:10 PM   #2
Daemon Poster
 
Captain Pooka's Avatar
 
Join Date: Oct 2006
Posts: 1,108
Default Re: Help Required PLZ! Dual network setup

Not exactly sure what you're saying, but from the first paragraph it sounds like you're trying to bridge connections. From the first computer, are you connected wirelessly? Or do you have two NICs (network cards)?

If you only have one network card and are not connected wirelessly, you cannot simply connect your computer to another and pull the internet from nowhere.

To connect two computers together you need to use a crossover cable. To share an internet connection you need to go to Network Settings and look that the adapter that is being used to connect the computers together. Right click it and select "Bridge connections". Now you'll be sharing internet, but this only works if computer 1 is getting internet from somewhere (Wirelessly or a secondary NIC).

Good luck,

-Q
__________________

Captain Pooka is offline   Reply With Quote
Old 10-25-2011, 12:47 PM   #3
Site Team
 
root's Avatar
 
Join Date: Mar 2004
Posts: 8,001
Default Re: Help Required PLZ! Dual network setup

You don't necessarily need to turn off the DHCP server on the router that you're trying to use as just a switch...


Can you confirm the following.

what is your wireless network details.

(I suspect that you'll see that your IP address is 192.168.1.2 with a subnet mask of 255.255.255.0 and a gateway of 192.168.1.1)

What is the range of addresses assigned to your other router that you;re trying to use as a switch.

I suspect that these ranges clash. (i.e they are the same)

Change them so that they do not.





if that does not clear up your problems then you'll find that you should be able to solve them in the following way:

use the router, but instead of letting it assign your address, right click your network connection, select properties, select TCP/IP and press properties then select to manually assign an address,
assign an address in the same range that the router was giving the PC anyway, (possibly even the same address), and assing the same subnet mask that was being used (likely 255.255.255.0) do not asign a gateway address. ensure that the range used is different from the range used on your wireless network.

you can confirm your settings by opening the command prompt and typing

route -print

which will show you something like this:


IPv4 Route Table
================================================== =========================
Active Routes:
Network Destination Netmask Gateway Interface Metric
0.0.0.0 0.0.0.0 192.168.16.1 192.168.16.173 25
127.0.0.0 255.0.0.0 On-link 127.0.0.1 306
127.0.0.1 255.255.255.255 On-link 127.0.0.1 306
127.255.255.255 255.255.255.255 On-link 127.0.0.1 306
192.168.16.0 255.255.255.0 On-link 192.168.16.173 281
192.168.16.173 255.255.255.255 On-link 192.168.16.173 281
192.168.16.255 255.255.255.255 On-link 192.168.16.173 281
192.168.198.0 255.255.255.0 On-link 192.168.198.1 276
192.168.198.1 255.255.255.255 On-link 192.168.198.1 276
192.168.198.255 255.255.255.255 On-link 192.168.198.1 276
255.255.255.255 255.255.255.255 On-link 127.0.0.1 306
255.255.255.255 255.255.255.255 On-link 192.168.198.1 276
255.255.255.255 255.255.255.255 On-link 192.168.16.173 281
================================================== =========================
Persistent Routes:
None


this shows you that the default route that will go to anywhere will use the interface on may machine 192.168.16.173
(i.e traffic to the internet uses this route)

however, if I want to access a machine on the 192.168.198.x network, then this goes via the interface 192.168.198.1




Basically, I think that you have a routing problem.

if you want to confirm this before changing anything, enable both interfaces and go to the command prompt and type route -print

then disable the correct interface for you to come back online and post the results here.
__________________
I didn’t fight my way to the top of the food chain to be a vegetarian…
Im sick of people saying 'dont waste paper'. If trees wanted to live, they'd all carry guns.
"The inherent vice of capitalism is the unequal sharing of blessings; The inherent vice of socialism is the equal sharing of miseries."
root is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 09:20 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0