Go Back   Computer Forums > General Computing > Networking | DNS
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-14-2008, 01:03 PM   #1
Solid State Member
 
pete123456's Avatar
 
Join Date: Oct 2004
Posts: 12
Default BIND: Alias "www" displays gateway

Hello,

Here is my network configuration:
Server IP: 192.168.2.111
Gateway: 192.168.2.1

Imagine the domain is example.com

I am currently hosting a domain (using BIND) at home and running a web server. I have a strange issue when querying www.example.com (from a browser), it displays the gateway (router's) configuration page, however example.com displays what it should (the webpage hosted).
As you can imagine this would be a a bad breach of security so port 80 is blocked at the moment.

An nslookup of www.example.com does indeed point to 192.168.2.111 (internally) but when accessed from a web browser it displays the 192.168.2.1 router configuration page.

I apologise if I am being a bit vague and will supply more details if needed.
Thanks for your time,
Regards,
Pete

Edit: Seems to be fixed, I made the router use my DNS servers instead of my ISPs.
pete123456 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 01:28 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0