Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-03-2009, 10:17 AM   #1
Beta Member
 
Join Date: Oct 2009
Posts: 3
Default XP not recognising new SATA drive.

Can anyone help. I have 2 IDE hdds one running XP Home edition. I have bought a new SATA 500Gb hdd and have plugged it iin to a sata connection on the MOBO and connected power. When I turn on the computer I see it recognised in the BIOS start up and if I go into the BIOS it is visible. However when I go to My Computer all that is displayed is the 2 IDE drives.

What am I missing?
__________________

dogtang is offline   Reply With Quote
Old 10-03-2009, 11:20 AM   #2
Daemon Poster
 
Whyfly??'s Avatar
 
Join Date: Jun 2009
Posts: 976
Default Re: XP not recognising new SATA drive.

Stupid question, forgive me.
But did you plug the power into the hard drive, and also the SATA connectors into the right slot?
__________________

__________________
Amd Phenom ii 940 3.0 Stock cooler :( :( :(
XFX Geforce 260 Core 216
Antec 1200 with 600 watt Ocz Modxstream Pro
4 gigs DDR2 1066 RAM... 640 gig hard drive
Gigabyte Ud4P-MA790x
Whyfly?? is offline   Reply With Quote
Old 10-03-2009, 11:22 AM   #3
Beta Member
 
Join Date: Oct 2009
Posts: 3
Default Re: XP not recognising new SATA drive.

All the connections are correct and there is power (hence the sata drive being recognised in the BIOS settings and in the pre windows BIOS load up).
dogtang is offline   Reply With Quote
Old 10-03-2009, 11:24 AM   #4
Daemon Poster
 
Whyfly??'s Avatar
 
Join Date: Jun 2009
Posts: 976
Default Re: XP not recognising new SATA drive.

I am thinking you need to format the drive for it to show up on Windows.
Can you check if the drive shows up in the Device Manager?
__________________
Amd Phenom ii 940 3.0 Stock cooler :( :( :(
XFX Geforce 260 Core 216
Antec 1200 with 600 watt Ocz Modxstream Pro
4 gigs DDR2 1066 RAM... 640 gig hard drive
Gigabyte Ud4P-MA790x
Whyfly?? is offline   Reply With Quote
Old 10-03-2009, 11:44 AM   #5
Beta Member
 
Join Date: Oct 2009
Posts: 3
Default Re: XP not recognising new SATA drive.

Does not show up in device manager.

When the system loads there is an option to enter RAID facility. I went into this, and again it recognised the sata drive and allowed me to do a low level format. I do have an underlying knowledge of computers and computer systems (all be it a basic one - I did build the current PC) so I would like to think that I have all the basics covered, however there is always the possiblilty I have overlooked something simple. Needless to say it is driving me nuts!
Am I missing specific drivers for the sata for windows to see it?
dogtang is offline   Reply With Quote
Old 10-03-2009, 01:10 PM   #6
Omnipotent One
 
Atomic Rooster's Avatar
 
Join Date: Apr 2006
Location: USA
Posts: 11,161
Send a message via AIM to Atomic Rooster Send a message via Yahoo to Atomic Rooster
Default Re: XP not recognising new SATA drive.

Have a read through this:

How to use Disk Management to configure basic disks in Windows XP
Atomic Rooster is offline   Reply With Quote
Old 10-03-2009, 01:28 PM   #7
Daemon Poster
 
Whyfly??'s Avatar
 
Join Date: Jun 2009
Posts: 976
Default Re: XP not recognising new SATA drive.

^^^
Ahh I was looking for that site, Atomic beat me to it
__________________
Amd Phenom ii 940 3.0 Stock cooler :( :( :(
XFX Geforce 260 Core 216
Antec 1200 with 600 watt Ocz Modxstream Pro
4 gigs DDR2 1066 RAM... 640 gig hard drive
Gigabyte Ud4P-MA790x
Whyfly?? is offline   Reply With Quote
Old 10-03-2009, 01:35 PM   #8
Fully Optimized
 
cboucher's Avatar
 
Join Date: Jun 2009
Location: USA
Posts: 1,652
Default Re: XP not recognising new SATA drive.

Sometimes, even if it shows up in BIOS, it still has to be enabled. Also, check which port on the motherboard it is plugged into (SATA 0, SATA 1, etc.). Usually the SATA ports are enabled separately.
__________________
But I'm trying, Ringo. I'm trying real hard... to be the Shepherd.
cboucher is offline   Reply With Quote
Old 10-04-2009, 12:27 PM   #9
Solid State Member
 
Join Date: Oct 2009
Posts: 7
Default Re: XP not recognising new SATA drive.

Quote:
Originally Posted by cboucher View Post
Sometimes, even if it shows up in BIOS, it still has to be enabled. Also, check which port on the motherboard it is plugged into (SATA 0, SATA 1, etc.). Usually the SATA ports are enabled separately.
this, if it's showing up in bios and not on your OS it might just have to be enabled. even if it's not formatted it will still show up in disk management.
tist006 is offline   Reply With Quote
Old 10-05-2009, 03:02 AM   #10
Solid State Member
 
Join Date: Oct 2009
Posts: 16
Default Re: XP not recognising new SATA drive.

I'd say Atomic hit the nail on the head. Chances are it needs to be initialised and formatted, not sure if it will show up even in device manager prior to being initialised. Computer Management in Administrative Tools is your friend
__________________

Chickensoup is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 03:57 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0