Go Back   Computer Forums > General Computing > Hardware
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 08-07-2007, 01:42 AM   #1
Daemon Poster
Taylor's Avatar
Join Date: Jul 2006
Posts: 946
Default wow

wow, creatives drivers suck... I log in, and all the speakers in my 5.1 setup work. i go into itunes, and the two rear ones dont work. Its really starting to tick me off. Is there any other drivers i can download? Its for the X-Fi soundblaster Xtrememusic.

| Intel Pentium D 820 2.80GHz(Smithfield) | EVGA 780i | EVGA GeForce 7600GT 256MB 128-bit GDDR3 |4GB Corsair 800 | WDCaviar 250GB | Arctic Cooling Freezer 7 Pro(w/ arctic silver 5) | Ultra 500w X-Finity Power Supply w/ 120mm Fan | Antec P180B. | Windows Vista Home Premium | Creative Sound Blaster X-Fi XtremeMusic | Dell Ultrasharp 22" Flatscreen Monitor

Macbook Pro 15" Unibody. 2GB Ram 250GB HDD Leopard
Taylor is offline   Reply With Quote
Old 08-07-2007, 02:39 AM   #2
In Runtime
Join Date: Apr 2007
Posts: 446
Send a message via MSN to Comp_Pro
Default Re: wow

are they plugged in correctly?

Intel i7 4770k 3.50ghz, 32gb Corsair Vengeance RAM (8x4 kit), 2 x 2TB WD Black HHD, nVidia 770GTX 4gb OC, Asus Z87-A Motherboard, running Windows 7 64 bit.
Comp_Pro is offline   Reply With Quote
Old 08-07-2007, 03:44 AM   #3
Fully Optimized
Join Date: Nov 2006
Posts: 3,623
Send a message via AIM to ߧ∩H♠H䎀
Default Re: wow

Welcome to the club. I found that out as soon as I bought Vista. There latest drivers don't carry a digital passthrough upon reboot. So I turned my computer on and it sounded like a jet taking off through the speakers. At first I thought my computer blew up then realized it was the speakers.

Reverting back to the original driver fixed the problem but has like half the stuff the latest driver had. At least I can play my music with the old one.
ߧ∩H♠H䎀 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 08:18 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0