Go Back   Computer Forums > General Computing > Hardware
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 09-01-2009, 04:48 AM   #11
Join Date: Jan 2005
Location: Wales
Posts: 5,556
Send a message via MSN to j03
Default Re: Windows 7 ATI Display Driver Install FAIL

mongoman, this is quite an old thread.

However, I have had SIMILAR issues regarding older, low end ATi cards and Windows 7. ATi Have dropped support for the x200/x300 under W7 - I'm using old, uncompatible with drivers with my x300. I get random lockups, and have to restart all the time.

My 4870 is coming tomorrow, and should fix that ^_^

j03 is offline   Reply With Quote
Old 09-01-2009, 09:02 PM   #12
Fully Optimized
mongoman's Avatar
Join Date: May 2006
Posts: 2,021
Send a message via AIM to mongoman
Default Re: Windows 7 ATI Display Driver Install FAIL

lol, it got dug up by a spammer whos post is now gone i never noticed the date tho, my bad. the 4870 will work for sure too :P

||Intel Core i5 @ 3.84ghz with turbo boost||Intel DP55KG motherboard||Corsair 750w psu||4gb Corsair XMS3 9-9-9-24||MSI Dvd Burner||500gb Seagate Barracuda||ATI Radeon 5670 1gb HIS||
mongoman is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 07:05 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0