Go Back   Computer Forums > General Computing > Hardware
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 10-06-2005, 07:44 AM   #1
In Runtime
marcmarteleira's Avatar
Join Date: Jan 2005
Posts: 166
Send a message via AIM to marcmarteleira Send a message via MSN to marcmarteleira
Default Windows 2000 Working Bad?

Hello, I have installed Windows 2000 on my computer and for some reason it runs really really slow. Do you know what might be wrong with it?

2.4 GHz Celeron D
512 MB Single Channel PC3200 DDR-SDRAM
256 MB nVidia GeForce FX 5500
80 GB Hard Drive
Onboard AC97 Sound

For more detailed specs:

Does anyone know why Windows 2000 Pro may run so slow on my computer?

marcmarteleira is offline   Reply With Quote
Old 10-07-2005, 04:36 PM   #2
Lord Kalthorn's Avatar
Join Date: Dec 2003
Location: Britain
Posts: 13,293
Send a message via MSN to Lord Kalthorn

It really shouldn't run slow. I'd personally use XP on that particular machine. Is it a new install?
A Knight is sworn to Honour. His heart knows only Virtue. His blade defends the helpless. His might upholds the Weak. His word speaks only truth. His wrath undoes the Wicked.
Lord Kalthorn is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 12:57 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0