Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-05-2007, 05:40 PM   #1
Baseband Member
 
Join Date: Sep 2007
Posts: 68
Default Why does Warcraft III run so slow?

Okay, to start, ill give my system specs (it's old, I know):

_________________________________________________
Pentium 4 2.0 Ghz processor

ATI radeon x700 pro

hds722525vlat80 | 233 total giga-bytes, 299 giga-bytes free

768 MB of ram

Windows XP home edition

Samsung SD-612 DVD-ROM

(Don't know mobo, or how to find out)
__________________________________________________


I can't play warcraft 3 without significant lag. I know its not my internet because it still lags in offline 4-people lan parties.

Also, my parents comp (http://compreviews.about.com/od/budg...hinesT2984.htm) runs it fine, despite being quite inferior to my computer.

So I Quick-deleted everything and re-installed windows. I say quick-delete, because I did not reformat it, I just deleted the partition. But my comp still lagged when playing Warcraft 3. So I did free virus scans with AVG, Spybot, and NoD32, all of them coming up with nothing. However, I did do a free scan with RegCare, and it came up with about 380 corrupted files or w/e they where.

What should I do to get WC3 to run well? Do i need to reformat my computer? Or is it possible that there has been a hardware failure, like some ram getting fried.

Also, the only things I installed after clearing everything was the newest driver for the graphics card, Firefox, and WC3. Is there another driver or program that I have to have for my system to run properly?

Last tidbit - When i installed windows, it said some sort of file was not found, then canceled installation several times, each time giving a different file not found. The final time, it still said a file was not found, but it continued installing. Would this mess anything up? If it where crucial, wouldn't windows not continue? And why did it mess up so many times?



Thanks very very much to whoever decides to try to help me. I know its a lot of crap to read, but I wanted to be thorough.

Thanks again.
__________________

Pyrox920 is offline   Reply With Quote
Old 09-05-2007, 06:03 PM   #2
Fully Optimized
 
mongoman's Avatar
 
Join Date: May 2006
Posts: 2,021
Send a message via AIM to mongoman
Default Re: Why does Warcraft III run so slow?

warcraft 3 should run fine......try doin a format reload
__________________

__________________
||Intel Core i5 @ 4.1ghz||Intel DP55KG||Corsair 750w psu||8gb G. Skill ram||120gb intel ssd 2x 1.5tb WD Green||MSI Gtx 970||
mongoman is offline   Reply With Quote
Old 09-06-2007, 12:12 AM   #3
Golden Master
 
MikeReiner's Avatar
 
Join Date: Aug 2005
Posts: 5,053
Send a message via AIM to MikeReiner Send a message via MSN to MikeReiner Send a message via Yahoo to MikeReiner
Default Re: Why does Warcraft III run so slow?

Do a real format, Make sure all drivers all up to date, make sure chipset drivers are installed.

If the ram was bad, well, it would just plain crash, not run slow.


That system should run War3 perfectly fine.
MikeReiner is offline   Reply With Quote
Old 09-06-2007, 01:48 AM   #4
Daemon Poster
 
sek3o1's Avatar
 
Join Date: Jan 2007
Posts: 1,150
Default Re: Why does Warcraft III run so slow?

get the newest bios update for the board and update windows then scan the comp.
__________________
dell xps 700 pent d 3.8 ghz duel 7900 gtx
4gigs 800 ram
sony vaio core 2 duo t7600 radon mobility x1600
2 gigs of ram
sek3o1 is offline   Reply With Quote
Old 09-06-2007, 07:18 AM   #5
In Runtime
 
Join Date: Apr 2007
Posts: 446
Send a message via MSN to Comp_Pro
Default Re: Why does Warcraft III run so slow?

it occurs to me if you have a 233gb harddrive how can you have 299gb free?
__________________
Intel i7 4770k 3.50ghz, 32gb Corsair Vengeance RAM (8x4 kit), 2 x 2TB WD Black HHD, nVidia 770GTX 4gb OC, Asus Z87-A Motherboard, running Windows 7 64 bit.
Comp_Pro is offline   Reply With Quote
Old 09-08-2007, 02:38 PM   #6
Baseband Member
 
Join Date: Sep 2007
Posts: 68
Default Re: Why does Warcraft III run so slow?

Quote:
Originally Posted by Comp_Pro View Post
it occurs to me if you have a 233gb harddrive how can you have 299gb free?

Sorry, got it backwards: 300gb HDD, 233gb free.

Anyways, I think it might be my power supply. It's about 7 years old and came with the computer case. Is there anyway to check and find out if its the power supply?
__________________

Pyrox920 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 02:48 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0