Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-22-2006, 03:59 PM   #1
In Runtime
 
Join Date: Sep 2005
Posts: 159
Default USB Ports not working... Help?

So everything is going fine... I have several peripherals hooked up via USB including my wireless mouse, ipod dock, external hdd and printer. But then my HDD stopped responding. It was just hooked up to another computer and then I hooked it up to the front ports. I figured it was the front ports not working because the mouse (hooked up to the back) was still working and nothing I plugged into the front worked. Now, for some reason, nothing works via USB.

What else can I do to figure out what is going on.

I'm running XP Pro on an AMD64 X2 3800+ cpu. 1024mb DDR2 RAM on an ASUS M2NBP-VM motherboard.

Oh yeah, device manager says everything is "working properly".
__________________

__________________
DailyOffTopic.com
The cure for boredom.
un4given is offline   Reply With Quote
Old 12-22-2006, 04:03 PM   #2
muz
Golden Master
 
muz's Avatar
 
Join Date: Oct 2006
Posts: 6,928
Default Re: USB Ports not working... Help?

hmm let me get this right its all usb that are not working or is it just the front ones, if it was the front ones only then check the connections to the mobo inside.
If it is all the usb's check in the BIOS that they are turned on and if they are maybe try resetting bios , or check for latest bios vesion

EDIT>check event viewer as well this may tell you something
also did mobo come with disk if so it may have a diagnostic prigrame otherwise download ultimate boot cd http://www.ultimatebootcd.com/ this has tools to check mobo
__________________

__________________
Desktop-AMD Athlon 64 X2 6000+-2GB Elixer DDR2 800 250gb+500gb+500gb+120gb
Laptop-Apple Macbook Pro 13" Intel core i5(2.3ghz) 4gb Ram 320gb hard drive
muz is offline   Reply With Quote
Old 12-22-2006, 04:34 PM   #3
In Runtime
 
Join Date: Sep 2005
Posts: 159
Default Re: USB Ports not working... Help?

I just pulled the batt out of the mobo and still same thing.

Whenever I plug in any device (example, I just plugged in a jump drive) a pop up comes up in the bottom corner saying "USB device unrecognized". So it knows it's there, just doesn't wanna work.
__________________
DailyOffTopic.com
The cure for boredom.
un4given is offline   Reply With Quote
Old 12-22-2006, 05:50 PM   #4
muz
Golden Master
 
muz's Avatar
 
Join Date: Oct 2006
Posts: 6,928
Default Re: USB Ports not working... Help?

hmm sounds like maybe a driver error on the bios chip , but i cannot be certain, have you tried resetting the bios and flashing with the latest version of firmware,

you could also try theis > download a live cd of linux and try USB on there

go into device manager and click on usb controller and click roll back drivers , you could also try scan hardware for changes

these are the steps i would take if anyone else has any suggestions please add them as i don't know everything
__________________
Desktop-AMD Athlon 64 X2 6000+-2GB Elixer DDR2 800 250gb+500gb+500gb+120gb
Laptop-Apple Macbook Pro 13" Intel core i5(2.3ghz) 4gb Ram 320gb hard drive
muz is offline   Reply With Quote
Old 12-22-2006, 06:43 PM   #5
In Runtime
 
joelbeveridge's Avatar
 
Join Date: Aug 2006
Posts: 187
Default Re: USB Ports not working... Help?

So Not one single USB device works, Cool. These USB devices work in other machine? You are just trying 1 USB device not all at same time? Do you know your motherboard type? Go into device managed and uninstall the USB drivers then click on the button (find new hardware), it should scan for new devices eg. USB and reload them, we are just doing this to make sure the drivers are loaded correctly. Oh you will need PS2 mouse or keyboard if USB not working.
__________________
(\__/)
(='.'=)
(")_(") Control your computer, Dont let it control You!
joelbeveridge is offline   Reply With Quote
Old 12-22-2006, 07:54 PM   #6
Golden Master
 
Tommy Boy's Avatar
 
Join Date: Jul 2004
Location: USA
Posts: 8,463
Send a message via Yahoo to Tommy Boy
Default Re: USB Ports not working... Help?

That is weird....I can't imagine why all usb ports would stop working at the same time. You sure you don't have a virus or something?
__________________

__________________
When all else fails...Ham Radio!

I still have the same old HP DV9700T laptop I've had for years...still kickin'
Tommy Boy is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 08:24 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0