Go Back   Computer Forums > General Computing > Hardware
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 03-21-2010, 06:27 PM   #1
Beta Member
Join Date: Mar 2010
Posts: 1
Default Tower just shut off

My computer tower just shut off and won't turn back on. I thought it might be the psu so I pulled it and tried turning it on just with the mb cable on it and it started no problem. So I started plugging everything back in one thing at a time and when I got the the video it won't start with that 12v wire running to the video card,,it starts with without it plugged in,,? is there anyway I can tell if its the video card or psu without ordering both?thanks

PSU-ultra 550w sli

It's been running fine for years

Frost44 is offline   Reply With Quote
Old 03-21-2010, 08:05 PM   #2
Daemon Poster
GibsonSGKing's Avatar
Join Date: Jan 2009
Posts: 1,384
Default Re: Tower just shut off

Yeah, try a different PSU or video card, or measure the rails on your PSU with a multimeter and compare them with the specs. I can't really think of any other options off my head right now.
C2Q Q9400 @ 3.2GHZ | Zalman 9900 LED HeatSink | Asus P5E3 Pro Motherboard | CM Storm Scout case | 1TB Caviar Black HDD | GTX760 4GB | 23" Acer [1920x1080] & 21.6" Asus [1920x1080] monitors
GibsonSGKing is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 04:18 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0