Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-20-2006, 01:39 PM   #1
Daemon Poster
 
jcon89's Avatar
 
Join Date: Jul 2005
Posts: 734
Default thermal compound

when i installed my cpu's heatsink, i did not put the correct amount of thermal compound on... is it safe to clean it off? and if so, how do i do it?

-edit- I have not even turned my computer on yet.. i just hooked everything up.
__________________

__________________
www.patientjoe.com - Computer Repairs in Warwick, Rhode Island
QuadCore AMD Phenom II X4 920, 2800 MHz (14 x 200), Asus M3A76-CM, 4GB DDR2 Corsair RAM, Geforce 7900GTX, Windows 7 Ultimate (64-bit)
time for an upgrade!!!
jcon89 is offline   Reply With Quote
Old 08-20-2006, 01:51 PM   #2
Daemon Poster
 
prosser13's Avatar
 
Join Date: Dec 2004
Posts: 1,080
Send a message via MSN to prosser13
Default Re: thermal compound

Pop down the local computer store and buy some Akasa thermal paste remover. Or, buy some from the internet.

If you can't wait that long, use a lint free cloth to wipe as much of it as you can, that should be OK in the short term.
__________________

__________________
If I help you, I welcome Reputation Points to show your thanks. I won't forget it!
prosser13 is offline   Reply With Quote
Old 08-20-2006, 01:52 PM   #3
Daemon Poster
 
BigLu's Avatar
 
Join Date: Feb 2005
Posts: 1,140
Send a message via AIM to BigLu
Default Re: thermal compound

yes it is safe to clean it off, use a cloth or paper towell and wipe it off, then take some rubbing alcohol and use that to completely clean it off. it's not like if you're messing with fire here, it doesn't have to be perfectly done.
__________________
E8400
HD 4870
4GB DDR2
BigLu is offline   Reply With Quote
Old 08-20-2006, 02:19 PM   #4
Daemon Poster
 
jcon89's Avatar
 
Join Date: Jul 2005
Posts: 734
Default Re: thermal compound

ok thx guys that helps a lot
__________________
www.patientjoe.com - Computer Repairs in Warwick, Rhode Island
QuadCore AMD Phenom II X4 920, 2800 MHz (14 x 200), Asus M3A76-CM, 4GB DDR2 Corsair RAM, Geforce 7900GTX, Windows 7 Ultimate (64-bit)
time for an upgrade!!!
jcon89 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 06:58 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0