Go Back   Computer Forums > General Computing > Hardware
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 11-14-2005, 09:46 PM   #1
Beta Member
Join Date: Nov 2005
Posts: 5
Default Teamspeak 2 sound echo

I have onboard sound that came with this Gigabyte K8 Triton series and the problem is when I use the push to talk button in teamspeak and somebody else is talking we both get a weird echo. One more very interesting problem, If I hold the push to talk button down, the other people in TS2 can hear everything that goes throught my headset. I installed the driver for the Realtech97 chip that I have and so far nothing. I messed around in Teamspeak an there is nothing that can fix this. Please help me. I are confused...

mdelany08 is offline   Reply With Quote
Old 11-14-2005, 09:49 PM   #2
Golden Master
jac006's Avatar
Join Date: Oct 2004
Posts: 5,810
Send a message via AIM to jac006
Default Re: Teamspeak 2 sound echo

Uninstall teamspeak, reinstall for a fresh program, and then go to settings and adjust so that you have no echo. I'm sorry, but I use ventrilo and that's how I do it. I don't really have expereincewith teamspeak, but I hope this helps!
Macbook Pro and Logitech z5500s. All you really need.
jac006 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 12:23 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0