Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-26-2010, 08:51 PM   #1
Baseband Member
 
Dieter's Avatar
 
Join Date: Apr 2006
Posts: 80
Send a message via AIM to Dieter
Default SupremeFX X-FI

My friend gave me a SupremeFX X-FI that came on his Rampage 2 Mobo. He bought a new video card so there was nothing wrong with it. When I plug it into my computer the blue logo lights up but my computer doesn't recognize it at all. I can't find any drivers for it either. Any help? My computer specs are in my sig with the exception of my OS I have Windows 7 Ultimate.
__________________

__________________
ROG Crosshair V Formula | AMD Phenom II X4 970BE @ 4.2GHz | 8GB(2 x 4GB) G.Skill Ripjawz | ATI Radeon HD 4870X2 | Win 7 64Bit | HAF 912 w/ custom water cooling
Dieter is offline   Reply With Quote
Old 10-26-2010, 09:05 PM   #2
Golden Master
 
Join Date: Mar 2005
Posts: 13,091
Default Re: SupremeFX X-FI

AFAIK, the card he gave you was just the extension card for his board, housing the connectors, and not the actual sound card. That's what I can believe.
__________________

lhuser is offline   Reply With Quote
Old 10-26-2010, 09:09 PM   #3
Golden Master
 
Kage's Avatar
 
Join Date: Nov 2004
Posts: 13,873
Send a message via MSN to Kage
Default Re: SupremeFX X-FI

Apparently from what I've been reading, the X-FI functionality is software only. There is no dedicated X-FI chip, so it can't really be considered as a true X-FI card.
It runs off Soundmax drivers.

http://support.asus.com/download/dow...Language=en-us

Try downloading the drivers from the Audio section. I don't know if your Windows would be 32bit or 64bit, but you can choose that from the drop down

I hope this solves the issue.

*EDIT*
It is meant to be a replacement for an on-board chip, but as a riser instead. So it should offer sound functionality. That I'm not 100% certain of however

Hmm but you may be right. It's meant to go into the black slot on the Asus motherboard, so it may only work with that specific make of motherboard
__________________
Abit IP35 Pro / Q6600 G0 / Zalman 9700 / 8800GTS 640mb / 4x 2GB Corsair XMS / X-FI Xtreme M / 1x 1TB / Antec 900 / Logitech Z-5500 / Samsung 20inch
Kage is offline   Reply With Quote
Old 10-26-2010, 09:20 PM   #4
Baseband Member
 
Dieter's Avatar
 
Join Date: Apr 2006
Posts: 80
Send a message via AIM to Dieter
Default Re: SupremeFX X-FI

That didnt work but what yall are saying about ti not being a real sound card makes sense, no harm in trying though haha. Thanks for the quick responses.
__________________
ROG Crosshair V Formula | AMD Phenom II X4 970BE @ 4.2GHz | 8GB(2 x 4GB) G.Skill Ripjawz | ATI Radeon HD 4870X2 | Win 7 64Bit | HAF 912 w/ custom water cooling
Dieter is offline   Reply With Quote
Old 10-26-2010, 09:23 PM   #5
Golden Master
 
Join Date: Mar 2005
Posts: 13,091
Default Re: SupremeFX X-FI

Normally, you would have had a notification about having the card recognized. Looks like I can confirm what I believed. Smart move ASUS...sucks hard...
lhuser is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 09:25 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0