Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-20-2007, 11:20 PM   #1
In Runtime
 
Join Date: May 2005
Location: C
Posts: 401
Default Still low FPS?!

After just buying my new ATI Radeon X1300 Pro 256 MB DDR2 video card, I'm wondering why I'm getting very nice FPS one second, then it drops, then it's back to normal, repeat...repeat. I'm assuming this is due to my 512 MB RAM? I'm thinking I need a RAM upgrade perhaps?
__________________

Marshillboy is offline   Reply With Quote
Old 02-20-2007, 11:43 PM   #2
Baseband Member
 
Join Date: Jul 2006
Posts: 58
Default Re: Still low FPS?!

In what game? It could be your RAM, but the X1300 is not THAT great of a card either.
__________________

Lightning_Rider is offline   Reply With Quote
Old 02-20-2007, 11:51 PM   #3
In Runtime
 
Join Date: May 2005
Location: C
Posts: 401
Default Re: Still low FPS?!

BF1942. Granted, the X1300 isn't supreme, but it's the best I'm going to get for a budget AGP card. Not PCI-E mind you.
Marshillboy is offline   Reply With Quote
Old 02-21-2007, 01:01 AM   #4
Daemon Poster
 
Join Date: Sep 2005
Posts: 1,027
Default Re: Still low FPS?!

Well i'm no expert on ATi cards, so i can't really help like that....it shouldn't be your RAM, BF1942 isn't a demanding game, and from what i know that card should handle it, what is your CPU/Mobo?

Matt
Mattyl110792 is offline   Reply With Quote
Old 02-21-2007, 04:32 AM   #5
In Runtime
 
Join Date: May 2005
Location: C
Posts: 401
Default Re: Still low FPS?!

CPU is a P4 2.6ghz northwood perhaps. Motherboard is a Biostar U8668 V4/5.
Marshillboy is offline   Reply With Quote
Old 02-21-2007, 05:08 AM   #6
BSOD
 
Jenox's Avatar
 
Join Date: Feb 2007
Posts: 1,156
Default Re: Still low FPS?!

Update the drivers.
Jenox is offline   Reply With Quote
Old 02-21-2007, 09:47 AM   #7
Golden Master
 
mammikoura's Avatar
 
Join Date: Jul 2005
Posts: 7,459
Send a message via MSN to mammikoura
Default Re: Still low FPS?!

and try reinstalling the game.
__________________
0_o
mammikoura is offline   Reply With Quote
Old 02-21-2007, 11:51 AM   #8
In Runtime
 
medabomb2000's Avatar
 
Join Date: Jun 2005
Posts: 271
Send a message via AIM to medabomb2000
Default Re: Still low FPS?!

what you also might want to do, is lower the graphical settings within the game so it doesnt use that many resources from your computer.
__________________
PSU:OCZ 600W modular - Mobo:ASUS P8Z68-V PRO - Processor:Intel Core i7-2600K - CPU Coolant:ZALMAN CNPS11X Extreme - Memory:CORSAIR Vengeance 8GB DDR3 1866 - Hard Drive:4.0 TB [2]Seagate Barracuda XT 7200 RPM SATA 6.0Gb/s - Video Card:NVIDIA GeForce 7950 GT 512mb - DVD Drives:Sony 18x DVD+/- DL Burner and Samsung 18x DVD+/- DL Burner - OS: Windows 7 Ultimate 64-bit
medabomb2000 is offline   Reply With Quote
Old 02-21-2007, 01:17 PM   #9
In Runtime
 
Join Date: May 2005
Location: C
Posts: 401
Default Re: Still low FPS?!

Quote:
Originally Posted by Jenox
Update the drivers.
You mean motherboard chipset drivers? I already did that less than a month ago...
__________________

Marshillboy is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 06:13 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0