Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-23-2009, 08:32 PM   #1
Golden Master
 
superman22x's Avatar
 
Join Date: May 2006
Posts: 7,903
Send a message via MSN to superman22x Send a message via Yahoo to superman22x
Default Speakers went bad on me... Need new ones 5.1

I have Logitech Z-640s and they just went out on me I think. At first it was the right front wouldnt work but if I wiggled the cable they sometimes would, but it got worse over time... Then the left side just went too, and I can't get them both back on. The rear speakers sound all distorted too... So, need some recommendations for new ones. Looking to spend around $40-50... I'm in a college dorm, so it doesnt need to be loud either.
Thanks!
__________________

__________________
“Adults are just obsolete children and the hell with them.” - Dr. Suess
superman22x is offline   Reply With Quote
Old 08-23-2009, 08:45 PM   #2
Daemon Poster
 
winslow33's Avatar
 
Join Date: Jul 2009
Posts: 861
Default Re: Speakers went bad on me... Need new ones 5.1

Not sure if you'r handy with electronics or wiring, but you could give a shot at fixing them.. saves the $40-50 and keeps it in your wallet. All you need is pliers, tape, and a screwdriver. lol.
__________________

winslow33 is offline   Reply With Quote
Old 08-23-2009, 08:47 PM   #3
Golden Master
 
superman22x's Avatar
 
Join Date: May 2006
Posts: 7,903
Send a message via MSN to superman22x Send a message via Yahoo to superman22x
Default Re: Speakers went bad on me... Need new ones 5.1

I opened them up, and it's little wires super-glued onto the board... I have a screwdriver and duct tape, and access to pliers, but I think I would need a soldering iron...
__________________
“Adults are just obsolete children and the hell with them.” - Dr. Suess
superman22x is offline   Reply With Quote
Old 08-23-2009, 08:50 PM   #4
Fully Optimized
 
FlightSimBoy's Avatar
 
Join Date: Jun 2007
Posts: 2,114
Send a message via AIM to FlightSimBoy
Default Re: Speakers went bad on me... Need new ones 5.1

Cheapest 5.1 on Newegg: http://www.newegg.com/Product/Produc...82E16836708009 Never heard of that brand before, and so far there are no reviews. 26 watts RMS.
__________________
My Computer: eMachines T5226 - Intel Pentium D Dual Core @ 3 GHz - Diamond Viper Radeon HD3870 OC Edition with 1 GB GDDR3 VRAM - 4 GB PQi Turbo DDR2-533 RAM - Corsair 650W PSU with 52A on single rail - TSSTcorp DVD-DL+-RW combo drive - Lite-on 52x CD-RW burner - Creative SoundBlaster X-Fi XtremeGamer - Logitech z5300e speakers - WinFast TV Tuner - Vista Ultimate 64-Bit. eBay name: Flightsimboy304
FlightSimBoy is offline   Reply With Quote
Old 08-23-2009, 08:53 PM   #5
Fully Optimized
 
wol-va-rine's Avatar
 
Join Date: Feb 2007
Posts: 2,104
Default Re: Speakers went bad on me... Need new ones 5.1

I would check craigslist, someone always seems to be selling some Logitech speakers cheap like old X-540s, usually around $40...
__________________
MY INTARDNET BEAST ■ Antec 300 ■ Q6600 B3, 2.8GHz @ 1.325v ■ MSI X48C Platinum ■ Kingwin XT-1264 ■ Visiontek HD 4870 512MB ■ 4x1GB Transcend aXeRam DDR3-1800 @ 1400MHz ■ WD Raptor (160GB) ■ Western Digital (250GB) ■ Samsung (640GB) ■ Seagate (500GB) ■ WD Caviar Green (1TB) ■ OCZ ProXStream 1kw ■ Sound Blaster X-Fi Platinum ■ JVC HA RX900 ■

ME ■ I am bald and my head is lumpy...fear me ■
wol-va-rine is offline   Reply With Quote
Old 08-23-2009, 09:26 PM   #6
Golden Master
 
superman22x's Avatar
 
Join Date: May 2006
Posts: 7,903
Send a message via MSN to superman22x Send a message via Yahoo to superman22x
Default Re: Speakers went bad on me... Need new ones 5.1

I have no vehicle either... lol. I rigged it up by plugging the rear speakers into the front port and it seems to work. Oh, and moved the rears up front. No rears now though.
__________________
“Adults are just obsolete children and the hell with them.” - Dr. Suess
superman22x is offline   Reply With Quote
Old 08-23-2009, 09:37 PM   #7
Golden Master
 
01001010's Avatar
 
Join Date: Oct 2005
Posts: 7,888
Default Re: Speakers went bad on me... Need new ones 5.1

Why not get a higher quality 2.1 system for the same price?
__________________
Stop the genocide now.
↳ www.savedarfur.org

Send comments, suggestions and criticisms.
↳ 01001010listens@gmail.com
01001010 is offline   Reply With Quote
Old 08-23-2009, 09:40 PM   #8
Fully Optimized
 
Grantofhell's Avatar
 
Join Date: Apr 2009
Posts: 3,762
Default Re: Speakers went bad on me... Need new ones 5.1

WHY not just get some headphones?

( Oh, good to see you back J. Sorry to hear your in China :| )
__________________
RD-PC -//- i7 950 // Evga x58 SLI // 3x2 OCZ PC3-12800 // 2x Evga GTX470 // Corsair HX850 // SilverStone TJ07
Grantofhell is offline   Reply With Quote
Old 08-23-2009, 10:05 PM   #9
Golden Master
 
01001010's Avatar
 
Join Date: Oct 2005
Posts: 7,888
Default Re: Speakers went bad on me... Need new ones 5.1

Quote:
Originally Posted by Grantofhell View Post
WHY not just get some headphones?
I don't think headphones are a good replacement. They're fine for some applications, but I wouldn't be caught using them as my primary system.

Quote:
Originally Posted by Grantofhell View Post
( Oh, good to see you back J. Sorry to hear your in China :| )
Don't get me wrong, China is a great country to visit and explore. It's just under the circumstances on how I arrived here. To sum everything up, someone screwed up my flight reservations. My schedule is currently setup like this -

California -> Hong Kong
Hong Kong -> Japan
Japan -> Hong Kong
Hong Kong -> Mainland China
Mainland China -> Hong Kong
Hong Kong -> California
__________________
Stop the genocide now.
↳ www.savedarfur.org

Send comments, suggestions and criticisms.
↳ 01001010listens@gmail.com
01001010 is offline   Reply With Quote
Old 08-23-2009, 10:43 PM   #10
Golden Master
 
superman22x's Avatar
 
Join Date: May 2006
Posts: 7,903
Send a message via MSN to superman22x Send a message via Yahoo to superman22x
Default Re: Speakers went bad on me... Need new ones 5.1

I like having surround sound a lot... These were good for quite a while. I think I'll just stick with my rigged up 3.1 system, and then for christmas ask for a 5.1 system.

If I were to get a fairly cheap soundcard as well, would that give me any better qaulity through like logitech X-540s?
__________________

__________________
“Adults are just obsolete children and the hell with them.” - Dr. Suess
superman22x is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 07:43 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0