Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-29-2009, 04:19 PM   #1
Baseband Member
 
Join Date: May 2005
Posts: 47
Default Slow External HD 1TB Fantom transfers

Hey! I finally got around to buying an external HD. It's a 1TB Fantom Drive (GFII1000EU). I've been drag and dropping different files, testing out the transfer speeds, and they seem extremely slow for some odd reason. I'm connected through E-Sata. I've also tried USB but it seems to be exactly the same. Makes weird grinding noises when I first transfer files and sometimes through-out it, and I don't exactly know if that's a bad thing or not. I also scanned my computer for any viruses and fixed any reg errors just to make sure it wasn't something stupid. But yah I honestly have no idea why this thing is slow. I tested transfer speeds up against a friend Western Digital, he was using USB and I was using E-Sata, my 1gb file took 10 minutes, his took 45 seconds. Could the drive be damaged? Or could it be because of something on my main HD, slowing transfer speeds down? I've also heard that the NTI Shadow 4 and NTI ninja programs that come with it can slow it down, even though I don't use those at all, just drag and drop. Anyways, all help is very appreciated, thanks!
__________________

DeathDream23 is offline   Reply With Quote
Old 08-29-2009, 04:26 PM   #2
Site Team
 
berry120's Avatar
 
Join Date: Jul 2009
Location: England, UK
Posts: 3,425
Default Re: Slow External HD 1TB Fantom transfers

Hmm, it's possible that your drive is faulty, the grinding noises definitely don't sound good! My advice would be to try it on another machine and try another external drive on your machine to make sure the bottleneck isn't somewhere else.
__________________

berry120 is offline   Reply With Quote
Old 08-29-2009, 04:57 PM   #3
Baseband Member
 
Join Date: May 2005
Posts: 47
Default Re: Slow External HD 1TB Fantom transfers

Its bottlenecking like you said. I just tried it on my dads junky laptop and the damn thing transferred 1gig in like 30 seconds through USB. >.> My comp is pretty good, so could it just be because of the large amount of JUNK on my comp? even though i have 138gigs out of 500 left, or some kind of error/virus?
DeathDream23 is offline   Reply With Quote
Old 08-29-2009, 05:22 PM   #4
Site Team
 
berry120's Avatar
 
Join Date: Jul 2009
Location: England, UK
Posts: 3,425
Default Re: Slow External HD 1TB Fantom transfers

Hmm, is UDMA enabled for the drive? Sounds like it might be running in PIO...
berry120 is offline   Reply With Quote
Old 08-29-2009, 05:28 PM   #5
Baseband Member
 
Join Date: May 2005
Posts: 47
Default Re: Slow External HD 1TB Fantom transfers

Whats UDMA? lol first time ever owning an external HD, and the manual sure didn't say anything at all.
DeathDream23 is offline   Reply With Quote
Old 08-29-2009, 05:35 PM   #6
Site Team
 
berry120's Avatar
 
Join Date: Jul 2009
Location: England, UK
Posts: 3,425
Default Re: Slow External HD 1TB Fantom transfers

This should explain what you need to know: http://www.microsoft.com/whdc/device...e/IDE-DMA.mspx
berry120 is offline   Reply With Quote
Old 08-29-2009, 05:56 PM   #7
Baseband Member
 
Join Date: May 2005
Posts: 47
Default Re: Slow External HD 1TB Fantom transfers

How exactly do I figure out which IDE channel it is? I have 4 secondary and 4 primary lol.
DeathDream23 is offline   Reply With Quote
Old 08-29-2009, 07:14 PM   #8
Site Team
 
berry120's Avatar
 
Join Date: Jul 2009
Location: England, UK
Posts: 3,425
Default Re: Slow External HD 1TB Fantom transfers

Personally I'd set them all to "DMA if available" if they're not already, then try again
berry120 is offline   Reply With Quote
Old 08-29-2009, 08:05 PM   #9
Baseband Member
 
Join Date: May 2005
Posts: 47
Default Re: Slow External HD 1TB Fantom transfers

I've set them all to that and its still slow. But the second one under the secondary IDE channel says transfer mode is set to DMA if available, and the current transfer mode is set to "PIO Mode" even though I switched it back and forth a few times. I've been reading other threads and there is quite a bit on this issue, its really hard to narrow it down but I'm still working at it. I heard it was some kind of XP DMA bug or something. I also may need to edit some reg if I ever figure out what to edit.

I was reading here...

http://forums.dealnews.com/read.php?4,2758543

And the Spotlight indexing thing caught my attention, what exactly is that? They say it can slow down externals.

Just tried terracopy to see what the actual transfer rates are..and omg...3mb's a sec with e-sata. I don't know whats wrong with this thing, maybe it is faulty? =(
DeathDream23 is offline   Reply With Quote
Old 08-30-2009, 03:35 AM   #10
Site Team
 
berry120's Avatar
 
Join Date: Jul 2009
Location: England, UK
Posts: 3,425
Default Re: Slow External HD 1TB Fantom transfers

Hmm, I'm afraid I've never hit this issue personally so beyond this point I can really be of limited assistance.

One thing I would suggest would be to run windows update and make sure all the patches and suchlike are installed, if it IS a well known XP bug then I would've thought Microsoft should've released a patch for it.

Spotlight indexing? Isn't that a mac thing?

At this point what I'd be personally doing would be googling around lots of places (as you have been) to try and find details of the issue - it seems it's a known problem and you're now in a better position to seek help on the issue.

Remember, use system restore / backup the registry before making any changes you're not sure of just in case they do something worse, and you should be fine.

Beyond that I can really only think of reinstalling windows which does seem like a bit overkill for this situation, but then again it's always a possibility if it does come to the worst!
__________________

berry120 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 03:54 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0