Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-26-2010, 02:24 PM   #1
In Runtime
 
Join Date: Jan 2010
Posts: 133
Default Should of went with an Nvidia card....

Ok so i recently built my computer and im somewhat happy with it. The graphics card XFX Radeon 5770 BLOWS! The drivers are so OLD and i cant find the new drivers because its on this asain website.... The problem with my 5770 is i get this gray screen that flickers sometimes or just stays gray whenever i play certain games like AVA. Should of got an gtx 275..
__________________

sina13 is offline   Reply With Quote
Old 03-26-2010, 02:28 PM   #2
Fully Optimized
 
Join Date: Dec 2007
Location: England
Posts: 3,390
Default Re: Should of went with an Nvidia card....

Have you downloaded the correct drivers?
__________________

__________________
Lenovo ThinkPad T410 - i7 620M - 8GB RAM - Crucial M4 120GB SSD - 250GB 2nd drive - Intel HD 3000 GPU - 1440x900 - Windows 7/8
REMENIZ Computers
Remeniz is offline   Reply With Quote
Old 03-26-2010, 02:54 PM   #3
Daemon Poster
 
madanchi's Avatar
 
Join Date: Oct 2008
Posts: 529
Default Re: Should of went with an Nvidia card....

erm something is quite bad there, you sure youve got the latest drivers and have you OCed it? plus why the heck are the drivers on an asian wbsite? dont you know about the official ati/ amd site - http://support.amd.com/us/psearch/Pa...ords=&items=20
__________________
6950 flashed to 6970 Oc:880cpu 1300memory,2x2gb ddr3 1066,phenomII x4 955 3.2ghz,Tuniq hsf,750w psu,1tb f2 32mb 7200rpm,2tb f4 64mb 7200rpm,cyborg V7, cyborg V3, X-fi creative sounfblaster, Audiophile M-audio,Xclio-windtunnel,Tb7300 graphics tablet
madanchi is offline   Reply With Quote
Old 03-26-2010, 03:04 PM   #4
In Runtime
 
Join Date: Jan 2010
Posts: 133
Default Re: Should of went with an Nvidia card....

i went to the link mandachi gave me but which one out of the 3 do i download?
http://support.amd.com/us/psearch/Pa...ords=&items=20
sina13 is offline   Reply With Quote
Old 03-26-2010, 03:14 PM   #5
Daemon Poster
 
madanchi's Avatar
 
Join Date: Oct 2008
Posts: 529
Default Re: Should of went with an Nvidia card....

id go for the full package because then you get the lates control center and the latest drivers i think
__________________
6950 flashed to 6970 Oc:880cpu 1300memory,2x2gb ddr3 1066,phenomII x4 955 3.2ghz,Tuniq hsf,750w psu,1tb f2 32mb 7200rpm,2tb f4 64mb 7200rpm,cyborg V7, cyborg V3, X-fi creative sounfblaster, Audiophile M-audio,Xclio-windtunnel,Tb7300 graphics tablet
madanchi is offline   Reply With Quote
Old 03-26-2010, 03:16 PM   #6
In Runtime
 
Join Date: Aug 2006
Posts: 272
Default Re: Should of went with an Nvidia card....

I'd go here: http://game.amd.com/us-en/drivers_ca...indows-7-64bit

Download the catalyst control center one. (4th download button down, 54mb file size)
__________________
ASUS M4A79XTD EVO | 4gb DDR3 GSkill | 550W Corsair power supply | AMD Phenom II X2 550 Black Edition Callisto 3.1ghz(Unlocked 2 extra cores) | Sapphire 4870 512mb | 500gb Samsung |21.5" 1080p Hdmi Dell monitor| 21.6" Samsung monitor | RAIDMAX Tornado ATX-238WG | Windows 7 Ultimate Signature Edition
CBrooks is offline   Reply With Quote
Old 03-26-2010, 03:22 PM   #7
Daemon Poster
 
madanchi's Avatar
 
Join Date: Oct 2008
Posts: 529
Default Re: Should of went with an Nvidia card....

yeah that has the same exact downlaod its just what ever you prefer to go on OP
__________________
6950 flashed to 6970 Oc:880cpu 1300memory,2x2gb ddr3 1066,phenomII x4 955 3.2ghz,Tuniq hsf,750w psu,1tb f2 32mb 7200rpm,2tb f4 64mb 7200rpm,cyborg V7, cyborg V3, X-fi creative sounfblaster, Audiophile M-audio,Xclio-windtunnel,Tb7300 graphics tablet
madanchi is offline   Reply With Quote
Old 03-26-2010, 03:51 PM   #8
Golden Master
 
worshipme's Avatar
 
Join Date: Oct 2007
Posts: 5,603
Default Re: Should of went with an Nvidia card....

ATi can't sell you common sense...
__________________
AMD Phenom II X4 955 BE @ 4.0GHz + TU120E lapped - MSI 770-CD45 AM3 - 2x2GB OCZ DDR3 1333MHz - Sapphire HD 4870 - Samsung Spinpoint 500GB 7200RPM 16MB cache HDD - Tagan TG600-BZ Piperock - (Currently open test bed) - Windows Vista Home Premium 64bit.
worshipme is offline   Reply With Quote
Old 03-26-2010, 05:48 PM   #9
In Runtime
 
nbrikha's Avatar
 
Join Date: Jan 2010
Posts: 336
Send a message via AIM to nbrikha Send a message via Yahoo to nbrikha
Default Re: Should of went with an Nvidia card....

I didn't get that on my 5770. Though 3D graphics or any kind of flash or java video will randomly lag, then stop, then inadvertently catch up with the audio again after 2 seconds. Ya, a lil disappointed.
__________________
Desktop: AMD Phenom II 840 X4 @ 3.7Ghz // Asus Sabertooth 990FX // CM HAF 932 // XFX HD 5770 // 8GB Corsair Vengeance @1600 + 8GB G.skill Sniper @ 1600mhz (C9) // Cooler Master 600W // Zalman CNPS9900 // Sidewinder x8
Laptop: Dell Vostro 3555 // AMD A6-3400 1.4Ghz x4 w/ 6520 // 500GB HDD // 4GB Ram upgrading to 8GB soon // Backlit Spillproof Keyboard
nbrikha is offline   Reply With Quote
Old 03-26-2010, 07:29 PM   #10
In Runtime
 
Join Date: Jan 2010
Posts: 133
Default Re: Should of went with an Nvidia card....

wow.... why is there so freaking many?! Which one is the BEST and will not get me the gray screen of DEATH!!!
__________________

sina13 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 06:01 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0