Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-23-2009, 11:04 PM   #1
Baseband Member
 
Join Date: May 2009
Posts: 92
Default Sapphire 4830..Im about to send it back

Im about to give up on my Sapphire ATI 4830 and send it back.

I have tried everything I could to get this thing to work. I just get a crappy picture. Lines arent smooth,Text hurts my eyes, I go into settings and put everything at "Quality" instead of performance and it stays the same. I put it on performance it stays the same. I change resolution and it stays the same (other than the icons getting smaller or bigger)

I have all the newest drivers (ATI) downloaded direct from the website.

I even found a post on here saying to try "Driver Cleaner" and running it in safe mode. I did it according to the instructions and it did remove ALOT of stuff that the "Add /Remove programs" didnt.. and then reinstalled the new ATI package dated June 2009 and still nothing.

My PC sees the card in the ATI software, I see the temp so I know its there and I can change the resolution etc. When I do reboot "windows found hardware" shows up. If I click "auto install" it does nothing. It says it cant install it, yet I see it in the hardware tree and CPUID.

I have never had this much trouble with PC drivers or software.

Im about to send it back and get a nvidia card if I cant figure it out. (my last one was nvidia and it plugged in and worked in 5 minutes)
__________________

pitbull30 is offline   Reply With Quote
Old 07-23-2009, 11:06 PM   #2
Omnicide now.
 
foothead's Avatar
 
Join Date: May 2009
Location: My own personal hell
Posts: 10,014
Default Re: Sapphire 4830..Im about to send it back

You have directx 10.1 right?
And the proper resolution/refresh rate and everything are properly configured?
__________________

foothead is offline   Reply With Quote
Old 07-23-2009, 11:10 PM   #3
Fully Optimized
 
Grantofhell's Avatar
 
Join Date: Apr 2009
Posts: 3,762
Default Re: Sapphire 4830..Im about to send it back

I had the same problem with my first 9600GT. Installing drivers would cause a BSOD and the picture was very unclear and had a few green tinted stripes across my screen. I just RMA'd the card and I've been happy ever since. I'd love to see a member go Nvidia, but it would make no sense if you could just RMA the card and get a new one.
__________________
RD-PC -//- i7 950 // Evga x58 SLI // 3x2 OCZ PC3-12800 // 2x Evga GTX470 // Corsair HX850 // SilverStone TJ07
Grantofhell is offline   Reply With Quote
Old 07-23-2009, 11:39 PM   #4
Baseband Member
 
Join Date: May 2009
Posts: 92
Default Re: Sapphire 4830..Im about to send it back

Quote:
Originally Posted by foothead View Post
You have directx 10.1 right?
And the proper resolution/refresh rate and everything are properly configured?
Ive downloaded the directx 10 update just now when you said and rebooted. However when I type "dxdiag" into "run"
it shows me 9.04C (4.09.0000.0904). Still the same pic.

Grant of hell: when i restarted my PC i got a green line accross on the boot screen. Is this what you got?
pitbull30 is offline   Reply With Quote
Old 07-24-2009, 12:01 AM   #5
Fully Optimized
 
Grantofhell's Avatar
 
Join Date: Apr 2009
Posts: 3,762
Default Re: Sapphire 4830..Im about to send it back

Not exactly, mine was just horizontal lines of my display tinted green spaced variably on my monitor. I called up tech and they said the card was DOA. Is your card still under warranty?
__________________
RD-PC -//- i7 950 // Evga x58 SLI // 3x2 OCZ PC3-12800 // 2x Evga GTX470 // Corsair HX850 // SilverStone TJ07
Grantofhell is offline   Reply With Quote
Old 07-24-2009, 12:11 AM   #6
Baseband Member
 
Join Date: May 2009
Posts: 92
Default Re: Sapphire 4830..Im about to send it back

Just got it a few days ago so it should be.

Ive played with it enough so unless someone else has some ideas I am going to send it back and try a different card.

My PC is new so I should have no issues..well im willing to work with alittle issues but this is too much..Several guys on the forum have told me things to try and it always ends up the same..
pitbull30 is offline   Reply With Quote
Old 07-24-2009, 12:13 AM   #7
Omnicide now.
 
foothead's Avatar
 
Join Date: May 2009
Location: My own personal hell
Posts: 10,014
Default Re: Sapphire 4830..Im about to send it back

Get another 4830. You just got a dead card. It happens.

If you want to spend a bit more, the sapphire 4850 is excellent.
foothead is offline   Reply With Quote
Old 07-24-2009, 12:13 AM   #8
Fully Optimized
 
Grantofhell's Avatar
 
Join Date: Apr 2009
Posts: 3,762
Default Re: Sapphire 4830..Im about to send it back

I can guarantee you right now the card is DOA. Or defective, but that still falls under "DOA". RMA it for the same card or try a different card. The Nvidia GTS 250 is a great all-around card right now.
__________________
RD-PC -//- i7 950 // Evga x58 SLI // 3x2 OCZ PC3-12800 // 2x Evga GTX470 // Corsair HX850 // SilverStone TJ07
Grantofhell is offline   Reply With Quote
Old 07-24-2009, 12:17 AM   #9
Fully Optimized
 
MooseMan's Avatar
 
Join Date: Nov 2005
Location: United States
Posts: 2,627
Send a message via AIM to MooseMan
Default Re: Sapphire 4830..Im about to send it back

well it sounds like you have done everything right. Before you go ahead and send it back, make sure you have a secure connection at both the video card and the monitor. if thats all squared away then I would probably call an RMA on it.

I personally prefer Nvidia as well, I've had issues with all of my ATi products.
__________________
.::The top folder on the CF F@H team::.
http://fah-web.stanford.edu/cgi-bin/...&teamnum=42655
MooseMan is offline   Reply With Quote
Old 07-24-2009, 12:20 AM   #10
Omnicide now.
 
foothead's Avatar
 
Join Date: May 2009
Location: My own personal hell
Posts: 10,014
Default Re: Sapphire 4830..Im about to send it back

Meh.
ATI!!!!!
Where'd you buy from. If its newegg, they will make you pay a restock fee to get a dfferent card even if its DOA.
__________________

foothead is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 02:44 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0