Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-05-2011, 04:36 PM   #1
Beta Member
 
Join Date: May 2011
Posts: 4
Default RAM issue

I have recently built my self a computer that came with 4GB of RAM. My PC is only reading 3.1GB and i dont know why its not reading the whole 4GB. Can anyone explain to me why its only reading 3.1GB when i have 4 installed, or how i could fix this. Thanks
__________________

Coppola21 is offline   Reply With Quote
Old 05-05-2011, 04:38 PM   #2
Fully Optimized
 
~Darkseeker~'s Avatar
 
Join Date: Jan 2010
Location: Welwyn Garden City, United Kingdom
Posts: 2,494
Default Re: RAM issue

What OS Is installed?

a 32-bit OS will only see around 3GB. Win7 will show the full amount but say something like (3.75GB Usable).
__________________

__________________
EVGA SLI Micro Z68 // Intel i5-2500k @ 4.4GHz // 8GB Corsair Vengeance 1866MHz // Overclocked ASUS GTX 660 Ti // Corsair Carbide SPEC-03 // Kingston Hyper-X 120GB // 2TB WD Green + 500GB WD Black
#JC4PM
~Darkseeker~ is offline   Reply With Quote
Old 05-05-2011, 04:42 PM   #3
Beta Member
 
Join Date: May 2011
Posts: 4
Default Re: RAM issue

im running windows xp 32-bit. so i would have to use windows 7 to see my full amount?
Coppola21 is offline   Reply With Quote
Old 05-05-2011, 04:54 PM   #4
Fully Optimized
 
~Darkseeker~'s Avatar
 
Join Date: Jan 2010
Location: Welwyn Garden City, United Kingdom
Posts: 2,494
Default Re: RAM issue

To USE your full amount, you would need a 64-bit operating system. 32-bit can usually only see around 3GB to 3.25GB. Windows 7 can SEE all of it and show it to you, but still only x64 OSes will use the full 4GB.
__________________
EVGA SLI Micro Z68 // Intel i5-2500k @ 4.4GHz // 8GB Corsair Vengeance 1866MHz // Overclocked ASUS GTX 660 Ti // Corsair Carbide SPEC-03 // Kingston Hyper-X 120GB // 2TB WD Green + 500GB WD Black
#JC4PM
~Darkseeker~ is offline   Reply With Quote
Old 05-05-2011, 04:56 PM   #5
Beta Member
 
Join Date: May 2011
Posts: 4
Default Re: RAM issue

ok so i would need windows xp running 64 bit? im not a fan of windows 7 id rather stay xp. if i were to run a 64-bit than i should be fine? itll see more than what its seeing now?
Coppola21 is offline   Reply With Quote
Old 05-05-2011, 05:00 PM   #6
Fully Optimized
 
~Darkseeker~'s Avatar
 
Join Date: Jan 2010
Location: Welwyn Garden City, United Kingdom
Posts: 2,494
Default Re: RAM issue

Well you see this is a weird thing. In theory, 32-bit can use UP TO 4GB, but most of them show or less. Theoretically any x64 bit OS would show you up to it's defined limit. E.g.

Windows 7 Ultmate Memory Limits

x86 - Min=1GB Max=4GB
x64 - Min=2GB Max=192GB

Windows XP Professional does come in a x64 architecture, but you'd have to wipe and load to get it to show the full 4GB. And, tbh, since it can use all of your memory, it just cant see it, you probably wouldn't notice much of a difference from all your troubles.
__________________
EVGA SLI Micro Z68 // Intel i5-2500k @ 4.4GHz // 8GB Corsair Vengeance 1866MHz // Overclocked ASUS GTX 660 Ti // Corsair Carbide SPEC-03 // Kingston Hyper-X 120GB // 2TB WD Green + 500GB WD Black
#JC4PM
~Darkseeker~ is offline   Reply With Quote
Old 05-05-2011, 05:02 PM   #7
Beta Member
 
Join Date: May 2011
Posts: 4
Default Re: RAM issue

ahhh icic, so im better off just leaving it? it runs fast for me, its good enough what its at now, i just feel as though i kind of got screwed you know? bought 4GB and its really only using around 3. so i might as well leave it than?
Coppola21 is offline   Reply With Quote
Old 05-05-2011, 05:35 PM   #8
Fully Optimized
 
~Darkseeker~'s Avatar
 
Join Date: Jan 2010
Location: Welwyn Garden City, United Kingdom
Posts: 2,494
Default Re: RAM issue

XP SP1 has a RAM requirement of 64MB i think, so anything you have above 64MB is sitting idle for programs, games and w/e else you need to run (:

it will perform as if it has 4GB RAM, even if it isnt showing it has.
__________________
EVGA SLI Micro Z68 // Intel i5-2500k @ 4.4GHz // 8GB Corsair Vengeance 1866MHz // Overclocked ASUS GTX 660 Ti // Corsair Carbide SPEC-03 // Kingston Hyper-X 120GB // 2TB WD Green + 500GB WD Black
#JC4PM
~Darkseeker~ is offline   Reply With Quote
Old 05-06-2011, 12:08 AM   #9
In Runtime
 
Chipeater's Avatar
 
Join Date: Nov 2010
Posts: 364
Default Re: RAM issue

Quote:
Originally Posted by ~Darkseeker~ View Post
To USE your full amount, you would need a 64-bit operating system. 32-bit can usually only see around 3GB to 3.25GB. Windows 7 can SEE all of it and show it to you, but still only x64 OSes will use the full 4GB.
Windows in 32bit does address 4GB, but you must remember that that includes the RAM on your video display adapter.

4GB motherboard RAM - 512MB Video RAM = 3.5GB motherboard RAM
__________________

Chipeater is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 07:20 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0