Go Back   Computer Forums > General Computing > Hardware
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 04-25-2010, 06:29 PM   #1
Beta Member
Join Date: Apr 2010
Posts: 1
Default problem with sound blaster xfi

hey guys ty for the help in advanced. i just built my first rig. i bought a sound blaster xfi extreme gamer and hooked it up to a evga x58 3way sli. i had problems with it from start. wouldnt recognize it.. when it did after a boot up made my system very unstable. would freeze on me and id have to reboot. brand new system i check everyrhting. all my other hardware is fine. card doesnt seem defective cuz it works..just seems to be a compability problem and i have tried the new drivers and deleted the old ones before i installed the new ones. win 7 system os by the way. if anyone can help ty.

eazycash is offline   Reply With Quote
Old 04-25-2010, 08:03 PM   #2
Omnipotent One
Atomic Rooster's Avatar
Join Date: Apr 2006
Location: USA
Posts: 11,161
Send a message via AIM to Atomic Rooster Send a message via Yahoo to Atomic Rooster
Default Re: problem with sound blaster xfi

Have you gone here and downloaded the correct drivers for your card: Creative Support.

There is a driver available that may help your system recognize the card in Win 7.

Atomic Rooster is offline   Reply With Quote
Old 04-25-2010, 08:43 PM   #3
foothead's Avatar
Join Date: May 2009
Location: Louisiana
Posts: 9,629
Default Re: problem with sound blaster xfi

If the new drivers do not work, I would also try disabling the onboard sound if there is any. I know it's a longshot, but I have seen stuff like this happen befre in W7, and that is what fixed it.
Account no longer active. Contact info available in profile, if anyone cares to reach me.
foothead is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 06:58 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0