Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Closed Thread
 
Thread Tools Search this Thread Display Modes
 
Old 11-08-2005, 03:01 AM   #1
In Runtime
 
Join Date: Jul 2005
Posts: 132
Default Problem with my new power supply?

I just installed a new power supply in my supposedely proprietary Dell Optiplex GX620 and it's acting kinda funny. The actual power supply that I got to replace the stock Dell psu doesn't even fit perfectly into the case, it's actually a bit longer and slimmer but the screws aligned and i was able to attach it without any additional problems. The power supply appears to be working and it is definately giving my video card the extra wattage it desperately needs to perform up to its potential. It's kind of hard to explain or pinpoint exactly what has happened to my computer since I've installed the new psu but it can't be good. Basically, everything just seems a bit laggy(opening and closing applications, even web browsers). Could there be a problem with this new setup?

Here's the power supply that I got to replace the proprietary Dell one.
http://www.newegg.com/Product/Produc...82E16817154015
__________________

fetus is offline  
Old 11-08-2005, 03:50 AM   #2
CJ
In Runtime
 
CJ's Avatar
 
Join Date: May 2004
Posts: 399
Default Re: Problem with my new power supply?

What are your system specs? All I can say is stay away from cheap power supplies. However, the issue may be something else entirely.
__________________

CJ is offline  
Old 11-08-2005, 04:39 AM   #3
In Runtime
 
Join Date: Jul 2005
Posts: 132
Default Re: Problem with my new power supply?

P4 3.4GHZ
Some Foxconn Mobo
1 gig of ram(4x 256 I think)
48x CD-R
CD-RW/DVD Combo Drive
Windows Xp Pro Sp2
6800GT nVidia GeForce
fetus is offline  
Old 11-08-2005, 04:27 PM   #4
Golden Master
 
joxley1990's Avatar
 
Join Date: Oct 2005
Posts: 7,846
Send a message via AIM to joxley1990 Send a message via MSN to joxley1990
Default Re: Problem with my new power supply?

Is it in a dell case?
joxley1990 is offline  
Old 11-08-2005, 05:25 PM   #5
Golden Master
 
Join Date: Mar 2005
Posts: 13,091
Default Re: Problem with my new power supply?

you can't just upgrade a PSU like this. It doesn't really fit because their case is way too small. Second, Dell made their special designed PSU for this. It might be an inverted wire from the original that is not inverted in yours that could make this. Also, Dells does everything so you can't upgrade it
lhuser is offline  
Old 11-08-2005, 05:44 PM   #6
In Runtime
 
Speedydowt's Avatar
 
Join Date: Jan 2005
Posts: 402
Default Re: Problem with my new power supply?

yeah what he said ^^ also hate to be stating hte ovious, updated drivers for your new graphics card?
__________________
|Q6600 @ 4ghzs|
Speedydowt is offline  
Old 11-08-2005, 06:36 PM   #7
In Runtime
 
Join Date: Jul 2005
Posts: 132
Default Re: Problem with my new power supply?

Quote:
Originally Posted by lhuser
you can't just upgrade a PSU like this. It doesn't really fit because their case is way too small. Second, Dell made their special designed PSU for this. It might be an inverted wire from the original that is not inverted in yours that could make this. Also, Dells does everything so you can't upgrade it

So you're saying that one of the wires in the connecter could be of a different wattage than the Dell power supply? So I'm just lucky that it didn't simply fry the power supply and/or the mobo? In that case, do you think it's still relatively safe to do this? Apparently, this other kid who has my exact same computer(Optiplex GX620) with the same case and everything. He put the exact power supply that I just bought into his Dell and it has worked fine for the past month or so.
fetus is offline  
Old 11-17-2006, 03:32 AM   #8
Beta Member
 
Join Date: Nov 2006
Posts: 1
Default Re: Problem with my new power supply?

Fetus....what type of power supply are you using?.....i have a gx620 as well and want to add a high powered video card.....can't seem to find a psu cause dell sux
RotNRol is offline  
Old 11-17-2006, 07:17 AM   #9
Golden Master
 
Join Date: Mar 2005
Posts: 13,091
Default Re: Problem with my new power supply?

Well, the thread is old, so he's probably been solved. For your case, Call Dell and ask if they ship PSUs.

Sooo...*thread closed*
__________________

lhuser is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 06:28 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0