Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-16-2014, 10:29 AM   #1
Baseband Member
 
Join Date: Aug 2005
Posts: 42
Default Printer not recognised

Printer Connection no longer recognised.

Have not connected the printer for a few weeks and have done nothing to the printer or the computer.

Plugged it into the computer and turned on the printer today and a message appeared on the computer:

“USB device not recognized. One of the USB devices attached to this computer has malfunctioned and Windows does not recognise it.”

So the printer is effectively offline and of course will not print from the computer.

Computer: Toshiba Satellite laptop running Windows XP
Printer: Canon Image class MP390

I have 3 USB plug connections on my computer and have plugged the connection cable into each of them with the same result. Up pops the same message each time – “USB device not recognised”. Shutting down the computer and restarting everything makes no difference. Shutting down the printer and restarting it makes no difference.

I do not have anything else connected to my computer except for the internet modem.

The only thing that has occurred in the last few days are the automatic updates of the windows software from Microsoft that occur from time to time . I doubt such updates would result in the computer suddenly failing to recognise and accept the printer connection. In years of use I have never had any issues .

So now I am mystified as to why it was working fine a few weeks ago and now suddenly the computer will not recognise the printer.

The only thing I have not done yet is uninstall the printer connection software and then reinstall again it from the CD . I suspect that is not going to solve the issue.

Can anyone throw any light on this please because I have no clue how to rectify this problem?

Thanks
__________________

Jules2408 is offline   Reply With Quote
Old 04-16-2014, 11:42 AM   #2
Baseband Member
 
Join Date: Aug 2005
Posts: 42
Default Re: Printer not recognised

CORRECTION to the above - running Windows VISTA on the laptop.
__________________

Jules2408 is offline   Reply With Quote
Old 04-16-2014, 12:49 PM   #3
Fully Optimized
 
jmacavali's Avatar
 
Join Date: Jun 2009
Posts: 4,867
Default Re: Printer not recognised

A few idea, not sure if any will work.

Power cycle the printer and laptop and then plug it back in.

Uninstall and reinstall the software and driver. It's possible (however slight) that the updates to Vista broke the driver. It sounds more like a USB issue though than a driver or software issue.

Can you test with any other USB device to see if it works?
__________________
****************************************
Don't take life too seriously -- no one gets out alive. Plus, who wants to arrive to the hereafter in pristine condition wearing a suit and tie?
I want to slide in sideways, worn out, used up, hair a mess, clothes tattered, & screaming, "Whooo! What a ride!"
****************************************
jmacavali is offline   Reply With Quote
Old 04-16-2014, 06:15 PM   #4
The Candyman
 
~mr mixx~'s Avatar
 
Join Date: Jun 2004
Location: USA
Posts: 11,310
Default Re: Printer not recognised

It is possible that some Micro$oft updates screw with some things sometimes. I done a lot of updates one time, and after my computer restarted my sound got screwed up. I had to go to the company web site and download the sound drivers and install them over again to fix it.
__________________
" Let the music move you "
~mr mixx~ is offline   Reply With Quote
Old 04-26-2014, 09:46 AM   #5
Golden Master
 
BK_123's Avatar
 
Join Date: Dec 2009
Location: Australia
Posts: 7,528
Default Re: Printer not recognised

Quote:
Originally Posted by ~mr mixx~ View Post
It is possible that some Micro$oft updates screw with some things sometimes. I done a lot of updates one time, and after my computer restarted my sound got screwed up. I had to go to the company web site and download the sound drivers and install them over again to fix it.
Yeah I've encountered this a few times..
BK_123 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 08:00 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0