Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-19-2009, 09:38 AM   #1
Golden Master
 
dude_se's Avatar
 
Join Date: Nov 2004
Posts: 8,632
Send a message via AIM to dude_se Send a message via MSN to dude_se
Default powers on but dead screen

i said id look at someones computer for them because they said "it doesnt turn on". turns out that was down to a loose cable and it now powers on fine, except the screen is dead, no beeps, and the hdd light is solidly on. everything seems plugged in and as it should be, but i dont know. im no repair whizz.

any ideas?
__________________

__________________
Laptop spec: ASUS X53E, i5 2430m 2.4ghz, 3gb ram, 320gb hdd, intel hd graphics, usb 3.0
dude_se is offline   Reply With Quote
Old 11-19-2009, 10:09 AM   #2
Solid State Member
 
Join Date: Nov 2009
Posts: 12
Default Re: powers on but dead screen

video card or bad monitor I would guess. Maybe try a different monitor, or if it has two monitor outputs try using the other one.
__________________

sp0oK is offline   Reply With Quote
Old 11-19-2009, 10:39 AM   #3
Golden Master
 
dude_se's Avatar
 
Join Date: Nov 2004
Posts: 8,632
Send a message via AIM to dude_se Send a message via MSN to dude_se
Default Re: powers on but dead screen

monitor is fine. i use it every day and just tested it with my laptop.
only had dvi as the other slot and i dont have the right cable
__________________
Laptop spec: ASUS X53E, i5 2430m 2.4ghz, 3gb ram, 320gb hdd, intel hd graphics, usb 3.0
dude_se is offline   Reply With Quote
Old 11-19-2009, 11:16 AM   #4
Baseband Member
 
Keynan's Avatar
 
Join Date: Nov 2009
Location: USA
Posts: 27
Send a message via MSN to Keynan
Default Re: powers on but dead screen

did you make any recent changes to any of the computer hardware inside your case? If you did make sure you plugged in the power connectors completely secure in the right spots.

make sure the video card is seated properly as well and if it requires a power connector then make sure it is also plugged in.

the problem is clearly not the monitor so it must be hardware related
__________________
Education: B.Sc IT
Certifications: CCNA:S, CCNA:R&S, CCENT, Linux+, LPIC-1, CLA, A+, Net+, Sec+, Project+, CIW:WF, CIW:WDS, CIW:JS, CIW:v5DBS
Keynan is offline   Reply With Quote
Old 11-19-2009, 12:12 PM   #5
Golden Master
 
dude_se's Avatar
 
Join Date: Nov 2004
Posts: 8,632
Send a message via AIM to dude_se Send a message via MSN to dude_se
Default Re: powers on but dead screen

as i said its not my pc, so i know little about it. ive taken out the graphics card and put it back in with no luck. not sure if it requires a power connector ... there is a bit on the edge of the card that looks like something can be attatched to it but i have no idea.
__________________
Laptop spec: ASUS X53E, i5 2430m 2.4ghz, 3gb ram, 320gb hdd, intel hd graphics, usb 3.0
dude_se is offline   Reply With Quote
Old 11-19-2009, 01:00 PM   #6
muz
Golden Master
 
muz's Avatar
 
Join Date: Oct 2006
Posts: 6,928
Default Re: powers on but dead screen

Quote:
Originally Posted by dude_se View Post
i said id look at someones computer for them because they said "it doesnt turn on". turns out that was down to a loose cable and it now powers on fine, except the screen is dead, no beeps, and the hdd light is solidly on. everything seems plugged in and as it should be, but i dont know. im no repair whizz.

any ideas?
Unplug all the non essential stuff from the motherboard , the hdd's the dvd drive if the motherboard has onborad graphics take the graphics card out as well and plug the monitor into the onboard graphics
Does it work then ?
__________________
Desktop-AMD Athlon 64 X2 6000+-2GB Elixer DDR2 800 250gb+500gb+500gb+120gb
Laptop-Apple Macbook Pro 13" Intel core i5(2.3ghz) 4gb Ram 320gb hard drive
muz is offline   Reply With Quote
Old 11-19-2009, 07:47 PM   #7
Golden Master
 
dude_se's Avatar
 
Join Date: Nov 2004
Posts: 8,632
Send a message via AIM to dude_se Send a message via MSN to dude_se
Default Re: powers on but dead screen

its a bit late now so ill just try in the morning. dont think it has onboard graphics at all.
ill let you know how i get on.

ive got a spare pci graphics card that i could test in it too
__________________
Laptop spec: ASUS X53E, i5 2430m 2.4ghz, 3gb ram, 320gb hdd, intel hd graphics, usb 3.0
dude_se is offline   Reply With Quote
Old 11-19-2009, 09:06 PM   #8
Fully Optimized
 
dude_56013's Avatar
 
Join Date: Jul 2007
Posts: 4,262
Default Re: powers on but dead screen

Have you cleared the BIOS/CMOS?
dude_56013 is offline   Reply With Quote
Old 11-19-2009, 09:47 PM   #9
Golden Master
 
dude_se's Avatar
 
Join Date: Nov 2004
Posts: 8,632
Send a message via AIM to dude_se Send a message via MSN to dude_se
Default Re: powers on but dead screen

as i said before. its not my pc. i havent done a thing, apart from fixing a loose cable and switching it on
__________________
Laptop spec: ASUS X53E, i5 2430m 2.4ghz, 3gb ram, 320gb hdd, intel hd graphics, usb 3.0
dude_se is offline   Reply With Quote
Old 11-19-2009, 10:05 PM   #10
Fully Optimized
 
Grantofhell's Avatar
 
Join Date: Apr 2009
Posts: 3,762
Default Re: powers on but dead screen

When you get a chance, find the model number of the card so we can have a look and see what it is. Also, make sure the cable on the back of the monitor is plugged all the way.
__________________

__________________
RD-PC -//- i7 950 // Evga x58 SLI // 3x2 OCZ PC3-12800 // 2x Evga GTX470 // Corsair HX850 // SilverStone TJ07
Grantofhell is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 05:29 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0