Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-05-2009, 03:15 PM   #1
TMP
Beta Member
 
Join Date: Sep 2009
Posts: 3
Default Power Supply Unit question?

I recently got a free computer tower. It is pretty old but it has good specs. It did not come with any power cable at all. I have a picture of the model number and so other stuff. I was wondering if you could tell me if the power cord linked below would work. I had one for a EMachines and plugged it in but it made a high pitched whine and nothing worked.

Thanks.



http://www.tigerdirect.com/applicati...=ITD&body=MAIN
__________________

TMP is offline   Reply With Quote
Old 09-05-2009, 03:21 PM   #2
Omnipotent One
 
Atomic Rooster's Avatar
 
Join Date: Apr 2006
Location: USA
Posts: 11,161
Send a message via AIM to Atomic Rooster Send a message via Yahoo to Atomic Rooster
Default Re: Power Supply Unit question?

That cable should work. I would think the other cable may be fine too. The machine in question my be having problems since it did nothing but make a high pitched whine when you tried to start it up.
__________________

Atomic Rooster is offline   Reply With Quote
Old 09-05-2009, 03:28 PM   #3
TMP
Beta Member
 
Join Date: Sep 2009
Posts: 3
Default Re: Power Supply Unit question?

The other cable is 125 watts one. Would that cause a difference?

Stupid me. I forget to plug it in to the motherboard. :P That made the noise go away but the fans only turn on when I turn it off. Then of course it's off so they go off.
TMP is offline   Reply With Quote
Old 09-05-2009, 03:51 PM   #4
Daemon Poster
 
nevermind1534's Avatar
 
Join Date: Oct 2008
Posts: 754
Default Re: Power Supply Unit question?

I have experienced a problem like this before with an emachines, and the PSU, motherboard, one memory module, and the keyboard were dead. All from a failed fan (I think) in the power supply
__________________
Your PC Forums - yourpcforums.org
nevermind1534 is offline   Reply With Quote
Old 09-05-2009, 04:09 PM   #5
TMP
Beta Member
 
Join Date: Sep 2009
Posts: 3
Default Re: Power Supply Unit question?

Should I get a new PSU?
TMP is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 06:23 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0