Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-19-2010, 05:01 PM   #1
Baseband Member
 
mike90t09's Avatar
 
Join Date: Jan 2010
Posts: 58
Send a message via MSN to mike90t09
Default Power Supply Trouble (I think)

I recently finished building my first gaming computer but came across a problem. The system would not turn on at all. I push the power button and the blue LED flickers then goes away. I did some research online and came to two conclusions:
My power supply is bad or
I have a short circuit.

I did the paperclip test on the power supply and it still didn't turn on. So I decided it was bad. I sent it back for a replacement and will get it soon. My question is if I get it back and it still doesn't work what should I do about the short circuit or any other problems you think I might have.

My power supply is a CORSAIR CMPSU-650TX 650W.
My other specs just in case:
AMD Anthlon II X4 620 2.6GHz processor
GIGABYTE MA-GMT785-UD2H motherboard
G.SKILL 4GB (2 x 2GB) DDR3 SDRAM DDR3 1333 (PC3 10600) Dual Channel
XFX ATI Radeon HD 4890 1GB GDDR5

Thanks a bunch!
__________________

mike90t09 is offline   Reply With Quote
Old 01-19-2010, 06:51 PM   #2
Daemon Poster
 
VINMAN46's Avatar
 
Join Date: Feb 2009
Posts: 1,123
Send a message via AIM to VINMAN46
Default Re: Power Supply Trouble (I think)

did you have the standoffs on the case?
__________________

VINMAN46 is offline   Reply With Quote
Old 01-19-2010, 07:03 PM   #3
Fully Optimized
 
cboucher's Avatar
 
Join Date: Jun 2009
Location: USA
Posts: 1,652
Default Re: Power Supply Trouble (I think)

^I was just about to say check under the motherboard and make sure there isn't anything shorting it to the case...
__________________
But I'm trying, Ringo. I'm trying real hard... to be the Shepherd.
cboucher is offline   Reply With Quote
Old 01-19-2010, 07:25 PM   #4
Baseband Member
 
mike90t09's Avatar
 
Join Date: Jan 2010
Posts: 58
Send a message via MSN to mike90t09
Default Re: Power Supply Trouble (I think)

I used the standoffs, the case (Thermaltake SopranoRS VG7000BWS) only came with three standoffs.

Some of the holes were raised up anyway(it looks like a metal hump), that might be it also, when you think about it, it's a stupid concept. But I've read reviews and people have gotten it to work.

Should I just buy more standoffs, or perhaps a better case?
mike90t09 is offline   Reply With Quote
Old 01-19-2010, 07:46 PM   #5
Daemon Poster
 
VINMAN46's Avatar
 
Join Date: Feb 2009
Posts: 1,123
Send a message via AIM to VINMAN46
Default Re: Power Supply Trouble (I think)

i had those prebumps on my mine too i just put electricla tape over them
try building this computer on a piece of cardboard so you can narrow down the problems
VINMAN46 is offline   Reply With Quote
Old 01-19-2010, 07:53 PM   #6
Baseband Member
 
mike90t09's Avatar
 
Join Date: Jan 2010
Posts: 58
Send a message via MSN to mike90t09
Default Re: Power Supply Trouble (I think)

Wow, I didn't even think of electrical tape. That's a really good idea, thank you, I will definitely try that. I am pretty sure that was the problem, those metal prebumbs in my case.
__________________

mike90t09 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 10:17 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0