Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-01-2008, 05:09 PM   #1
Beta Member
 
Join Date: Dec 2008
Posts: 2
Default Power Supply problem, or something else

Lately, when I tried to turn on my pc, it wouldn't happen anything, not even turn on any lights or so on. But after a minute or so, when I pushed the button once again, it would turn on. It worked just fine, no problems at all, I could work with it properly with no problems occuring - this lasted for 3 weeks and some days, I guess. But suddenly, four days ago I tried to turn it on, but wouldn't turn on, not even after 5 minutes or more. I thought this was the Power Supply, so I went to fix it. They changed my Power Supply and it turned on very well. Took it home, turned it on and worked fine. Suddenly, after 20 or 30 minutes, I'm not sure, it turned off itself. I didn't have much time to do anything, becasue it suddenly turned on again. But this time, my monitor didn't turn on. I turned the computer off by holding the power button for three seconds, and then turned it on again, it started but only the green light was on on the computer, the red one wasn't working at all and monitor wasn't on.

What could it be?
__________________

radiator is offline   Reply With Quote
Old 12-01-2008, 05:13 PM   #2
Guru
 
JogaBonito1502's Avatar
 
Join Date: Jan 2008
Location: U.S.
Posts: 7,841
Default Re: Power Supply problem, or something else

It could be a number of things. Could be that the PSU is gone again. I would check that as it's the easiest to replace. The red light I assume is the HDD. Even if it was out you'd still be able to see a picture. Are you running onboard video? If so there are good chances your motherboard went bye-bye. If you have dedicated video, I would check that too by plugging in the VGA/DVI cable to onboard. If you don't have onboard, try to get another video card to test it.
__________________

JogaBonito1502 is offline   Reply With Quote
Old 12-01-2008, 05:21 PM   #3
Beta Member
 
Join Date: Dec 2008
Posts: 2
Default Re: Power Supply problem, or something else

What is onboard video? *blushing*

I resent my pc to the service that changed my Power Supply, and they reinstalled my pc and said it's working fine now. Took it home, switched it on and while I was transfering my saved documents in my computer, it turned off again and then turned on and nothing happened - the red and green light was working. I was worried that maybe the current where my computer was taking the power was the problem, and changed it, but still happened the same. I switched it from UPS thinking maybe it was the UPS doing all this, but still it kept repeating the same problem. Help!
radiator is offline   Reply With Quote
Old 12-01-2008, 05:23 PM   #4
Fully Optimized
 
Join Date: Dec 2007
Location: England
Posts: 3,390
Default Re: Power Supply problem, or something else

Whats the PSU power rating?

I had this problem whan I started out trying to use low power PSU's until they died.
__________________
Lenovo ThinkPad T410 - i7 620M - 8GB RAM - Crucial M4 120GB SSD - 250GB 2nd drive - Intel HD 3000 GPU - 1440x900 - Windows 7/8
REMENIZ Computers
Remeniz is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 03:50 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0