Go Back   Computer Forums > General Computing > Hardware
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 01-27-2011, 08:14 PM   #1
Beta Member
Join Date: Jan 2011
Posts: 1
Default Power doesnt turn on.. Motherboard problem? or PowerSupply problem?

Hi guys.
I dropped my desktop (not that hard) when it wasnt turned on,
and i saw a little spark from the inside of the desktop.
I tried to turn on my desktop, but the green power LED goes off, and
nothing happens. The fan doesnt start... nothing.
i tried disconnecting things one by one. RAMs, Harddrive,Graphic card, even the CD drive.
no changes were made. it was still the same.
However, when i disconnect the motherboard, the LED never went off but still fan doesnt start and nothing happens.
Whats the problem?

tensy is offline   Reply With Quote
Old 01-28-2011, 04:41 AM   #2
foothead's Avatar
Join Date: May 2009
Location: Louisiana
Posts: 9,629
Default Re: Power doesnt turn on.. Motherboard problem? or PowerSupply problem?

Unplug the 24 pin atx plug from the motherboard and jump the green wire to any black one with a paperclip. If the power supply turns on, the motherboard is most likely the problem. If it doesn't, then it's the power supply.
Account no longer active. Contact info available in profile, if anyone cares to reach me.
foothead is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 09:45 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0