Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-30-2008, 01:29 PM   #1
Solid State Member
 
Join Date: Sep 2008
Posts: 13
Default Please help with Sapphire HD4870X2

First of all new to this forum, and hoping someone can be of assistance. I just dropped $3000 on a new tower:
Q9550 Core 2 Quad Processor 2.83 GHZ
4gigs Ram
Sapphire HD 4870X2 2GB DDR5 video card
300gb velociraptor HD
1 Terabite Seagate second HD
DX48BT2 Intel Motherboard

When I got it back from being built it ran fine. Crysis played at 1280X1024 on very high settings. (thats as high as my monitor can handle). A week or 2 later I saw 8.9 drivers so I grabbed them, as the release date was after my build. Every since, Crysis crashes on game exit, Neverwinter nights crashes on any graphics adjustment whatsoever..... as soon as I click apply to save changes I get a black screen (game music still playing in background) then I get colored waves for a bit then the vid card sounds like it tries to reset itself then back to the black screen and music. Eventually after a minute or 2 the computer reboots. I have tried uninstalling and reinstalling 8.7, 8.8, and 8.9 drivers, running ATI uninstall between each one. I have updated to the lates bios and chipset drivers, I have done a fresh windows restore, and tried installing off the video driver disk (FAIL) ATI driver does not install but everything else does. I am at a loss!! Can anyone help before I take a sludge hammer to this piece of crap?

Should add, I am running Windows Vista 32.
__________________

HolyNumber2 is offline   Reply With Quote
Old 09-30-2008, 01:41 PM   #2
Daemon Poster
 
vaio-fx's Avatar
 
Join Date: Jul 2007
Posts: 515
Default Re: Please help with Sapphire HD4870X2

This happened to my mate after he upgraded his drivers on his 4870X2. He just did a format and reinstall of windows and it worked fine. But your saying you already did that, so thats strange.
__________________

__________________
DESKTOP: Custom Build - HAF 932: Microsoft Windows 7 Home Premium 64-Bit / Samsung 2433 24" LCD 1920x1200/ 6144 MB RAM DDR3 1600MHz Corsair Dominator/ XFX GTX 260 XXX Edition 896MB/ Intel Core i7 950 @ 4.01GHz/ 500GB Sata II 7200 RPM & 320GB 7200RPM/ 700W Jeantech Storm Modular PSU
vaio-fx is offline   Reply With Quote
Old 09-30-2008, 01:57 PM   #3
Solid State Member
 
Join Date: Sep 2008
Posts: 13
Default Re: Please help with Sapphire HD4870X2

Yup, first thing I did after the restore was try the driver disk (rather than updated drivers from the site) but can't even successfully install off the disk. Anyone have any reason why that would be? Do I need to have Dirext X installed prior to loading the vid card drivers or anything stupid like that? It manages to install all catalyst drivers, hydrovision etc, but the ati driver fails everytime. Had success installing web drivers if I installed them as separate downloads (driver first then catalyst).
HolyNumber2 is offline   Reply With Quote
Old 09-30-2008, 02:50 PM   #4
Daemon Poster
 
vaio-fx's Avatar
 
Join Date: Jul 2007
Posts: 515
Default Re: Please help with Sapphire HD4870X2

You don't need to install directX as it come with Vista. I can't see why the drivers are not installing though, have you tried installing them manually through device manager? As for the catalyst control center I'm afraid i'm not too familiar with it, I haven't owned a radeon since my old Radeon 9550.
__________________
DESKTOP: Custom Build - HAF 932: Microsoft Windows 7 Home Premium 64-Bit / Samsung 2433 24" LCD 1920x1200/ 6144 MB RAM DDR3 1600MHz Corsair Dominator/ XFX GTX 260 XXX Edition 896MB/ Intel Core i7 950 @ 4.01GHz/ 500GB Sata II 7200 RPM & 320GB 7200RPM/ 700W Jeantech Storm Modular PSU
vaio-fx is offline   Reply With Quote
Old 09-30-2008, 02:52 PM   #5
Golden Master
 
worshipme's Avatar
 
Join Date: Oct 2007
Posts: 5,603
Default Re: Please help with Sapphire HD4870X2

First off, you bought a HD 4870 X2 for 1280x1024??!!!!

I suggest you uninstall CCC and all the ATi drivers. Then reboot in safe mode, and run Driver Cleaner (tick "ATi-display") Then reboot and install the latest drivers.
__________________
AMD Phenom II X4 955 BE @ 4.0GHz + TU120E lapped - MSI 770-CD45 AM3 - 2x2GB OCZ DDR3 1333MHz - Sapphire HD 4870 - Samsung Spinpoint 500GB 7200RPM 16MB cache HDD - Tagan TG600-BZ Piperock - (Currently open test bed) - Windows Vista Home Premium 64bit.
worshipme is offline   Reply With Quote
Old 09-30-2008, 02:57 PM   #6
Solid State Member
 
Join Date: Sep 2008
Posts: 13
Default Re: Please help with Sapphire HD4870X2

Worship Me..... it was a temporary issue (1280X1024) baby steps.... was hard enough to convince the wife to let me spend $3000 on the tower alone.... I figured the monitor I can upgrade anytime....

Second, I saw your suggested post on another forum, prior to you telling me here just now and already copied and pasted and emailed it home to try when I get off work tonight. Thanks again for coming to the rescue again. Any idea how I should try to install the latest drivers again, since the catalyst suite fails me every time????
HolyNumber2 is offline   Reply With Quote
Old 09-30-2008, 03:57 PM   #7
Golden Master
 
worshipme's Avatar
 
Join Date: Oct 2007
Posts: 5,603
Default Re: Please help with Sapphire HD4870X2

Quote:
Any idea how I should try to install the latest drivers again, since the catalyst suite fails me every time????
Are you installing CCC with the driver? If yes, I suggest you download just the driver after having uninstalled CCC of course.

You can use Rivatuner for fan control, overclocking etc.
__________________
AMD Phenom II X4 955 BE @ 4.0GHz + TU120E lapped - MSI 770-CD45 AM3 - 2x2GB OCZ DDR3 1333MHz - Sapphire HD 4870 - Samsung Spinpoint 500GB 7200RPM 16MB cache HDD - Tagan TG600-BZ Piperock - (Currently open test bed) - Windows Vista Home Premium 64bit.
worshipme is offline   Reply With Quote
Old 09-30-2008, 04:48 PM   #8
Solid State Member
 
Join Date: Sep 2008
Posts: 13
Default Re: Please help with Sapphire HD4870X2

I'll give it a go. I also saw on the AMD support site I should be installing DAO as well. I never knew that was part of the ATI drivers, so also not sure what affect this might have been having. I used Driver Genius the last time, to install my ATI driver and that's all it installed was the driver and not the CCC, and I did seem to have better luck (with Crysis....playing and exiting) but still crashed whenever I adjust even the smallest graphics change in Never Winter Nights 2.

that should have been UN-install Dao.

Well here's an update. I tried several attempts to uninstall using driver sweeper to no avail. I still could not update new or old drivers. I did YET ANOTHER full windows restore, and updates, and grabbed latest motherboard updates, and tried 8.9 drivers first (just the driver not all the CCC. installed 3D Mark and ran a test. *CRASH* So I uninstalled and rebooted in safe mode, ran driver sweeper cleaned it all up, rebooted again and tried 8.7 drivers *failure* after successful install (no error messages) the video cards in the device manager would not show installed. Uninstalled drivers, ran driver sweeper again in safe mode, and grabbed the 8.9 drivers from sapphire's site rather than AMD's site. Gave that a go, ran 3d Mark..... *crash*. Uninstalled, ran driver sweeper again in safe mode, tried the 8.8 drivers. Crashed on install to black screen. I waited a while in case it was a screen flicker but no recover. Rebooted and to my amazement, everything installed, CCC and all. No errors. Ran 3d Mark and *crash*. I give up. I am going back to memory express tomorrow and giving them three choices. They replace the card, fix it while I'm there, or they give me a full refund and I'll go buy a Mac!
HolyNumber2 is offline   Reply With Quote
Old 10-01-2008, 07:53 PM   #9
Solid State Member
 
Join Date: Sep 2008
Posts: 13
Default Re: Please help with Sapphire HD4870X2

HMMMMM. Turns out it wasn't a driver issue afterall. Memory Express is looking at it now and her figures it's a motherboard issue. They are awaiting a replacement board, and we'll see from there.
HolyNumber2 is offline   Reply With Quote
Old 10-07-2008, 11:54 AM   #10
Solid State Member
 
Join Date: Sep 2008
Posts: 13
Default Re: Please help with Sapphire HD4870X2

All is better now, NEW Motherboard, and New Video Card. 8.8 Drivers.
__________________

HolyNumber2 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 05:55 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0