Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-12-2011, 04:24 PM   #1
Baseband Member
 
Lurno's Avatar
 
Join Date: Apr 2011
Posts: 25
Default PC won't boot?

Greetings. I'm experiencing a problem with a PC that worked OK up until now. I opened it to see if a new motherboard that I had purchased would fit (Not removing it, just comparing the size, I only removed a cover from the case) and when I cover it again, it won't boot... Not even into bios. Is the board dead? This seems too random to be true, but not a big loss since I was going to replace it anyways... But this is the second time something like this happens to me... Is this normal? I am starting to suspect that the power supply has something to do with this, but I can't detect burning smell or any sound from it (other than the fan).
__________________

Lurno is offline   Reply With Quote
Old 06-12-2011, 04:35 PM   #2
In Runtime
 
Join Date: May 2011
Posts: 330
Default Re: PC won't boot?

Was it plugged in when youtried this? Did you ground yourself and use an antistatic wrist strap? Did the motherboard you were holding touch anything metal?
__________________

krone6 is offline   Reply With Quote
Old 06-12-2011, 04:43 PM   #3
In Runtime
 
Chipeater's Avatar
 
Join Date: Nov 2010
Posts: 364
Default Re: PC won't boot?

I've accidentally hit the switch on the power supply before while handling a computer case. It had me scratching my head for a minute...let's see...cord plugged into mains power outlet...other end of the power cord plugged into power supply...OH!, darn it, I must have switched the power supply off by accident!
Chipeater is offline   Reply With Quote
Old 06-12-2011, 04:51 PM   #4
In Runtime
 
Join Date: May 2011
Posts: 330
Default Re: PC won't boot?

Quote:
Originally Posted by Chipeater View Post
I've accidentally hit the switch on the power supply before while handling a computer case. It had me scratching my head for a minute...let's see...cord plugged into mains power outlet...other end of the power cord plugged into power supply...OH!, darn it, I must have switched the power supply off by accident!
Oh yea, that too. Same as when my video card wouldn't start.. It wasn't plugged in!
krone6 is offline   Reply With Quote
Old 06-12-2011, 04:51 PM   #5
Baseband Member
 
Lurno's Avatar
 
Join Date: Apr 2011
Posts: 25
Default Re: PC won't boot?

Yes, it was plugged in, however, now that you mention grounding... I never ground myself... But I didn't touch anything metallic, nor did the motherboard... I think... But if this is what happened, then the new motherboard is dead as well and the other parts have not even arrived yet... I am very screwed... Very, very screwed. Wait... Is screwed considered a vulgar term? Sorry if it is...
EDIT:Wow, 2 more replies while I typed this. Thanks for the help!
Edit 2: I checked and the power supply lacks switches.
Lurno is offline   Reply With Quote
Old 06-12-2011, 10:51 PM   #6
In Runtime
 
Join Date: May 2011
Posts: 330
Default Re: PC won't boot?

Is the problem still around?
krone6 is offline   Reply With Quote
Old 06-13-2011, 02:34 PM   #7
Baseband Member
 
Lurno's Avatar
 
Join Date: Apr 2011
Posts: 25
Default Re: PC won't boot?

Quote:
Originally Posted by krone6 View Post
Is the problem still around?
[video=youtube;H6OtFKNDPUc]
Lurno is offline   Reply With Quote
Old 06-15-2011, 01:29 PM   #8
Baseband Member
 
Lurno's Avatar
 
Join Date: Apr 2011
Posts: 25
Default Re: PC won't boot?

The older motherboard mysteriously came back to life the moment i was going to replace it. The new processor arrived, but not the ram... yet... I left the motherboard alone for a bit and one of my family members pulled a capacitor off... When I connect it, I expect to see at least spinning fans... But nothing seems to get power. Does this mean that the motherboard is 100% dead or will it work if i just place it back on the pins without soldering and when I get the ram?
EDIT: The ram arrived, it didn't work...
__________________

Lurno is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 10:48 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0