Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-25-2014, 05:15 AM   #1
Solid State Member
 
Join Date: Jan 2014
Posts: 6
Default Packard bell one month old imedia s2870 not working properly

Hi, I bought a packard bell imedia on boxing day for 500! It has worked great since until now... I switch it on and the logo comes up and then the screen goes black with only the mouse to see and the computer does not do anything! I was wondering if you people can help me thanks jamie
__________________

jamie fagan is offline   Reply With Quote
Old 01-25-2014, 06:32 AM   #2
..m.0,0.m..
Site Team
 
iPwn's Avatar
 
Join Date: May 2010
Location: USA
Posts: 3,870
Default Re: Packard bell one month old imedia s2870 not worling properly

Welcome to CF!

There's a few things you can do to clear this up (hopefully)

First, power down and unplug the machine. (If this is a laptop, also remove the battery).
With no power source, press the power button a few times.
Restore power and boot up.
If that fails to resolve the issue, reboot and follow below steps.

When it first comes on (I'm assuming this is Windows 8 by purchase date), press F11 when you see the Packard Bell logo.
This should take you to the Advanced Startup screen.
There should also be a troubleshoot option
Then there should be an Automatic Repair option.
Try running that and hopefully it can unbreak itself

Best of luck
__________________

__________________
Me: You'd think as the dominant species we wouldn't be so effing stupid.
J: We're just intelligent enough to be completely effing stupid.
iPwn is offline   Reply With Quote
Old 01-25-2014, 07:12 AM   #3
Solid State Member
 
Join Date: Jan 2014
Posts: 6
Default Re: Packard bell one month old imedia s2870 not working properly

Thanks for your help!
jamie fagan is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 09:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0