Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-11-2005, 01:12 PM   #1
Baseband Member
 
Join Date: Oct 2005
Posts: 68
Default Omg Omg Omg

Trying to install my damn water cooling and i DROPED MY CPU!!!!!

bent one pin and i put it back and it set right down in the socket...

computer booted up fine and everything ... could there be anything at all wrong with it???
__________________

Tx3kgtman is offline   Reply With Quote
Old 11-11-2005, 01:24 PM   #2
Golden Master
 
ISOwner's Avatar
 
Join Date: Dec 2004
Posts: 12,208
Default Re: Omg Omg Omg

Nope, I don't think so. If it boots up normally, then CPU's working. That was close though because of the sensitivity of microprocessors. Lucky...Good thing you didn't drop it in water. Even if you did, it may still work if you make sure it's completely dry before installing it.
__________________

__________________
*Fact: Microsoft Window's Blue Screen of Death vs Computerforums.org's White Screen of Death. Which is worse?
ISOwner is offline   Reply With Quote
Old 11-11-2005, 01:35 PM   #3
Golden Master
 
alvino's Avatar
 
Join Date: Sep 2004
Posts: 19,967
Send a message via AIM to alvino
Default Re: Omg Omg Omg

If you dropped it in water, definately make sure it dries before you install it. The only way computer parts short circuit because of water is when you turn it on and send a electric current through.
alvino is offline   Reply With Quote
Old 11-12-2005, 07:33 PM   #4
Daemon Poster
 
GeforcebOY's Avatar
 
Join Date: Feb 2004
Posts: 1,251
Default Re: Omg Omg Omg

I did that with a 6800 not good mate, watch out . Ruined two 6800's that way. Most expensive drop of water i have ever seen fall. lol
__________________
AMD FX57 - 2Gb DDR - 200Gb HDD - 512Mb X1800 XTPE - DVD Dual Layer - Creative XFi Fatality FPS - Windows Media Center 2005
3D Mark 05 : 9600
3D Mark 06 : 3800
GeforcebOY is offline   Reply With Quote
Old 11-12-2005, 09:04 PM   #5
Fully Optimized
 
ownage's Avatar
 
Join Date: Oct 2004
Posts: 4,404
Default Re: Omg Omg Omg

Lol
ownage is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 11:42 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0