Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-30-2015, 09:51 AM   #1
In Runtime
 
jarlmaster's Avatar
 
Join Date: Mar 2014
Location: USA
Posts: 473
Default no speakers or headphones are plugged in error

The title is self explanatory but suddenly I've been getting this error and I get no sound out of my laptop, whether it be through the internal speakers or through my set of external speakers. Headphones don't work either. However if I plug the laptop into my tv, I get sound.

I have tried reinstalling the realtek HD audio drivers, adding legacy hardware in device manager, and letting windows reinstall the drivers it feels I need (deleting the high definition audio device in device manager) and restarting but nothing has worked.

My sound drivers/onboard sound has been wonky the last few days anyway so I've ordered a usb to 3.5mm adapter which should solve the problem. I just figured I'd post here and see what you guys think.
__________________

jarlmaster is offline   Reply With Quote
Old 08-30-2015, 12:56 PM   #2
BSOD
 
Join Date: Jul 2015
Location: USA
Posts: 827
Default Re: no speakers or headphones are plugged in error

Quote:
However if I plug the laptop into my tv, I get sound.
Hi! How are you connecting your TV. Are you using HDMI??
I hope you solve your issue! Keep us posted!
Gary!
__________________

donetao is offline   Reply With Quote
Old 08-30-2015, 02:28 PM   #3
In Runtime
 
jarlmaster's Avatar
 
Join Date: Mar 2014
Location: USA
Posts: 473
Default Re: no speakers or headphones are plugged in error

Yes I use HDMI to connect to my tv.
jarlmaster is offline   Reply With Quote
Old 08-30-2015, 04:00 PM   #4
Fully Optimized
 
Celery's Avatar
 
Join Date: Jan 2013
Location: USA
Posts: 3,869
Default Re: no speakers or headphones are plugged in error

Go to your sound device and set it as default. Right click on speaker icon and select playback devices.
__________________
I'm being stalked!
Celery is offline   Reply With Quote
Old 08-31-2015, 10:00 AM   #5
In Runtime
 
jarlmaster's Avatar
 
Join Date: Mar 2014
Location: USA
Posts: 473
Default Re: no speakers or headphones are plugged in error

There is no speaker icon. I am now starting to wonder if there is a driver conflict. I booted up today and my speakers were working (with realtek HD audio showing up) but my wireless adapter wasn't and it didn't show up in device manager. A reboot later and the wireless adapter was once again working but the speakers weren't. Ugh this is so frustrating. Any suggestions?

---------- Post added at 09:00 AM ---------- Previous post was at 08:56 AM ----------

Update. I was looking through MSconfig and saw that under services it says realtek audio service start pending. There is my issue I think. How do I fix that?
jarlmaster is offline   Reply With Quote
Old 08-31-2015, 01:08 PM   #6
Fully Optimized
 
Celery's Avatar
 
Join Date: Jan 2013
Location: USA
Posts: 3,869
Default Re: no speakers or headphones are plugged in error

That makes me wonder if they're trying to use the same interrupts. In that case it'll be the drivers forcing it. I'd try a different version of the drivers.
__________________
I'm being stalked!
Celery is offline   Reply With Quote
Old 08-31-2015, 02:04 PM   #7
Wizard of Wires
 
setishock's Avatar
 
Join Date: Feb 2005
Location: Not sure
Posts: 10,030
Default Re: no speakers or headphones are plugged in error

If it says pending then something might have set it to manual. It should be set to automatic.

DO NOT edit the services from msconfig. Just don't.
Go to the services list and look down the list until you see the service in question. Click on it to highlight it. In the left column you should see how it's set to start up. If it's not running you need to set it to automatic. Double click on the highlighted service and it will open another window. Select automatic from the menu and click save.
Reboot.

It sounds more like a misconfiguration.
setishock is offline   Reply With Quote
Old 08-31-2015, 03:44 PM   #8
In Runtime
 
jarlmaster's Avatar
 
Join Date: Mar 2014
Location: USA
Posts: 473
Default Re: no speakers or headphones are plugged in error

It is set to automatic but under status it says starting... like its frozen. I don't get it. I can't stop it or anything. Bizzare
__________________

jarlmaster is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 04:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0