Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-25-2008, 04:49 PM   #1
Beta Member
 
Join Date: Sep 2008
Posts: 2
Default No Display output Sapphire HD4870

Hi guys hope you can be of some assistance!

I've tried installing my new card today a Sapphire ATI Radeon HD 4870 only to be met by pain and frustration!

I thought i'd make sure everything was in order by installing the PSU, processor, cooler, a ram module and the card before trying to display the BIOS. However, although the fan on the card spins no display appears on the monitor. I've tried the card on a couple of mates PC's to be met with the same problem. This suggests the card could be at fault? Is there anything out of the ordinary that needs to be done installing the card?

Thanks in advance

The rest of the system is as follows.

Intel Core Duo E8500 CPU
Asus motherboard P5Q SKT 775 Intel P45 1600FSB DDR2 ATX
Corsair 4096MB TwinX 8500Dominator C5 DDR2 5-5-5-15 1066Mhz Memory Western Digital 320GB Caviar SATA II 300 7200rpm 16MB cache Hard Disk
Corsair PSU 550W VX550W ATX12V

These all compatible?

Thanks again

Tom
__________________

tomarsawrous is offline   Reply With Quote
Old 09-25-2008, 06:32 PM   #2
Fully Optimized
 
rohan23's Avatar
 
Join Date: Sep 2008
Posts: 4,087
Default Re: No Display output Sapphire HD4870

Hey, I had this problem when I got my 8800. It took me a few hours to get this, though. All you have to do is take the RAM out and just put it in different slots. If it's dual channel, put them side by side. If not, put them next to each other. It worked with me. Good luck!
__________________

rohan23 is offline   Reply With Quote
Old 09-25-2008, 07:29 PM   #3
Fully Optimized
 
_-..zKiLLA..-_'s Avatar
 
Join Date: Nov 2007
Posts: 3,952
Send a message via AIM to _-..zKiLLA..-_
Default Re: No Display output Sapphire HD4870

well if it didn't work in a couple computers then it could be DOA. Are the extra power connectors connected?
__________________
My beast lappy: Acer netbook, 1.6ghz atom dual core, 2gb ddr3
My PSN: Kalikid_420
_-..zKiLLA..-_ is offline   Reply With Quote
Old 09-26-2008, 07:26 AM   #4
Beta Member
 
Join Date: Sep 2008
Posts: 2
Default Re: No Display output Sapphire HD4870

Thanks for the help guys but I think _-..zKiLLA..-_ might be right. We've tried the card with loads of other components and with another card and the ram in the same slot the computer boots up. I've connected both power leads. Think I'm going to send it back today.

Thanks
tomarsawrous is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 10:02 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0