Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-05-2009, 07:28 AM   #1
Solid State Member
 
Join Date: May 2009
Posts: 8
Default No C: drive... Only K: drive

I was having problems with the old drive so I added another drive to copy files onto. Then later, sure enough, the old drive died. So I took it out and am using the new drive. But it doesn't show as C: drive. It shows as K: drive.

How do I fix this without losing all of the data already on this drive? None of my programs will work installed to this K: drive setup. I need this to show as C: drive.

Any thoughts?
__________________

Panda Cat is offline   Reply With Quote
Old 05-05-2009, 08:23 AM   #2
Fully Optimized
 
wol-va-rine's Avatar
 
Join Date: Feb 2007
Posts: 2,104
Default Re: No C: drive... Only K: drive

Quote:
Originally Posted by Panda Cat View Post
I was having problems with the old drive so I added another drive to copy files onto. Then later, sure enough, the old drive died. So I took it out and am using the new drive. But it doesn't show as C: drive. It shows as K: drive.

How do I fix this without losing all of the data already on this drive? None of my programs will work installed to this K: drive setup. I need this to show as C: drive.

Any thoughts?
how was it assigned as the K drive...? did you manually assign it as the K drive in disk management when you added it...?
__________________

__________________
MY INTARDNET BEAST ■ Antec 300 ■ Q6600 B3, 2.8GHz @ 1.325v ■ MSI X48C Platinum ■ Kingwin XT-1264 ■ Visiontek HD 4870 512MB ■ 4x1GB Transcend aXeRam DDR3-1800 @ 1400MHz ■ WD Raptor (160GB) ■ Western Digital (250GB) ■ Samsung (640GB) ■ Seagate (500GB) ■ WD Caviar Green (1TB) ■ OCZ ProXStream 1kw ■ Sound Blaster X-Fi Platinum ■ JVC HA RX900 ■

ME ■ I am bald and my head is lumpy...fear me ■
wol-va-rine is offline   Reply With Quote
Old 05-05-2009, 09:53 AM   #3
Solid State Member
 
Join Date: May 2009
Posts: 8
Default Re: No C: drive... Only K: drive

I have no idea how it was assigned as K: At the time, I was running a 160 gig as C: and 2 DVD/CD drives. I have a card reader plugged into one of the USB ports and a wireless keyboard/mouse plugged into another..... so that makes A:floppy drive, C: first hard drive, D: & E: the two DVD's, F:G:H:J: as the card reader, and K: became the second hard drive when I first installed it as a slave. I think I had formatted that drive in another box some time ago and had never used it for anything. It had (I thought) XP installed as a boot drive. And it still boots... But as K: drive. And there is no other hard drive installed or hooked up right now. Still has all of the stuff above but only one hard drive.

A little about me... some gray hair.. first computer was a Trash 80 back in the day.. got disgusted for a few years, then got back into it with an XT Clone. Lived throught the 286,386,386SX, 486, years.. went to school for "Programing In Basic For Business" at the local night school. Was the only agent in my Real Estate office that had a computer for several years. Then went out on my own, opened my Real Estate office, got too busy to keep up with the changes, called one of the teenagers (I sold him his first computer) to come work on mine. Now I just cobble together a couple of units for my office and home use. Not exactly dumb about computers, but really not up to speed with the latest hardware. And I don't know much about hacking the Registery. Used to write Batch Files to menu drive the programs on Dos machines, but when Windows came out, I dropped out.

I was really hoping there was a way to correct the drive letter thing without having to reformat this unit. Any ideas?

Larry
Panda Cat is offline   Reply With Quote
Old 05-05-2009, 11:13 AM   #4
Solid State Member
 
Rockerz's Avatar
 
Join Date: May 2009
Posts: 17
Default Re: No C: drive... Only K: drive

Open up the Control Panel
Open Administrative Tools >> Computer Management
On the Left Side Pane, Click on disk Management
On the Right Side Pane, Right click and Click on Change Drive Letter and Paths
Rockerz is offline   Reply With Quote
Old 05-05-2009, 11:48 AM   #5
Solid State Member
 
Join Date: May 2009
Posts: 8
Default Re: No C: drive... Only K: drive

Rockerz, thanks for the heads up.

Pitter Patter of little feet as he runs home at lunch time to make these changes......
Panda Cat is offline   Reply With Quote
Old 05-08-2009, 09:24 AM   #6
Solid State Member
 
Join Date: May 2009
Posts: 8
Default Re: No C: drive... Only K: drive

Rockerz, I tried that and it gives me a message that says, "Windows cannot change the drive letter of your system volume or boot volume."

Looks like format is the only way to go. Shhhiiiittttttt.
Panda Cat is offline   Reply With Quote
Old 05-08-2009, 09:25 AM   #7
Golden Master
 
Kage's Avatar
 
Join Date: Nov 2004
Posts: 13,873
Send a message via MSN to Kage
Default Re: No C: drive... Only K: drive

Does it really matter?

The K drive will function the same way as the C. Its just a letter.
__________________
Abit IP35 Pro / Q6600 G0 / Zalman 9700 / 8800GTS 640mb / 4x 2GB Corsair XMS / X-FI Xtreme M / 1x 1TB / Antec 900 / Logitech Z-5500 / Samsung 20inch
Kage is offline   Reply With Quote
Old 05-08-2009, 09:58 AM   #8
Solid State Member
 
Join Date: May 2009
Posts: 8
Default Re: No C: drive... Only K: drive

Kage, Yes it matters. Programs will not work if they can't find certain parts of their code. And they look for that code on the C: drive. If they don't find C:drive, they won't run. That's my problem.
Panda Cat is offline   Reply With Quote
Old 05-08-2009, 11:30 AM   #9
Golden Master
 
Kage's Avatar
 
Join Date: Nov 2004
Posts: 13,873
Send a message via MSN to Kage
Default Re: No C: drive... Only K: drive

But I install programs on my E drive all the time; my secondary drive, and it reads on E, not C.

Surely if you install programs on K, it'll read from K...

I don't get what you've done. You simply copied programs over, and didn't re-install them?
__________________
Abit IP35 Pro / Q6600 G0 / Zalman 9700 / 8800GTS 640mb / 4x 2GB Corsair XMS / X-FI Xtreme M / 1x 1TB / Antec 900 / Logitech Z-5500 / Samsung 20inch
Kage is offline   Reply With Quote
Old 05-08-2009, 11:34 AM   #10
BSOD
 
Join Date: Apr 2009
Posts: 28
Default Re: No C: drive... Only K: drive

check ur cables
__________________

hyperfrog is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 05:28 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0