Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-14-2015, 10:28 AM   #1
Solid State Member
 
Join Date: Mar 2015
Location: United Kingdom
Posts: 8
Default New processor won't work

Hi,

I recently bought an Xeon E5472 processor for my HP xw6400. Whenever i try booting the PC with the processor installed the PC boots but nothing shows on the monitor.

Is this something to do with my BIOS version?

BIOS version: Hewlett-Packard 786D4 v02.18 30/03/2007
Socket: LGA771
__________________

InvalidName is offline   Reply With Quote
Old 04-14-2015, 11:35 AM   #2
Fully Optimized
 
BikerEcho's Avatar
 
Join Date: Feb 2011
Location: Denmark
Posts: 4,013
Default Re: New processor won't work

It might be. Check HP's homepage.
Maybe you need to update the bios.
__________________

__________________
MOBO: Asus Maximus 6 Hero - GPU: Gigabyte GTX 980ti xtreme - CPU: I7-4770K - PSU: Corsair AX760
RAM: Corsair Vantage 2x4GB - SSD: Samsung 840 EVO 512 + LiteOn LCS-256 - Case: NZXT H440
BikerEcho is offline   Reply With Quote
Old 04-14-2015, 12:14 PM   #3
Wizard of Wires
 
setishock's Avatar
 
Join Date: Feb 2005
Location: Not sure
Posts: 10,030
Default Re: New processor won't work

Did the previous CPU chip have onboard graphics? Or you using a video card?
setishock is offline   Reply With Quote
Old 04-14-2015, 12:48 PM   #4
Fully Optimized
 
BikerEcho's Avatar
 
Join Date: Feb 2011
Location: Denmark
Posts: 4,013
Default Re: New processor won't work

If he use onboard graphics, it would be located on the motherboard.
It's the LGA771 socket. So a CPU swap shouldn't do anything about that.

Another tip. Check if the CPU socket have any bent pins.
__________________
MOBO: Asus Maximus 6 Hero - GPU: Gigabyte GTX 980ti xtreme - CPU: I7-4770K - PSU: Corsair AX760
RAM: Corsair Vantage 2x4GB - SSD: Samsung 840 EVO 512 + LiteOn LCS-256 - Case: NZXT H440
BikerEcho is offline   Reply With Quote
Old 04-14-2015, 12:51 PM   #5
Solid State Member
 
Join Date: Mar 2015
Location: United Kingdom
Posts: 8
Default Re: New processor won't work

It doesn't seem to because my old CPU works just fine. I'm using my old CPU now because my new one didn't work.

I will try updating the BIOS but i've heard it can be troublesome.
InvalidName is offline   Reply With Quote
Old 04-14-2015, 01:21 PM   #6
Solid State Member
 
Join Date: Mar 2015
Location: United Kingdom
Posts: 8
Default Re: New processor won't work

I'm really struggling updating my BIOS, it seems a bit advanced.
InvalidName is offline   Reply With Quote
Old 04-14-2015, 01:28 PM   #7
Fully Optimized
 
BikerEcho's Avatar
 
Join Date: Feb 2011
Location: Denmark
Posts: 4,013
Default Re: New processor won't work

Naa, It's not that hard.
Download it to a flash drive. You bios should have an option to flash itself using the USB drive.
DO NOT turn off the computer in that process and make sure you are downloading a BIOS that works on the motherboard. You might permanently fuck up your motherboard.

---------- Post added at 07:28 PM ---------- Previous post was at 07:24 PM ----------

Edit:
Keyword, Might. There are ways to recover it and go back to the stuck BIOS. But it can be a hassle. Just do it right, and you will be fine.
__________________
MOBO: Asus Maximus 6 Hero - GPU: Gigabyte GTX 980ti xtreme - CPU: I7-4770K - PSU: Corsair AX760
RAM: Corsair Vantage 2x4GB - SSD: Samsung 840 EVO 512 + LiteOn LCS-256 - Case: NZXT H440
BikerEcho is offline   Reply With Quote
Old 04-14-2015, 03:11 PM   #8
Fully Optimized
 
Celery's Avatar
 
Join Date: Jan 2013
Location: USA
Posts: 3,871
Default Re: New processor won't work

Xeon CPUs don't have graphic chips?
__________________
I'm being stalked!
Celery is offline   Reply With Quote
Old 04-14-2015, 06:04 PM   #9
Solid State Member
 
Join Date: Mar 2015
Location: United Kingdom
Posts: 8
Default Re: New processor won't work

Thanks a lot Biker I'm gonna research the crap outa' it. You've given me good advice
InvalidName is offline   Reply With Quote
Old 04-15-2015, 04:03 AM   #10
Fully Optimized
 
BikerEcho's Avatar
 
Join Date: Feb 2011
Location: Denmark
Posts: 4,013
Default Re: New processor won't work

glad to help.
__________________

__________________
MOBO: Asus Maximus 6 Hero - GPU: Gigabyte GTX 980ti xtreme - CPU: I7-4770K - PSU: Corsair AX760
RAM: Corsair Vantage 2x4GB - SSD: Samsung 840 EVO 512 + LiteOn LCS-256 - Case: NZXT H440
BikerEcho is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 09:55 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0