Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-20-2010, 11:27 AM   #1
In Runtime
 
mitch0508's Avatar
 
Join Date: Jul 2007
Posts: 113
Default New PC Build Problems

Hi

I have just finished building this spec pc

Intel i7 930
Asus Rampage II Gene motherboard
Nvidia Geforce 9600 GSO
2 x 2gb Kingston DDR3 Ram
320 GB hard drive
550w PSU

I have just plugged the monitor into the graphics card and switched the pc on for the first time and the computer switches on and sounds like it is working but nothing is showing up on the screen

Can anyone please help me with this issue as i really want to use my new pc?

Thanks
__________________

__________________
http://www.spforfree.com - TV and Movies For Free

i7 930 @ 2.8GHz , Asus Rampage II Gene , 4GB DDR3 , Geforce 9600 GSO , 510 Watt PSU , Coolermaster HAF 922
mitch0508 is offline   Reply With Quote
Old 07-20-2010, 11:50 AM   #2
Fully Optimized
 
Join Date: Dec 2007
Location: England
Posts: 3,390
Default Re: New PC Build Problems

Make sure you connect the monitor to the first monitor output and ensure that the graphics card is connected to the PSU, if necessary.
__________________

__________________
Lenovo ThinkPad T410 - i7 620M - 8GB RAM - Crucial M4 120GB SSD - 250GB 2nd drive - Intel HD 3000 GPU - 1440x900 - Windows 7/8
REMENIZ Computers
Remeniz is offline   Reply With Quote
Old 07-20-2010, 11:53 AM   #3
..m.0,0.m..
Site Team
 
iPwn's Avatar
 
Join Date: May 2010
Location: USA
Posts: 3,870
Default Re: New PC Build Problems

Let's start with some trouble shooting steps.

1. I remember the forum about your RAM, so I would take the RAM out and see if you're getting any POST errors (beeping). If you are that's good, the Mobo is working properly. See if it will boot without the RAM at least into the BIOS although I don't think it will.

2. See if the Video card is propely seated. Take it out and see if you get additional POST Errors. As there's no onboard video it's a little hard to trouble shoot the video card, try another video card that you know works.

Get back to us.
__________________
Me: You'd think as the dominant species we wouldn't be so effing stupid.
J: We're just intelligent enough to be completely effing stupid.
iPwn is online now   Reply With Quote
Old 07-20-2010, 12:04 PM   #4
In Runtime
 
mitch0508's Avatar
 
Join Date: Jul 2007
Posts: 113
Default Re: New PC Build Problems

Ok thanks alot but the only problem is it doesnt have a buzzer :/ so i cant tell if it makes any noise or not. Is there any other way to tell?
__________________
http://www.spforfree.com - TV and Movies For Free

i7 930 @ 2.8GHz , Asus Rampage II Gene , 4GB DDR3 , Geforce 9600 GSO , 510 Watt PSU , Coolermaster HAF 922
mitch0508 is offline   Reply With Quote
Old 07-20-2010, 12:30 PM   #5
..m.0,0.m..
Site Team
 
iPwn's Avatar
 
Join Date: May 2010
Location: USA
Posts: 3,870
Default Re: New PC Build Problems

Every motherboard has an onboard speaker for POST errors. If you get one, it will beep.
__________________
Me: You'd think as the dominant species we wouldn't be so effing stupid.
J: We're just intelligent enough to be completely effing stupid.
iPwn is online now   Reply With Quote
Old 07-20-2010, 12:36 PM   #6
In Runtime
 
mitch0508's Avatar
 
Join Date: Jul 2007
Posts: 113
Default Re: New PC Build Problems

It came with one but i lost it :/ i am going to find it now and then i will post back
__________________
http://www.spforfree.com - TV and Movies For Free

i7 930 @ 2.8GHz , Asus Rampage II Gene , 4GB DDR3 , Geforce 9600 GSO , 510 Watt PSU , Coolermaster HAF 922
mitch0508 is offline   Reply With Quote
Old 07-20-2010, 12:58 PM   #7
..m.0,0.m..
Site Team
 
iPwn's Avatar
 
Join Date: May 2010
Location: USA
Posts: 3,870
Default Re: New PC Build Problems

It should be soldered on the board.
__________________
Me: You'd think as the dominant species we wouldn't be so effing stupid.
J: We're just intelligent enough to be completely effing stupid.
iPwn is online now   Reply With Quote
Old 07-20-2010, 01:03 PM   #8
In Runtime
 
mitch0508's Avatar
 
Join Date: Jul 2007
Posts: 113
Default Re: New PC Build Problems

No its not it came seperatly from the board and you plug it in
__________________
http://www.spforfree.com - TV and Movies For Free

i7 930 @ 2.8GHz , Asus Rampage II Gene , 4GB DDR3 , Geforce 9600 GSO , 510 Watt PSU , Coolermaster HAF 922
mitch0508 is offline   Reply With Quote
Old 07-20-2010, 01:05 PM   #9
..m.0,0.m..
Site Team
 
iPwn's Avatar
 
Join Date: May 2010
Location: USA
Posts: 3,870
Default Re: New PC Build Problems

That's pretty old school xD but alright, plug that bad boy in and see if she beeps at ya.
__________________
Me: You'd think as the dominant species we wouldn't be so effing stupid.
J: We're just intelligent enough to be completely effing stupid.
iPwn is online now   Reply With Quote
Old 07-20-2010, 01:11 PM   #10
In Runtime
 
mitch0508's Avatar
 
Join Date: Jul 2007
Posts: 113
Default Re: New PC Build Problems

haha iv kind of lost it :/ is there any other way to do this test?
__________________

__________________
http://www.spforfree.com - TV and Movies For Free

i7 930 @ 2.8GHz , Asus Rampage II Gene , 4GB DDR3 , Geforce 9600 GSO , 510 Watt PSU , Coolermaster HAF 922
mitch0508 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 11:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0