Go Back   Computer Forums > General Computing > Hardware
Join Computer forums Today

Thread Tools Search this Thread Display Modes
Old 05-04-2013, 02:22 PM   #1
Beta Member
Join Date: May 2010
Posts: 2
Default New Computer - Display problems - browser problems..

I have dell monitors that are exactly the same. These things honestly have a mind of their own. I have 2 dvi, 1 hdmi, and no displayport. The first time i turned on the computer it didn't display anything on one of the monitors, so i was trying to figure out what was wrong, but it didn't seem like it was on my end. I switched the monitors and all of a sudden i see the bios display and everything turned on . I setup the monitors and they all worked fine. The 2 dvi cables were setup on the graphics card and the hdmi only worked on the motherboard. A week later i turn on the computer and the displays get messed up and only 2 of them display. I really don't understand what is happening. All 3 monitors displayed everything fine, and now only 2 work. Do i need a display port? I have Radeon HD 7850 ASUS, and i downloaded the latest driver. I also have windows 7! Please help!

Also my browsers keep on crashing. I use firefox, chrome, and IE. They randomly stop responding and im not sure why. I have java and flash installed.
harharimacar is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -5. The time now is 07:14 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0