Go Back   Computer Forums > General Computing > Hardware
Click Here to Login
Join Computer forums Today


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-12-2005, 07:06 AM   #1
Solid State Member
 
Join Date: May 2005
Posts: 8
Default needing help! about my mouse

Sorry I'm new and I don't even know if it is the right forum I am posting to, but my new optical mouse is driving me crazy...

It isn't working (cursor not moving at all). It was working just fine until after a week, it suddenly stopped. I restarted my pc (XP), it moved for a while, then stopped. Well, I have been using no mouse for almost a week now and it isn't easy.

I have the mouse checked on my neighbor (on her computer) and she says it's working alright.

Now, could the PS/2 mouse port just died? I went to check control panel >> mouse >> hardware and it says the device is working properly. What device is it talking about? And it also says that the mouse if plugged in, so the port couldn't die, right?

-------------

Oh yeah, does the drive Intellipoint mouse which I downloaded from Microsoft's site works on all mouse products? Because I uninstalled the old driver and installed Intellipoint and I am scared that when I am buy a new mouse, it wouldn't work.

So sorry for a lot of questions in one and my first post, but I am needing help :[ Thanks in advance.
__________________

jetmo is offline   Reply With Quote
Old 05-12-2005, 07:13 AM   #2
Golden Master
 
Kage's Avatar
 
Join Date: Nov 2004
Posts: 13,873
Send a message via MSN to Kage
Default Re: needing help! about my mouse

I'm not sure about the second question, but you should be able to un-install it and install a new piece of softwre if it causes you problems.

As for the first problem, I've never heard this happen to a PS/2 mouse, only USB. It happened to me on a Microsoft branded optical. It just kept cutting out after a few mintues. Unplugging it and putting it back made it work for another few, then it'd cut out again. Replacing the mouse fixed this.

With PS/2 it could still be the mouse, especially if it is a USB/PS2 mouse which can support both, and is optical, since these would not last as long (wheel mice would last a long time if it wasn't for the muck as there simple).

The weird thing is though, you say it works on your neibours computer? did they leave it in long enough before the problem occurs?...

I would try buying a new mouse since it could be the source of the problem anyway. And no, the PS2 port probably hasn't died, it works for a bit and the mouse stops responding. If its optical, does the light underneath switch off? If this is the case, it's probably the mouse.

Hope this helps
__________________

__________________
Abit IP35 Pro / Q6600 G0 / Zalman 9700 / 8800GTS 640mb / 4x 2GB Corsair XMS / X-FI Xtreme M / 1x 1TB / Antec 900 / Logitech Z-5500 / Samsung 20inch
Kage is offline   Reply With Quote
Old 05-12-2005, 07:23 AM   #3
Solid State Member
 
Join Date: May 2005
Posts: 8
Default Re: needing help! about my mouse

Thanks for the reply. At least reading this makes it all hopeful.

Anyway, yes it is optical, but the light is on, and doesn't even goes off. For the first days after it first stopped, the cursor was moving for a bit then will stop, but then, this time, it's not moving at all.

How do I know if the port died? Because on control panel >> mouse >> hardware it says the mouse is plugged in, so that means the port is still working, right? Or am I wrong?

--------------

By the way, this will be another question and out of topic, but I suddenly hear beeping while typing. It doesn't seem to be from the speakers though. What is this about?
jetmo is offline   Reply With Quote
Old 05-12-2005, 07:28 AM   #4
Golden Master
 
Kage's Avatar
 
Join Date: Nov 2004
Posts: 13,873
Send a message via MSN to Kage
Default Re: needing help! about my mouse

Hmm... this will be from the speaker in your computer case. This type of thing would usually happen for example, if you pressed toomany keys at once, or tried to type too much while restarting the computer... Not while typing in something like Word.

Since the mouse is slowly declining to work though, can yuo possibly borrow your neibours mouse? Test this, and if it does the same, its something more.
If it works though, just replace the mouse.

The fact that the keyboard plugs into the PS2 port too though makes it a bit worrying that its beeping. Try my suggestion though. Does it beep all the time?
__________________
Abit IP35 Pro / Q6600 G0 / Zalman 9700 / 8800GTS 640mb / 4x 2GB Corsair XMS / X-FI Xtreme M / 1x 1TB / Antec 900 / Logitech Z-5500 / Samsung 20inch
Kage is offline   Reply With Quote
Old 05-12-2005, 07:40 AM   #5
Solid State Member
 
Join Date: May 2005
Posts: 8
Default Re: needing help! about my mouse

Thanks a lot, I'll do that :]

I have two mice which works fine on my neighbor's and doesn't work on mine. If the one I borrowed just didn't work, a new USB mouse can do just fine, right?

------------------------------

It kept beeping while typing here. I heard that it is overheating when it beeps (some kind of a warning or something) but I am not very sure about this...
jetmo is offline   Reply With Quote
Old 05-12-2005, 07:57 AM   #6
Golden Master
 
Kage's Avatar
 
Join Date: Nov 2004
Posts: 13,873
Send a message via MSN to Kage
Default Re: needing help! about my mouse

Hmm..bit weird if its over heating as your typing... Don't think it makes the CPU core heat up that much

Hmm in that case, it is your pc. If the one you borrowed doesn't work on yours but does on your neibours. Its your computer, not the mouse, so getting a new mouse won't work.

I don't know much about PS2 drivers. Can anyone help? Sorry
__________________
Abit IP35 Pro / Q6600 G0 / Zalman 9700 / 8800GTS 640mb / 4x 2GB Corsair XMS / X-FI Xtreme M / 1x 1TB / Antec 900 / Logitech Z-5500 / Samsung 20inch
Kage is offline   Reply With Quote
Old 05-13-2005, 01:30 AM   #7
Solid State Member
 
Join Date: May 2005
Posts: 8
Default

You mean it's my computer or just the port? And can I just buy a new USB mouse?

--------

Thanks for helping me out with the pc beeping :'] It stopped and now i know it's not about my computer overheating, hehe.
jetmo is offline   Reply With Quote
Old 05-13-2005, 02:56 AM   #8
In Runtime
 
Windex's Avatar
 
Join Date: Jan 2005
Posts: 153
Default

Very interesting. The mouse at the college did the same thing. It's PS/2 . Would the mouse you have happen to be black?
__________________
Num, num, num. MMMMMM FRUIT!
Windex is offline   Reply With Quote
Old 05-13-2005, 07:50 AM   #9
Golden Master
 
Kage's Avatar
 
Join Date: Nov 2004
Posts: 13,873
Send a message via MSN to Kage
Default Re: needing help! about my mouse

Theres a possibility it could be the port. does your computer have two or just one? try the mouse on another one if so.

Does your keyboard run off PS/2?

If all else fails and updating drivers doesn't work (I'm sorry, I'm not sure on this at all), you could always get a USB mouse (Sorry, I know you asked this before, it confused me) so yeah, this would be a way around it Because if its the PS/2 port itself, there isn't really much you can do about it I don't think

Hope this helps
__________________
Abit IP35 Pro / Q6600 G0 / Zalman 9700 / 8800GTS 640mb / 4x 2GB Corsair XMS / X-FI Xtreme M / 1x 1TB / Antec 900 / Logitech Z-5500 / Samsung 20inch
Kage is offline   Reply With Quote
Old 05-13-2005, 07:59 AM   #10
Solid State Member
 
Join Date: May 2005
Posts: 8
Default Re: needing help! about my mouse

What do you mean by black? You mean, a color? If it is, then the first mouse is black (Genius) and after 4 months, it stopped working.

Even though I think it was too early for this mouse to die, I decided that it is already broken. Well, the same thing happened when I replaced it with a white optical mouse (coincidentally, it's Genius too), but this time it was earlier. Only a week old.

I had them tried on my neighbor's computer and she said they were working just fine.

What bugs me is that is the problem here. I don't know if it is the mice, my whole computer (if you think I need a new one since it's already 4 years old, is that old enough to be replaced?), or just the port. If it is just the port which died, then it couldn't be since on control panel >> mouse >> hardware >> it says the device is working fine and the mouse is plugged in the mouse port. Right? Or not? :[

((Sorry, I had it long :[))
__________________

jetmo is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 06:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.0